Jump to content

Falcon

Members
  • Content Count

    78
  • Joined

  • Last visited

Everything posted by Falcon

  1. Falcon

    Buffer Recovery

    Yay, the magic phrase was finally uttered, PIO. I got that clue early on, when someone mentioned that the CPU usage spikes when the buffer dies. PIO = using CPU to move data around, at very slow speeds. Normally this data-movement is done by the controller. At any rate, Windows hit its infamous problem of decreasing maximum transfer rate, for no apparent reason, without being able to restore the maximum speed via any user interface. Oh, how I love Windows. It tends to create threads this long for such problems. (I'm high as a kite right now so... pardon my rambling. XD) Run this... then go back to device manager, set to PIO mode, then back to DMA. Bam, on the fly, you'll be set to UDMA mode once again, and your burning problems will be no more. FixDMA.reg It tells Windows to quit limiting your disk drives... it writes to the most common location for the ATA controller settings, so it should work. Wonder why this thread went dead before the solution was found though?
  2. Burning at 600K/s, no other drive activity (used Pause to let it recover - ImgBurn is the only program with a Pause, what a great idea!!!), and it never recovers until "Waiting for buffers to recover"... =( This is a laptop I'm working with, and the HDD (UDMA-33) and CD-R (MW-DMA 2) are on the same channel. Crappy design, I know - when the CD drive is locked up, so is the HDD. I can't avoid it... but it does work fine in Nero. Everything else works kinda slow too, as though the CD drive is totally locking up the IDE channel. Is there a way around this? Hell, at any rate, ImgBurn kicks ass. You know how many times I fired up the other program just to burn an image before I knew about ImgBurn? Now I can burn everything!!
  3. Or just go to regedit, hklm/system/currentcontrolset/control/class/{4D36E96A-E325-11CE-BFC1-08002BE10318}/0001 and 0002 and make sure MasterDeviceTimingModeAllowed and SlaveDeviceTimingModeAllowed are both set to FFFFFFFF Which they are. Nothing else was going on... like I said, I "paused" the burning and the HDD light went off (it blinks in time to the CD drive light as well, highly annoying design) and it never picked back up after resuming. If nothing else, maybe I could ask that when the process is paused, it takes the time to refill the buffers? I could create an ISO first, but that would defeat the purpose of using ImgBurn instead of Nero... *shrug* I figure there has to be a better way. I could increase the buffer size - I didn't even know there was that option. I could make a 256mb buffer... hehe. =)
×

Important Information

By using this site, you agree to our Terms of Use.