Jump to content
Sign in to follow this  
rscottdrysdale

2.5.5.0: reading long audio CD on NEC 466 CD-ROM confuses ImgBurn

Recommended Posts

drive: my old friend, the NEC 466 SCSI CD-ROM.

media: a CD with 74..80 minutes of music (around 77 minutes in this case) and more than 9 tracks.

 

EAC can make an image of the disc from the NEC drive without problems.

 

i don't know if this problem occurs because of the hex/decimal track number problem or the disc being > 74 minutes.

 

I 11:08:41 ImgBurn Version 2.5.0.0 started!

I 11:08:41 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 3)

I 11:08:41 Total Physical Memory: 1,014,504 KB - Available: 303,712 KB

I 11:08:41 Initialising SPTI...

I 11:08:41 Searching for SCSI / ATAPI devices...

I 11:08:41 Found 1 CD-ROM and 1 DVD

Share this post


Link to post
Share on other sites

Already fixed this as per your other thread in the 'General' section.

 

It's not actually my bug though, it's a bug in the NEC firmware where it doesn't report values in the format it's supposed to (according to the MMC specs - even v1.0 of them).

Share this post


Link to post
Share on other sites
It's not actually my bug though, it's a bug in the NEC firmware

yeah, but you shouldn't go into "do nothing forever" mode in any case. bad programmer! bad! :)

Share this post


Link to post
Share on other sites

It's not supposed to do nothing forever... the 'found end of disc' thing is where it should quit because it knows there's no more to read.

 

It's probably because the 'end of disc' thing is something to expect in the last track and that's not where it's occurred. It's aborting the current track correctly but then still attempting the ones after it. I don't do a lot of problem drive/disc testing with CD's but I'll fix this for 2.5.1.0.

 

EDIT: Yup that was it and it's fixed now.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.