Jump to content
Sign in to follow this  
jpaulm

'sort files by source list order (*)' failing

Recommended Posts

Hi,

I tried to use

tools -> options -> build -> 'sort files by source list order (*)'

 

option hoping that this would modify the order in which the files were

put in the image to follow exactly the file order I see in the source

list but it has no impact and order is not respected - please can you explain its functionality.

[i guess I have misunderstood option as it is already possible to specify an

order of the files in the sources list itself - moving files up and down

list, which would make 'sort files by source list order (*)' redundant

I do not understand the significance of the '*' either there seems to be no

accompanying note]

 

I am trying to prepare a cd with mp3 files for a player which plays in the

order in which the files are burned as opposed to playing them after an aphanumeric sort.

 

I checked the order in which the files had been written by creating an image from

a burned disk and then displaying files with 'isoinfo -l -i' command which

concurred with the order the mp3 player played them; and this order does not match

order from source file list.

 

Thanks for any advice you have,

Paul

Share this post


Link to post
Share on other sites

They are indeed burned as you order them phisical on disc, but they will show up in explorer and played by any player only in alfanumeric order.

 

Your only option to play it in what order you want is to number them: 001_Name.mp3 ,002_Name.mp3, 003_Name.mp3... and so on. "Name" can be what you want.

Share this post


Link to post
Share on other sites

You're confusing the file system order with the physical order.

 

That option controls the physical order on the disc and the (*) is used to show there's a note in the tooltip when you hover over the option.

 

The files will always be stored alphabetically within the file system, that cannot be changed.

 

If you want files on an mp3 data disc to play in a certain order, give them proper names with the track number at the start (i.e. 01 - first track name.mp3, 02 - second track name.mp3). That's probably how your player plays them - if not from the track number within an ID3 tag that may also be present.

Share this post


Link to post
Share on other sites

Doh, too slow. :D

 

Thanks,

specifically these were the names of the files as specified in the source list;

effectively diverse mp3's I wanted to play in this order without inconvenience of prefixing with

a numeric index (a solution I had adopted successfully before on mp3's where they were all tracks on the same

album with pre-fixed/base name being same for all files )

 

who_morb5_23042010.mp3

who_morb6_28042010.mp3

who_morb7_28042010.mp3

who_mon_morb8_03052010.mp3

whopit_tue1_04052010.mp3

whopit_wed2_04052010.mp3

whopit_thur3_04052010.mp3

whopit_fri4_07052010.mp3

 

order these played on a alpine mp3 changer was

 

whopit_tue1_04052010.mp3

whopit_fri4_07052010.mp3

whopit_thur3_04052010.mp3

whopit_wed2_04052010.mp3

who_mon_morb8_03052010.mp3

who_morb6_28042010.mp3

who_morb7_28042010.mp3

who_morb5_23042010.mp3

 

I tried to understand why alphabetic order was not respected

 

[alphabetical order for above would be

who_mon_morb8_03052010.mp3

who_morb5_23042010.mp3

who_morb6_28042010.mp3

who_morb7_28042010.mp3

whopit_fri4_07052010.mp3

whopit_thur3_04052010.mp3

whopit_tue1_04052010.mp3

whopit_wed2_04052010.mp3

]

 

after burning to a cd, I had written the iso image back from the cd and inspected it with isoinfo command which reported the same

order as the chnager play order - I could not find a mechanism in imgburn itself to inspect the physical order

[./isoinfo.exe -l -i /cygdrive/c/Nobackup.iso]

 

I concluded I just needed to get physical order to be play order I wanted

 

so I tried using the 'sort files by source list order (*)' option but this did not cause the order to change as reported

by isoinfo.

I believe that when I had previously seen the prefix mechanism working this was because physical order generated

by imgburn had coincidentally matched the alphabetic order, as opposed to player automatically playing alphabetically.

 

I was also exploring adding mp3 title/track tags as a mechanism to fix play order, but this is

equally inconvenient to prefixing files.

 

Regards, Paul

Share this post


Link to post
Share on other sites

Use IsoBuster to look at the disc and just sort by LBA.

 

If you're in Standard build mode, have added those files to the 'Source' box, arranged them in the order you want them (physically) and enabled the option in the settings you mentioned in your first post, their starting LBA's should be in that same order.

 

To be fair, an MP3 player should really work by ID3 tags, not file names or physical order. Sure, if there are no tags present then they should work by the file names, but they can't possibly expect a user to have control over file placement, that's insane.

 

If you really need to know how your player works, ask whoever made it which bits of info it uses and in which order.

Share this post


Link to post
Share on other sites

Use IsoBuster to look at the disc and just sort by LBA.

 

If you're in Standard build mode, have added those files to the 'Source' box, arranged them in the order you want them (physically) and enabled the option in the settings you mentioned in your first post, their starting LBA's should be in that same order.

 

To be fair, an MP3 player should really work by ID3 tags, not file names or physical order. Sure, if there are no tags present then they should work by the file names, but they can't possibly expect a user to have control over file placement, that's insane.

 

If you really need to know how your player works, ask whoever made it which bits of info it uses and in which order.

 

Thanks,

I tried ISobuster in fact this lists the files in the same order as isoinfo but following

your comment to look at LBA (Location of extent) these offset addresses, if I interpret them

corrrectly, do show the correct burn order is respected;

so both tools give file list in the order that matches play order

these show an abbreviation of the file names as follows

 

36177343 May 4 2010 [ 68883 00] WHOPIT_2.MP3 = whopit_tue1_04052010.mp3

35571504 May 7 2010 [ 121356 00] WHOPIT_F.MP3 = whopit_fri4_07052010.mp3

35508978 May 4 2010 [ 104017 00] WHOPIT_T.MP3 = whopit_thur3_04052010.mp3

35774521 May 4 2010 [ 86548 00] WHOPIT_W.MP3 = whopit_wed2_04052010.mp3

35514264 May 3 2010 [ 51542 00] WHO_MON_.MP3 = who_mon_morb8_03052010.mp3

35005839 Apr 28 2010 [ 17370 00] WHO_MOR2.MP3 = who_morb6_28042010.mp3

34976715 Apr 28 2010 [ 34463 00] WHO_MOR3.MP3 = who_morb7_28042010.mp3

35015258 Apr 23 2010 [ 272 00] WHO_MORB.MP3 = who_morb5_23042010.mp3

 

[lba is inside square brackets]

play is then based on alphabetic sorting of abbreviated name which does

not match the same alphabetic order as original files (how is abrreviated name derived)

 

nonethless, as you say, it would seem if I prefix the name at the start (which

does not seem to be impacted by 'inaccurate' abbreviation) it will make the play order correct

seems alphabetic order must be correctly expressed in first 7 characters of file name ?

Thanks, Paul

Share this post


Link to post
Share on other sites

What file systems are you using on the disc?

 

'ISO9660 + Joliet' would probably work best.

 

You could even try adjusting the restrictions to allow full length names and ansi characters in the ISO9660 file system, it might make a difference?!

 

Normally, names in the ISO9660 file system are limited to 8.3 characters (i.e. filename.ext).

Share this post


Link to post
Share on other sites

What file systems are you using on the disc?

 

'ISO9660 + Joliet' would probably work best.

 

You could even try adjusting the restrictions to allow full length names and ansi characters in the ISO9660 file system, it might make a difference?!

 

Normally, names in the ISO9660 file system are limited to 8.3 characters (i.e. filename.ext).

 

Thanks,

I had been using the ImgBurn default ISO9660+udf

In advanced->restrictions->ISO9660 I now selected level2 with 2-31 character names this

then gave correct alphanumeric play order in mp3 player.

[player supports joliet, but with ISO9660+joliet I concluded player seems to ignore joliet whilst

ISO9660 still present]

 

Thanks for the advice you gave in resolving this.

 

Regards, Paul

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.