Jump to content
Sign in to follow this  
TechHarmony

Silent crash when adding files to Detail List window

Recommended Posts

Jul 18 2010:

SUBJECT: Silent crash when adding files to Detail List window

 

I have had ImgBurn 2.5.1 silently crash several times over the last few weeks.

 

(silently meaning the ImgBurn window just disappears, and has no user access anymore. But on exploring, it is still listed in the Task Manager, and has info in Process Explorer - i will attach snap of that)

 

The scenario is: I create a Write Files-Folders to Disk task in ImgBurn,

I set the Labels and the burn speed (to 4x for my external Samsung DVDRW),

I open the Disc Layout Editor to drag-drop files and folders,

I burn a disc successfully (using Verbatim mostly), verifies OK,

I reopen the Disc Layout Editor to remove/delete some files/folders, add new files/folders in prep to burn a next and slightly different disc, but still having some similar content. Thus I did not want to quit and restart the program.

 

Crash happens (mostly) when when dragging new or updated files/folders into the Layout Editor list (may have happened when deleting from list also).

I could find no log file of ImgBurn activity. Note that I DO keep the onscreen progress log open while ImgBurn is running. But in these crash instances, the ImgBurn window and the ImgBurn onscreen log window both disappear.

There is nothing in the documents settings\{user}\application data\imgburn folder,

 

Re updating files:

(A) I am NOT updating any files or folders while a disk is being burned.

(B) Sometimes I do want to update files or folders in between my disk 1 and disk 2 creation though.

Since there is no "refresh" on the Layout Editor, I am careful to make sure that anything I have changed on disk (file or folder) is deleted and then re-added to the Layout Editor list screen.

© Question 2: Am I doing this right?

Should I be deleting files that I have changed content of in order for ImgBurn to see the new content, even though the file name has remained the same? And same for folder, sometimes I will change the content of the included folder between first burn and second burn, I have been deleting and re-adding when that is the case, since I can find no button or right-click to force ImgBurn to re-examine that folder content.

 

Further notes:

1.) actual crash was 1:14 local time.

2.) I noticed that a visible user screen for ImgBurn came back on its own! approximately 15 minutes later (I did not double click the startmenu program for it). The logfile of that is attached.

3.) The Settings Events Save Logfile and Append are Checkmarked On. With File Locations having a Log Files entry of: C:\Documents and Settings\{user}\Application Data\ImgBurn\Log Files\ (but there is no data in that folder)

4.) I could not find a way to attach multiple objects, (*since the button for advanced attaching uploader only goes to my profile settings page with no way to attach anything there) so I have put the screen snaps and log into a zip attachment. Hope this is OK)

 

ImgBurn 2.5.1

Windows XP SP3

2 GB RAM

 

Sorry for being so verbose.

Thank you for your assistance.

ImgBurn Crash Files 0718.zip

Edited by TechHarmony

Share this post


Link to post
Share on other sites

Chances are that it's just the fault of the component I'm using to handle the explorer style bit in the top pane.

 

2.5.2.0 is using a newer version so give that a try when I release it.

 

If the application crashes nicely it should prompt you to send an error report to me.

Share this post


Link to post
Share on other sites

HI, Thanks for speedy reply.

 

I guess the program is not crashing/quitting "nicely", since no window or chance to send a crash report ever shows itself to me.

 

The silent crash doesn't happen 100% of time between a disk burn and the file/folder changing set up for burn of disk 2, just sometimes. (I know that intermittent crashes are harder to track :( )

 

Win XP Pro SP3 (forgot to qualify my XP is XP Pro... if that makes any difference)

 

I will keep a lookout for ImgBurn 2.5.2

 

In the meanwhile, at least this is not really a disaster, as I can just re-start ImgBurn and create my disk 2 task from scratch.

 

Thanks.

Edited by TechHarmony

Share this post


Link to post
Share on other sites

Further info which may (or not) be helpful.

 

As you mention the 'Explorer style' toolbar in your reply, I went back and looked at that.

 

When I am adding files, I usually do that by drag and drop from an open folder on my windows desktop, not via the Add Files or Add Folder button.

 

But, when i delete something from a Layout Editor view, about half the time I use the "Delete" keyboard key, and about half the time I use the Red "X" on the Explorer style top toolbar.

Edited by TechHarmony

Share this post


Link to post
Share on other sites

Oh, are you in 'Standard' input mode rather than 'Advanced' ?

 

I've also fixed a D+D bug to do with the drop descriptions so maybe it's that.

Share this post


Link to post
Share on other sites

I am using Advanced file input mode - so that the 'Show Disc Layout Editor' icon/graphic/large-button is in the upper left 'Source' quadrant.

 

I had previouly tried the Standard input mode some while back, but found the size of the list too small and limited for me. SO its been Advanced input mode for me. ;)

 

Yes, since most of my file and folder adding is via drag and drop from a couple of open folder windows, your D&D fix might address that.

 

Screen snap attached. (Now I see that I can add multiple attachments, just one by one... don't know why I missed that before, but oh well... :blush: )

 

Thanks. :)

post-33001-051241000 1279514739.png

Share this post


Link to post
Share on other sites

Not that it matters but you've closed the Explorer pane down.

 

It's the left most button on the toolbar... but you probably already know that :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.