Jump to content
Sign in to follow this  
engine

ImgBurn 2.5.2.0 fails to install for AllUsers

Recommended Posts

Dear forum users,

 

When I am trying to install ImgBurn 2.5.2.0 for AllUsers manually or silently it installs for the current user only. I am using Windows XP SP3. Previous versions installed for AllUsers fine. I am using an AutoIt script to install silently. It doesn't work with ImgBurn version 2.5.2.0 anymore.

 

script.zip

 

Thanks.

Edited by engine

Share this post


Link to post
Share on other sites

Thanks but I found out about this the same day I released 2.5.2.0.

 

It's fixed for 2.5.3.0 - whenever that gets released.

Share this post


Link to post
Share on other sites

Thanks LIGHTNING UK!

 

Can´t you release a version 2.5.2.1 ? Otherwise I will have to wait for version 2.5.3.0

 

Thanks again.

Share this post


Link to post
Share on other sites

I am rolling it out to only 3. I started doing an unattended Windows XP setup about 6 years ago. Just for fun! That's how I ended up learning AutoIt. And that's why I ended up doing all those AutoIt scripts. I did all that just to entertain myself!

 

The problem with the AllUsers setup is that I use limited permission accounts for security reasons. I don't want to switch to an account just to burn a CD or DVD. That's why I use the Pattin-Couffin driver.

 

Thanks.

Share this post


Link to post
Share on other sites

Ok so the stuff you're scripting can be done manually quite easily on those 3 machines. It's just a case of moving the shortcuts to the 'All Users' folder.

 

Personally, I'd stick with SPTI and just use Nero (or Pokiosoft) BurnRights to give yourself permission on the drives.

 

SPTI has special features available to it that the other I/O interfaces can't use.

Share this post


Link to post
Share on other sites

I can code that on the script also. I would have to remove those lines for the next release of ImgBurn. In case it does it right for AllUsers again. I just don't know if it will uninstall those shortcuts.

 

So you recommend select the option to give access rights to SPTI for all users?

 

Thanks.

Share this post


Link to post
Share on other sites

Yes, there's that option... or do as I suggested in my previous post. Use Nero/Poikosoft BurnRights (google for it) to modify the permissions and give all users access to the drives.

Share this post


Link to post
Share on other sites

OK.

 

I updated the AutoIt install script to copy the shortcuts to the AllUsers desktop and program start menu folders. It's as I need it now.

 

Thanks for all your help.

Share this post


Link to post
Share on other sites

I just updated the AutoIt scripts. In case anyone is interested. It installs the shortcuts for AllUsers. It will work with future versions of ImgBurn. Hopefully! Just place the ImgBurn installer in the same path as the scripts. Then run the ImgBurn.au3 script or compile it.

 

Kind regards.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.