Jump to content
Sign in to follow this  
dpolsrod

Remember Copies setting only works in Build settings

Recommended Posts

Hi.

I searched the forum and couldn't find a topic for this specific bug.

I just wanted to let you know that the Remember 'Copies' setting in the Write settings has no effect.

It only remembers 'Copies' if you tick the box in Build settings.

I tried ticking just the box in Write settings, and it did not remember the number of copies.

Then I tried ticking just the box in Build settings, and then it remembered 'Copies' in both Build and Write mode.

I tried this in version 2.5.4.0 and 2.5.5.0 and earlier versions as well, though I can't remember the version numbers.

I also noticed that whenever I tried the various settings, the 'Copies' value in both Write and Build mode were always the same.

From that I assume that they check the same value in the settings, and not their respective settings tab.

 

I might not have explained this too well, but if you have any questions or need more info/testing, feel free to contact me.

Share this post


Link to post
Share on other sites

Actually, it's nothing to do with any of that :)

 

What you're seeing is the result of synchronisation between the different modes.

 

This is where you change 'Copies' in one of them and it changes the other modes to the same value.

 

It just so happens that the Build mode 'Copies' option is being restored first (when the program first loads) and is updating/overwriting Write modes value.

 

Normally they'd be the same value (due to the sync) and thus this problem is never normally visible. You're only saving the value for one mode and that's why they're then out of sync.

 

I'll see what I can do to work around the problem.

Share this post


Link to post
Share on other sites

Great. :)

I just got a bit irritated when it never remembered my 'Copies' even if I had ticked the box in the Write settings.

I didn't even know there was a Remember 'Copies' in Build settings until today.

Since it now remembers my 'Copies', it's not a big deal for me, but I just wanted to let you know. ;)

 

Also, I just want to thank you for an awesome program!

I absolutely love the quotes in the status bar at the Ez-Mode Picker screen. :D

Being a fan of most things British and American, and being a somewhat TV and film buff, I get most of the references.

When I saw a quote from the intro to SuperTed, I laughed hard.

Nice touch. ;)

Edited by dpolsrod

Share this post


Link to post
Share on other sites

This has now been fixed, thanks for reporting it :)

 

Synchronisation of options (so that's more than just the 'Copies' one) between modes no longer takes place when the form is first being shown.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.