Jump to content
Sign in to follow this  
Vytautas

Command Line / documentation error

Recommended Posts

Hi,

 

I'm trying to setup a backup script using ImgBurn and i ran in to a couple of problems.

 

1) The documentation, e.g. the readme file seems to have a error in it. It says that /SRC can specify a folder like this /SRC "C:\DVD_FILES\VIDEO_TS\" <-- taken directly from the readme. However when i specify the folder in this manner it is not added to the burn list. It only appears to work without the postfixed \

 

2) Is there a way to specity more than one source folder on the command line without using an IBB file?

 

Any help greatly appreaciated.

 

Vytautas

Share this post


Link to post
Share on other sites

Sorry, one more question. Is there and option to specify the default value of the message box that pops up when only one folder is selected in build mode?

 

Vytautas

Share this post


Link to post
Share on other sites

1. Although the documentation appears to be wrong, it is actually correct!

 

The path without the trailing backslash is passing the CLI parsing code ok because it looks like a file. The folder is blocked (well, ignored) because it's failing some other check.

 

I'll fix that.

 

2. No, sorry.

 

3. No, sorry. There is now (ready for next release), but only for gui purposes. If you set it in advance, even when you load ImgBurn with CLI parameters it'll still use that value.

I guess I could add an extra cli switch now though and I'm sure that would be the better way of doing it.

Share this post


Link to post
Share on other sites

1. Fixed.

 

2. You can now use the '|' character to seperate multiple entries (files/folders).

 

3. I've added a /rootfolder cli command for this purpose.

Share this post


Link to post
Share on other sites

What is correct now???

 

My imgburn version is 2.0.0.0, 948.736 bytes from 05.08.2006 20:21

 

If I use a batch file with:

imgburn /MODE ISOBUILD /BUILDMODE DEVICE /NOIMAGEDETAILS /SRC "D:\DVD\VIDEO_TS" /DEST N: /LOG test.log /START /CLOSE

everything works fine. With /SRC "D:\DVD\VIDEO_TS\" nothing happens at all!

(The batch file is started within the imgburn path, therefore no path info is necessary for imgburn and logfile)

Share this post


Link to post
Share on other sites
What is correct now???

 

My imgburn version is 2.0.0.0, 948.736 bytes from 05.08.2006 20:21

 

If I use a batch file with:

imgburn /MODE ISOBUILD /BUILDMODE DEVICE /NOIMAGEDETAILS /SRC "D:\DVD\VIDEO_TS" /DEST N: /LOG test.log /START /CLOSE

everything works fine. With /SRC "D:\DVD\VIDEO_TS\" nothing happens at all!

(The batch file is started within the imgburn path, therefore no path info is necessary for imgburn and logfile)

 

There's at least a bit newer version of ImgBurn 2.0.0.0 that can be downloaded from the Mirror 6 (Imgburn.com) site. The file size for that one should be 948,224 bytes. The first mirror (betanews) still has the older version you have.

Share this post


Link to post
Share on other sites

Thank you for your fast work. Look farward to testing the new changes when they get released.

 

Vytautas :D

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.