Jump to content
Sign in to follow this  
jinualex

ImgBurn 'Mode' error

Recommended Posts

I have created and saved a 'project file' with imgburn for burning, with the extension "xxx.ibb". But later when I tried to open that file I can not open it. It is showing an error message that "you're in the wrong 'Mode' for loading an IBB file. Switch to 'Build' mode and then try again". So I switched manually to 'Build' mode and then tried again. But it occuring the same error.

 

I,m using imgburn new version 2.5.7.0. Please help me.

 

ibmode.jpg

Share this post


Link to post
Share on other sites

You switch to 'Build' mode and then click 'File' -> 'Load Project' yeah?

 

If you're attempting to load it from the command line, you need to make sure your command line includes '/MODE BUILD'.

Share this post


Link to post
Share on other sites

Thank you LIGHTNING UK! and,

But I think in the previous version of imgburn the project files could be easily load directly, without changing any mode, by double clicking the IBB file. Doesn't it? I feel so. I request you please devolop the ImgBurn for automatically open the project files without any manual interface. In Nero (My previous application was Nero) its project files can be directly load(open) with a double clicking!

Share this post


Link to post
Share on other sites

I can double click them and it loads them just fine.

 

Uninstall ImgBurn and then reinstall it... see if that fixes the problem.

 

If It doesn't, I'll talk you through some registry stuff to find and fix it.

Share this post


Link to post
Share on other sites

Thank you LIGHTNING UK!

 

I Uninstalled and reinstalled the ImgBurn. But the poblem doesn't fix.

 

If it can fix thru registry editing please tell me how can I fix it.

Share this post


Link to post
Share on other sites

ok well you need to export a couple of registry keys for me to look at.

 

1. HKEY_CLASSES_ROOT\.ibb

2. HKEY_CLASSES_ROOT\ImgBurn.AssocFile.ibb

 

Just select them, then right click and choose 'Export'. Type a name for the file (i.e. 'ibb.reg' and 'ImgBurn.AssocFile.ibb.reg' would make sense) and save them somewhere easily accessible. Then upload both files here - you'll have to use the 'More Reply Options' button to be able to upload them.

Share this post


Link to post
Share on other sites

Ok well that's an easy one but I've no idea how it would have happened.

 

[HKEY_CLASSES_ROOT\.ibb]

@="ImgBurn.AssocFile.ape"

 

The 'default' value should be 'ImgBurn.AssocFile.ibb', not 'ImgBurn.AssocFile.ape'.

 

***BEFORE*** you change it, please just also export the following for me (if they exist)...

 

HKEY_CURRENT_USER\Software\Classes\.ibb

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ibb

Share this post


Link to post
Share on other sites

That's fine if it doesn't, I just wanted to make sure I had everything :)

 

You can go ahead and apply the fix I mentioned in post 8 now.

 

I've tweaked the installer (uninstaller) so that other (the incorrect 'ImgBurn.AssocFile.ape' - and others like it) entry will get removed upon uninstallation of the program. Previously, it would have only removed it if it was the correct 'ImgBurn.AssocFile.ibb' one.

Share this post


Link to post
Share on other sites

Thank You.

Not only there here was also the problem.

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.ibb

 

Now it's OK and fine. Thank you.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.