Jump to content
demattin

ImgBurn Crash after closing (Workaround/Solution)

Recommended Posts

ImgBurn (running on Win7) crashes with a windows-message after exiting the program.

Windows7 error in: nvinit.dll_unloaded

No error message in ImgBurn-log.

 

Referring to:

http://forum.imgburn.com/index.php?showtopic=20943

http://forum.imgburn.com/index.php?showtopic=20912

http://forum.imgburn.com/index.php?showtopic=20687

 

I had the same problem as described in above threads and I have found out a workaround or solution.

 

The problem seems to be in conjunction with the NVidia Optimus driver on notebooks (Nvidia grafic card with Intel onboard grafic card) and the auto-switching-function of the driver.

It actually seems not to work correct with ImageBurn.

I don't know where's the problem and whose "fault" it is. But up to now, ImgBurn ist the only program with this problem to me.

 

To solve the problem, you just have to select a grafic card to work with the program.

This has to be done either by right-click-Context-Menu on the ImgBurn Icon or within the nvidia-settings (In the 3D-settings-section you can define, which program has to be run on which grafics-prozessor).

 

It doesn't matter which card is defined to work with ImgBurn!

ImgBurn works with the Intel-Onboard as well as with the NVida.

Just the automatic switch is the thing, that doesn't work and causes the "exit-bug".

 

If you define the nvidia-card as prefered to work with ImgBurn, there occures a short mode-swtich to the nvidia-card when ImgBurn starts and an automatic reswitch to the onboard grafic. THIS switching is no problem!

I prefer to set the integrated Intel card.

 

My config:

NVida GTX 660M - Driver: 310.70

Intel HD 4000 - Driver 9.17.10.2867

Windows 7pro 64bit

ImgBurn v2.5.7.0

 

greetings,

Martin

 

PS: Had to create a new thread, because to me ist wasn't allowed to post in previous threads.

Edited by demattin

Share this post


Link to post
Share on other sites

I also have this problem. I don't see any setting you are talking about in the Nvidia Control panel to switch between GPU. I also have Intel onboard Video but I don't have it hooked up. I'm strictly using the Nvidia Video card (on desktop computer). Any further help will be appreciated as this problem is driving me nuts.

Edited by Mike89

Share this post


Link to post
Share on other sites

Here's a Screenshot of the Nvidia-Settings ....
It's the german language driver.

post-50235-0-91710700-1361310056_thumb.png

Edited by demattin

Share this post


Link to post
Share on other sites

You made a screenshot of the "global settings" tab in "Manage 3D settings"!
But in your screenshot there's another tab named "program settings" in "Manage 3D settings".

These are the settings I refer to.

Compare both screenshots and you will see what I mean...

Edited by demattin

Share this post


Link to post
Share on other sites

That setting is only there on Laptops where both onboard and video card are wired in together. That's why there would be an option to switch. On Desktops it's completely different.

 

 

NVControlPanel2.jpg

Edited by Mike89

Share this post


Link to post
Share on other sites

After some time with this issue I've come to believe it's an issue with this program. No other program I have show this behavior. For some reason the I7 3770K want's to show the onboard graphics option in Device Manager even though it's using a PCIE Video Card and no drivers are even installed for the onboard graphics. This seems to be what causing this issue with Imgburn (crashing after closing) for some reason and I see no way around it unless something in Imgburn is changed. This problem has been with me from day one after installing the 3770K (and seeing the two video adapters in Device Manager (with no way to remove the onboard entry)

Share this post


Link to post
Share on other sites

and yet i have no problem with my 3770k, i have ati graphics so i would still point my finger at the nvidia gfx drivers

Share this post


Link to post
Share on other sites

Do you both video displays showing in your Device Manager (both Intel onboard and the ATI vid card?

Share this post


Link to post
Share on other sites

post-8-0-57340300-1370495352_thumb.png

 

 

 

nope,have you disabled the onboard gfx in bios?

Share this post


Link to post
Share on other sites

Well looks like you helped my dumb ass fix it. I do not have an option to turn off the onboard video in BIOS. There is an option which one you want to boot first, Onboard, PCIE, or PCI or Auto. Of course I had it set to PCIE (never used Onboard Video and never installed any drivers for it). Then I saw another setting, "IGPU Multi Monitor" and it was set to Enabled. I disabled it and booted back up. Started Imgburn and exited it and no crash! No Onboard Video showing in Device Manager either. Looks like that was it. Thanks for the tip, it's what made me go back into the BIOS again and look.

Edited by Mike89

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.