Jump to content
sayang

File name clash when creating .iso file from files and folders

Recommended Posts

One may require all the files in the paths a/x/b and a/y/b to be copied to a .iso file.

However if there is a common file name, ImgBurn appears to  issue an error message and stops.

 

eg for file name c, a/x/b/c and a/y/b/c seems to result in an ImgBurn failure.

Share this post


Link to post
Share on other sites

2 files with the same name can't end up in the same folder.

 

If it's not obvious how the combination of several source folders will end up in your image, switch to Advanced input mode and use the more visual way of building your disc.

Share this post


Link to post
Share on other sites

They are in different folders:

          a      folder
          |
      ---------
      |         |
      x         y  folder
      |         |
      b        b  folder
      :         :   file
      c        c   file
      :         :   file
 

Share this post


Link to post
Share on other sites

They might be on your hdd but that doesn't mean they're ending up in different folders in the image / on the disc. You're probably just dragging both 'c' folders to the source box yeah? You'd have to 'preserve full pathnames' so that the different parent folders are added to the image to get around the clash.

 

The program wouldn't error out if there wasn't a problem somewhere along the line.

 

Take a screenshot of the error message and also of the main ImgBurn window showing the 'Source' box (ideally in 'Expanded' form).

 

All of this stuff is made much easier/clearer by using Advanced input mode and the Disc Layout Editor window.

Share this post


Link to post
Share on other sites

The advanced tab does not seem to help. I have V2.5.7.

 

A screen sot is attached.

What I thought should happen is files explicitly mentioned (eg Setup.exe)

would appear in the root folder of the CD image whereas the mention

of a folder only, would load all the files in the folder, including the path.

There are two folders: Discmaps\syd15\mapphoto and Discmaps\mel40\mapphoto.

If I delete one, the iso is created without an error message, then mounting it as a CD

does seem to display what I was expecting, with a full path for the folder.

 

post-52765-0-56127100-1378999354_thumb.gif

Share this post


Link to post
Share on other sites

Not the advanced tab, advanced input mode.

 

Click the 'input' menu at the top of the main window and then click advanced.

Share this post


Link to post
Share on other sites

Thanks, no bug!

 

What threw me was that with one path, without a file name attached, listed

in the `non-advanced' source window, that path and all associated files appeared

in the iso image (that is, the mounted CD). So that seemed to be the `simple' way

to do it - except when a second path was introduced.

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.