Jump to content
Sign in to follow this  
tuppel

Can't build a working windows xp sp2 slipstream cd with imgburn 2.1.0.0

Recommended Posts

I am trying to build a bootable slipstream Windows XP sp2 CD. The CD boots perfectly in character based setup mode. There are 2 files which can't be copied.

 

(file on slipstreamdir) -> (file on build cd)

 

CYCLAD-Z.IN_ -> CYCLAD_Z.IN_

CYCLOM-Y.IN_ -> CYCLOM_Y.IN_

 

I think that the minus sign isn't ISO compliant and is replaced by the underscore.

 

When I check "Allow full ASCII Charcter set" booting works, but fails in copying usbehci.sys (lowercase). I noticed that usbehci.sy_ is in lowercase in de slipstream directory while for example USBOHCI.SY_ is in all-caps. I didn't check if I all-cap usbehci.sy_ solves the problem.

 

Burning the same slipstream directory with Nero works fine. I user ISO character set DOS with Nero.

Edited by tuppel

Share this post


Link to post
Share on other sites

You should probably enable the logging option in the 'Build' settings so you can see exactly what's being changed to fit with ISO9660 restrictions.

 

Indeed though, a '-' character is not permitted under normal ISO9660 specs.

 

I wouldn't have though filename case would be a problem as Microsoft stuff doesn't normally care about case.

 

I try it myself in a bit and report my findings.

 

Fail in copying the file could just mean the drive cant read the disc.

Share this post


Link to post
Share on other sites

Ok, these are the problem files:

 

W 15:52:38 ISO9660 File: 'W:\WIN51' -> 'WIN51.'
W 15:52:38 ISO9660 File: 'W:\WIN51IP' -> 'WIN51IP.'
W 15:52:38 ISO9660 File: 'W:\I386\CYCLAD-Z.IN_' -> 'CYCLAD_Z.IN_'
W 15:52:38 ISO9660 File: 'W:\I386\CYCLOM-Y.IN_' -> 'CYCLOM_Y.IN_'
W 15:52:38 ISO9660 File: 'W:\I386\DISK1' -> 'DISK1.'
W 15:52:39 ISO9660 File: 'W:\I386\HEADSP~1.WM_' -> 'HEADSP_1.WM_'
W 15:52:39 ISO9660 File: 'W:\I386\HOSTS' -> 'HOSTS.'
W 15:52:39 ISO9660 File: 'W:\I386\MINIPL~1.WM_' -> 'MINIPL_1.WM_'
W 15:52:40 ISO9660 File: 'W:\I386\NTLDR' -> 'NTLDR.'
W 15:52:42 ISO9660 File: 'W:\I386\SV-262E1.PN_' -> 'SV_262E1.PN_'
W 15:52:42 ISO9660 File: 'W:\I386\SV-262E3.PN_' -> 'SV_262E3.PN_'
W 15:52:42 ISO9660 File: 'W:\I386\SV-262E4.PN_' -> 'SV_262E4.PN_'
W 15:52:42 ISO9660 File: 'W:\I386\UTOPIA~1.WA_' -> 'UTOPIA_1.WA_'
W 15:52:42 ISO9660 File: 'W:\I386\UTOPIA~2.WA_' -> 'UTOPIA_2.WA_'
W 15:52:42 ISO9660 File: 'W:\I386\UTOPIA~3.WA_' -> 'UTOPIA_3.WA_'
W 15:52:42 ISO9660 File: 'W:\I386\UTOPIA~4.WA_' -> 'UTOPIA_4.WA_'
W 15:52:44 ISO9660 File: 'W:\CMPNENTS\TABLETPC\I386\PT-BRKBC.DL_' -> 'PT_BRKBC.DL_'
W 15:52:44 ISO9660 File: 'W:\CMPNENTS\TABLETPC\I386\PT-PTKBC.DL_' -> 'PT_PTKBC.DL_'
W 15:52:44 ISO9660 File: 'W:\CMPNENTS\TABLETPC\I386\ZH-CHSKB.DL_' -> 'ZH_CHSKB.DL_'
W 15:52:44 ISO9660 File: 'W:\CMPNENTS\TABLETPC\I386\ZH-CHTKB.DL_' -> 'ZH_CHTKB.DL_'
W 15:52:44 ISO9660 Directory: 'W:\I386\WIN9XMIG\ICM\SYMBOLS.PRI\' -> 'SYMBOLS_PRI'
W 15:52:44 ISO9660 Directory: 'W:\I386\WIN9XMIG\IEMIG\SYMBOLS.PRI\' -> 'SYMBOLS_PRI'
W 15:52:44 ISO9660 Directory: 'W:\I386\WIN9XMIG\PWS\SYMBOLS.PRI\' -> 'SYMBOLS_PRI'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE1' -> 'FILE1.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE10' -> 'FILE10.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE11' -> 'FILE11.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE12' -> 'FILE12.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE13' -> 'FILE13.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE2' -> 'FILE2.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE3' -> 'FILE3.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE4' -> 'FILE4.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE5' -> 'FILE5.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE6' -> 'FILE6.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE7' -> 'FILE7.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE8' -> 'FILE8.'
W 15:52:44 ISO9660 File: 'W:\I386\WIN9XMIG\ACROBAT\FILES\FILE9' -> 'FILE9.'

 

A few problems here (Microsofts, not ImgBurn's):

 

ISO9660 filesystems cannot have folders with extensions.

ISO9660 filesystems cannot have files without extensions.

ISO9660 filesystems cannot have folder / files with characters in them that are anything except A-Z, 0-9 and _

 

So MS broke all the rules when naming the folder/files for this disc.

 

There's nothing really for me to 'fix' as technically I'm doing nothing wrong.

 

I could put another checkbox under ISO9660 restrictions to allow folders with extensions and files without them, but that's about it - and like I say, I shouldn't have to!

 

EDIT:

 

BTW, you can make an image that compares perfectly (file data content wise) to the original by using the following options:

 

General -> File System = ISO9660

Advanced -> Restrictions -> ISO9660 -> Level 2 - 31 Characters

Advanced -> Restrictions -> ISO9660 -> Allow More Than 8 Directory Levels

Advanced -> Restrictions -> ISO9660 -> Allow Full ASCII Character Set

Share this post


Link to post
Share on other sites

I agree that technicly speaking there is nothing nothing to fix. So this is not a bug. I know that Microsoft uses it's own "ISO standard".

 

Still I can't burn a working (working = booting and installing Windows) slipstream CD. I know at least three programs who can: Nero, nLite and Bart PE builder.

 

I think that during the character based part of the Windows setup the file system driver is more restrictive or more case sensitive. I am gone test it tomorrow (upercase usbehci.sy_ and maybe other files needed at the char based setup).

Share this post


Link to post
Share on other sites

Going by my cd, all the files are uppercase.

 

I've just done a bit more messing around and it seems you need to turn on the 'Don't Add ';1' Version Number To Files' options. If you don't, it can't find ntldr.

 

EDIT:

 

Yup, that's it.

 

Built + booted + fully installed without any issues.

Share this post


Link to post
Share on other sites

burntest.zipI have found the following.

 

Creating a non-slipstream CD works fine. When performing the slipstream (update -s:<path>) some files and directories are lowercased.

 

I've created 4 cd's. 3 with Imgburn and 1 with Nero. Imgburn fails only on the un-altered slipstreamed (not uppercased) files. This can be corrected by uppercasing at least de \i386 directory. Detailed screenshots and directory listing/logs are attached to this posting. Nero does not need altering to create a working slipstream CD.

 

cd a: Plain XP burned with imgburn 2.1.0.0. works.

cd b: Slipstream XP SP2 burned with imgburn 2.1.0.0. failed. usbehci.sys not found during charbased setup.

cd c: Slipstream XP SP2 burned with imgburn 2.1.0.0 \i386 directory altered all files uppercased. works.

cd d: Slipstream XP SP2 burned with Nero 6.6.1.4 unaltered. works.

 

(works=booting and installing).

Share this post


Link to post
Share on other sites

I guess the dos character set forces uppercase but allows things like '~' etc in file names.

 

So I need to add options for ISO9660 / DOS / ACSII character sets and remove the 'Allow full ascii character set' option.

 

Easily done, I'll get right to it!

Share this post


Link to post
Share on other sites

It would be great, but I have to do some "research" how the character set options work in Nero and other tools. I believe that choosing "ISO 9660" also work (maybe the tilde ~ is an issue). I am gone test a slipstream with "ISO 9660" and "ASCII" charset also. It takes some time. I'll post my findings in this thread.

 

Maybe I am gone make a CD with filenames like:

 

040_@

041_A

..

05A_Z

061_a

..

07A_z

 

to see how the different charset get handled/translated when you burn them with differt character sets.

Share this post


Link to post
Share on other sites

Well, in his defense, this WAS a Microsoft issue he had to fix. So, he, naturally, encountered other fucker gotchas that had to be worked around. :wink:

Share this post


Link to post
Share on other sites
That and I had to do it twice because borland crashed and I lost all my changes :&#39;(

Post your minidump file, and we'll tell you what crashed it. =))=))

Share this post


Link to post
Share on other sites
Ok, these are the problem files:

 

A few problems here (Microsofts, not ImgBurn's):

 

ISO9660 filesystems cannot have folders with extensions.

ISO9660 filesystems cannot have files without extensions.

ISO9660 filesystems cannot have folder / files with characters in them that are anything except A-Z, 0-9 and _

 

So MS broke all the rules when naming the folder/files for this disc.

 

There's nothing really for me to 'fix' as technically I'm doing nothing wrong.

Actualy, they didn't broke anything, they are using ISO9660:1999 (some programs call it ISO Level 4).

Share this post


Link to post
Share on other sites
Ok, these are the problem files:

BTW, you can make an image that compares perfectly (file data content wise) to the original by using the following options:

 

General -> File System = ISO9660

Advanced -> Restrictions -> ISO9660 -> Level 2 - 31 Characters

Advanced -> Restrictions -> ISO9660 -> Allow More Than 8 Directory Levels

Advanced -> Restrictions -> ISO9660 -> Allow Full ASCII Character Set

 

Are any of these switches available via the command-line options? I'm building a CD automatically and getting a error that my directories are more than 8-levels deep.

Edited by KenNashua

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.