Jump to content
DeathStalker

Failed To Initialize FIFO Buffer

Recommended Posts

Ok, this is really starting to p*** me off.

 

I've had this working just fine, but had to re-install Win 7 x64.  I have 32gb RAM and a 200gb pagefile - no matter what I set the IO Buffer to be (even as low as 128mb!) it is not working and I get the same error every time I try to burn.

 

It is CLEARLY *NOT* and issue with insufficient memory - Physical Memory shows 33,493,780 with 21,584,285 available (per Process Explorer).  I have even tried different Interface selections, but nothing changes.  It is also being run under Admin.

 

Please assist.  ImgBurn is the only burner software that I am aware of that does Verify, so I don't want to have to switch to another.

 

Thank you!

 

 

Share this post


Link to post
Share on other sites

That is the exact error.

 

Selecting Build>Burn (ISO/Joliet/UDF) - single layer

 

It goes from -

 

VirtualAlloc Failed!

Reason:  Not enough storage is available to process this command.

 

Hit OK

 

Failed to initialise FIFO Buffer (<amount of IO buffer selected>)

Share this post


Link to post
Share on other sites

VirtualAlloc is the Windows API function call being used and you can see the error Windows is returning.

 

Regardless of how much memory you have, you (we) can only go by what you're being told. Maybe try searching Google to find out why VirtualAlloc might fail like that when there should be enough memory.

 

Can I assume the 'amount of I/O buffer selected' does actually change as you change the sliders? I only ask because there are a few different buffer related ones in the settings and they'll all come into play at different times within the program flow. If in doubt, revert the settings to their default values. You should also try running the program in safe mode - some other app may be causing the issue (A/V or whatever). Oh and don't run it as admin, run it as a normal user (don't elevate).

Share this post


Link to post
Share on other sites

Yes, the buffer size *does* change with the slider.

 

Additionally, this *only* happens when I try to burn files/folders directly, if they are from an ISO/MDS file, then they burn fine.

 

There appears to be nothing related to my issue when [g]-ing "virtualalloc failed" - I am not a coder :(

Share this post


Link to post
Share on other sites

There will be more virtualallocs going on when using build mode as there's a buffer for reading in the files and one for data going to the drive. Plus more memory is being used for handling the info about the files you're burning - and don't forget it's only a 32bit application.

 

Have you (or can you, please) try what I said in my previous reply? After that, we'd have to examine a few things in Task Manager at the point when that error box is on the screen.

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.