Jump to content
JMThomas

Device problems after installing XP SP4 from RyanVM.net

Recommended Posts

1.  I don't have any hardware problems.  All I did was reinstall XP.  I even used ImgBurn to create the install CD that started my troubles.

 

2.  Installed a XP system disk with "Unofficial XP Service Pack 4" slip-streamed in.

 

SP4 is a well respected roll-up of all fixes issues by Microsoft after the M$ official SP3 release and the termination of XP support.  It is distributed through RyanVM.net, and many people still clinging to XP have used it without any difficulty. 

 

3.  The install recreated rebuilt reinstalled drivers for all of my hardware.  I followed up by installing the Intel chipset and graphics drivers for my motherboard.  Everything appeared to be fine; reinstalled programs, downloaded, etc.  Spent a good day doing mail, browsing, programming, games, even read a couple of CDs..

 

4.  Finally, I fired up ImgBurn again to make another copy of my install ISO, and it throws an I/O error at first write:

post-55360-0-02823100-1456637008_thumb.jpg

 

Here's the log

I 00:12:23 ImgBurn Version 2.5.8.0 started!
I 00:12:23 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 3)
I 00:12:23 Total Physical Memory: 2,086,100 KiB  -  Available: 664,964 KiB
W 00:12:23 Drive F:\ (FAT32) does not support single files > 4 GiB in size.
I 00:12:23 Initialising SPTI...
I 00:12:23 Searching for SCSI / ATAPI devices...
I 00:12:23 -> Drive 1 - Info: SONY DVD RW AW-G170A 1.75 (S:) (ATA)
I 00:12:24 -> Drive 2 - Info: SONY DVD RW DRU-180A 1.63 (R:) (ATA)
I 00:12:24 -> Drive 3 - Info: ELBY CLONEDRIVE 1.4 (V:) (SCSI)
I 00:12:24 Found 2 DVD±RW/RAMs and 1 BD-ROM/HD DVD-ROM!
I 00:12:54 Operation Started!
I 00:12:54 Source File: D:\XP_Pro_IU_SP4.iso
I 00:12:54 Source File Sectors: 571,520 (MODE1/2048)
I 00:12:54 Source File Size: 1,170,472,960 bytes
I 00:12:54 Source File Volume Identifier: XP_PRO_IU_SP4
I 00:12:54 Source File Volume Set Identifier: UNDEFINED
I 00:12:54 Source File Application Identifier: IMGBURN V2.5.8.0 - THE ULTIMATE IMAGE BURNER!
I 00:12:54 Source File Implementation Identifier: ImgBurn v2.5.8.0
I 00:12:54 Source File File System(s): ISO9660 (Bootable)
I 00:12:54 Destination Device: [0:0:0] SONY DVD RW DRU-180A 1.63 (R:) (ATA)
I 00:12:54 Destination Media Type: DVD+R (Disc ID: MCC-004-00)
I 00:12:54 Destination Media Supported Write Speeds: 4x, 6x, 8x, 12x, 16x
I 00:12:54 Destination Media Sectors: 2,295,104
I 00:12:54 Write Mode: DVD
I 00:12:54 Write Type: DAO
I 00:12:54 Write Speed: 4x
I 00:12:54 DVD+R Reserve Track: No
I 00:12:54 Link Size: Auto
I 00:12:54 Lock Volume: Yes
I 00:12:54 Test Mode: No
I 00:12:54 OPC: No
I 00:12:54 BURN-Proof: Enabled
I 00:12:55 Write Speed Successfully Set! - Effective: 5,540 KB/s (4x)
I 00:12:55 Filling Buffer... (80 MiB)
I 00:12:56 Writing LeadIn...
W 00:12:56 Failed to Write Sectors 0 - 15 - Reason: The parameter is incorrect.
W 00:12:56 Retrying (1 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (2 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (3 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (4 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (5 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (6 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (7 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (8 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (9 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (10 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (11 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (12 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (13 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (14 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (15 of 20)...
W 00:12:56 Retry Failed - Reason: The parameter is incorrect.
W 00:12:56 Retrying (16 of 20)...
W 00:12:57 Retry Failed - Reason: The parameter is incorrect.
W 00:12:57 Retrying (17 of 20)...
W 00:12:57 Retry Failed - Reason: The parameter is incorrect.
W 00:12:57 Retrying (18 of 20)...
W 00:12:57 Retry Failed - Reason: The parameter is incorrect.
W 00:12:57 Retrying (19 of 20)...
W 00:12:57 Retry Failed - Reason: The parameter is incorrect.
W 00:12:57 Retrying (20 of 20)...
W 00:12:57 Retry Failed - Reason: The parameter is incorrect.
E 00:21:33 Failed to Write Sectors 0 - 15 - Reason: The parameter is incorrect.
I 00:21:33 Synchronising Cache...
W 00:21:37 User opted to skip the 'Close Track/Session/Disc' functions.
E 00:21:37 Failed to Write Image!
E 00:21:37 Operation Failed! - Duration: 00:08:42
I 00:21:37 Average Write Rate: N/A - Maximum Write Rate: N/A

Here's my filters:

===============================================
Filter Driver Load Order - ImgBurn v2.5.8.0
===============================================

Upper Device Filter:  redbook
 Upper Class Filter:  [None Found]
             Device:  CD/DVD-ROM Device
 Lower Class Filter:  [None Found]
Lower Device Filter:  imapi

        Filter Name:  redbook
          File Name:  C:\WINDOWS\system32\DRIVERS\redbook.sys
       File Version:  5.1.2600.5512 (xpsp.080413-2108)
   File Description:  Redbook Audio Filter Driver
       Product Name:  Microsoft® Windows® Operating System
    Product Version:  5.1.2600.5512
       Company Name:  Microsoft Corporation
          Copyright:  © Microsoft Corporation. All rights reserved.

        Filter Name:  imapi
          File Name:  C:\WINDOWS\system32\DRIVERS\imapi.sys
       File Version:  5.1.2600.5512 (xpsp.080413-2108)
   File Description:  IMAPI Kernel Driver
       Product Name:  Microsoft® Windows® Operating System
    Product Version:  5.1.2600.5512
       Company Name:  Microsoft Corporation
          Copyright:  © Microsoft Corporation. All rights reserved.


My device Capabilities:

 

post-55360-0-81261400-1456637319_thumb.png

 

I have a second drive; it fails the same way.

 

I've tried Verbatum and ugly Memorex blanks, and the all fail the same.

 

The only interesting entries in the system log (actually 3): 1) "IMAPI CD-Burning COM" got a start command, 2) entered the running state, and 3) stopped.

 

My firmware is up to date for both devices.

 

This has got to be some sort of configuration problem.  I can read anything, but I can't write anything.

 

Can anyone please advise me?  Thanks!

 

PS: Did I miss any more diagnostic info ImgBurn can produce?

Share this post


Link to post
Share on other sites

Right click the drive selection drop down box and pick 'Family Tree'. Close the prompt and then copy + paste everything from the log window please.

 

If you boot into safe mode, does it work?

Share this post


Link to post
Share on other sites

---------------------------
ImgBurn
---------------------------
Device: [0:0:0] SONY DVD RW DRU-180A 1.63 (R:) (ATA)

Family Tree:

-> ACPI Multiprocessor PC
-> Microsoft ACPI-Compliant System
-> PCI bus
-> Intel® ICH7 Family Ultra ATA Storage Controllers - 27DF (VEN_8086&DEV_27DF - Intel - pciide - v9.1.1.1016)
-> Primary IDE Channel
-> CD-ROM Drive (SONY DVD RW DRU-180A) (0)

---------------------------
OK   
---------------------------
 

Share this post


Link to post
Share on other sites

Still fails in Safe Mode.

 

Here's info box on the right side of the ImgBurn window:

SONY DVD RW DRU-180A 1.63 (ATA)
Current Profile: DVD+R

Disc Information:
Status: Empty
State of Last Session: Empty
Erasable: No
Free Sectors: 2,295,104
Free Space: 4,700,372,992 bytes
Free Time: 510:03:29 (MM:SS:FF)
Next Writable Address: 0
MID: MCC-004-00
Supported Write Speeds: 4x, 6x, 8x, 12x, 16x

Physical Format Information (ADIP):
Disc ID: MCC-004-00
Book Type: DVD+R
Part Version: 1
Disc Size: 120 mm
Maximum Read Rate: Not Specified
Number of Layers: 1
Track Path: Parallel Track Path (PTP)
Linear Density: 0.267 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 2,491,711
Last Physical Sector in Layer 0: 0

Physical Format Information (Last Recorded):
Disc ID: MCC-004-00
Book Type: DVD+R
Part Version: 1
Disc Size: 120 mm
Maximum Read Rate: Not Specified
Number of Layers: 1
Track Path: Parallel Track Path (PTP)
Linear Density: 0.267 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 2,491,711
Last Physical Sector in Layer 0: 0

Performance (Write Speed):
Descriptor 1...
-> B0: 0x00, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2295103 (0x0023053F)
-> RS: 22,160 KB/s (16x) - WS: 5,540 KB/s (4x)
Descriptor 2...
-> B0: 0x00, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2295103 (0x0023053F)
-> RS: 22,160 KB/s (16x) - WS: 8,310 KB/s (6x)
Descriptor 3...
-> B0: 0x00, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2295103 (0x0023053F)
-> RS: 22,160 KB/s (16x) - WS: 11,080 KB/s (8x)
Descriptor 4...
-> B0: 0x00, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2295103 (0x0023053F)
-> RS: 22,160 KB/s (16x) - WS: 16,620 KB/s (12x)
Descriptor 5...
-> B0: 0x08, B1: 0x00, B2: 0x00, B3: 0x00
-> EL: 2295103 (0x0023053F)
-> RS: 22,160 KB/s (16x) - WS: 22,160 KB/s (16x)

Thank you very much for your effort in reviewing...

Share this post


Link to post
Share on other sites

Install virtual clonedrive or anything else that installs elbycdio, switch imgburn's i/o interface to elbycdio and see if that works.

 

I have no idea why, but the os is rejecting the commands and returning an error.

Share this post


Link to post
Share on other sites

Elaborate Bytes driver fails same.

 

Nero 9 fails same.

 

Inquiries are also being made in the SP4 forum.

 

Interestingly, I CAN create CDs.  Just not DVDs.

 

Thanks for you work, Lightning.  I don't expect further assistance, but wanted to keep things updated.

Edited by JMThomas

Share this post


Link to post
Share on other sites

We found that the install DVD I built was missing some files, though I can't name all of them.  I wish I could, but I ended up deleting the bad ISO too soon.  GIU mode install did ask for some files, but after I pointed it to the extracted SP4 files, install seemed to complete OK.

 

Theory:  The first missing file it ask for may have been from WMP, guessing from the name.  Since WMP seems to cary support for burning, perhaps it got into a conflict with XP base.

 

Anyway, another slipstream onto an older disk created an install disk that gives a working DVD burner.

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.