Jump to content

ImgBurn Support Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

Photo

ASMedia 106x SATA Controller



  • Please log in to reply
3 replies to this topic

#1 nvatray

nvatray

    ISF Newbie

  • New Members
  • Pip
  • 2 posts

Posted 09 January 2017 - 04:59 AM

First I wanted to comment on how great the Imgburn program is. 

 

Thank you.  Now I feel that it must be my turn to contribute back to society.

 

I recently had a problem with my DVD Burner that I feel others are also likely having.

 

Average Write Rate: 77 KiB/s (0.1x) - Maximum Write Rate: 77 KiB/s (0.1x)

 

No matter what I set my Burn speed to, it started off ok, then immediately dropped to 0.1x every time I tried to burn a DVD-R.

 

I seriously thought my DVD burner had died, but it was fairly new and lightly used, so I refused to give up.

 

Without telling you how long I banged my head against the wall, here is a quick fix to a serious issue in Windows 8.1 and likely many other versions of window with hardware containing ASMedia 106x Sata Controllers.

 

Firstly, verify which SATA Controller your DVD Drive is currently connected to.

 

With a disc in the drive:

 

Imgburn, Tools, Drive, Family Tree.

 

Just above your CD Rom Drive you will notice which controller it is connected to. 

 

Very Helpful, thank Imgburn for us not having to take the computer apart and trace the cables.

 

Note: Imgburn should likely recommend driver updates for Sata Controllers, or alert of possible driver version issues. (MS Drivers)

 

Step 1. Verify you have a Asmedia 106x SATA Controller

     a. Open Device Manger, Expand Storage Controllers, look for Asmedia 106x

 

Step 2. Check Driver Version,

     a. Double Click on Asmedia 106x

     b. Click Driver Tab

 

Don't bother clicking on Update Driver, It doesn't work! Trust me, I tried.  What the heck try anyways, maybe one day you will get lucky when they finally update the catalog.

 

I had a problem created by a Microsoft Driver, the only fix was to download the manufacturer's driver and install it manually.

 

When I discovered the problem, my driver version was:

     MS AHCI Storport Miniport Driver

     File Version 6.2.9200.16387

     Product Name Windows® Win 7 DDK driver

     Product Version 6.2.9200.16384

     Copyright Micro$oft Corp

     Size 77.2 KB

     Date Modified 9/16/2013 7:39 PM

     English

     Original filename asstor.sys

 

 

Running MSInfo32.exe confirms which driver file the Asmedia 106x Controller is using.

     Components, Storage, Scsi

     ASMedia 106x Sata Controller

     c:\windows\system32\drivers\asstor64.sys     (6.2.9200.16384)

 

I browsed the internet, found my motherboard on Asus website by searching for X79-Deluxe, clicked on Support and Drivers for Windows 8.1 x64.

 

Expanded the Sata Section.

 

Downloaded:

 

     Asmedia SATA Controller Driver V3.1.6.0 for Windows 7 32bit & 64bit / 8.1 64bit / 10 64bit.(WHQL)

 

I installed that driver, and rebooted.

 

I was amazed.  My DVD Burner worked like a champ and was normal once again!

 

I have a ASUS DRW-24B1ST DVD Burner (LITE-ON), connected to a Asmedia 106x Sata Controller, on a X79-Deluxe Motherboard running Windows 8.1 x64..

 

This was one of the weirdest problems I have ever seen, but with a little technical knowledge it is easily fixed.

 

When I was done I rechecked my Drivers.

 

     Asmedia Technology

     Driver Date 6/17/2015

     Driver Version 3.1.6.0

 

Run msinfo32.exe

 

     Components, Storage, SCSI,

 

     Asmedia 106x SATA Controller

     Manufacturer Asmedia Technology

     Driver c:\windows\system32\drivers\asstahci64.sys (3.1.6.0)

 

I noticed one thing that really appeared differently in the Imgburn Family Tree.

Before, it showed my DVD Burner as an Scsi CD Rom Device.

 

Afterwards, Scsi CD Rom Device was no longer listed.

 

Before, my Sata Controller was using asstore64.

 

Afterwards, my Sata Controller was using asstahci64.

 

I hope this helps someone else resolves these type of issues.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Attached Images

  • msinfo32.PNG
  • ImgBurn Tools Drive Family Tree.PNG
  • ImgBurn Tools Driver Family Tree After Driver Update.PNG
  • msinfo32_after_driver_update.PNG
  • System32 Drivers after Driver Update.PNG
  • System32 Drivers.PNG


#2 LIGHTNING UK!

LIGHTNING UK!

    Author of ImgBurn

  • Admin
  • PipPipPipPipPip
  • 29,277 posts
  • Gender:Male
  • Location:United Kingdom

Posted 09 January 2017 - 06:57 AM

Have you exhausted the actual intel sata ports on the MB and that's why it's on the Asmedia ones to begin with? Always opt for the intel ones over 3rd party.

Glad the driver update fixed your issue though :)
Please don't PM me with questions that should be posted in the forum. I won't reply - Especially if you have post count of 0!!!

Replies to posts belong in the forum where everyone can read them. Please don't PM them.

In fact, don't PM me at all unless it's something I've asked to be told about!

Before asking questions, search the forum to see if someone else already has.

Use the FAQ and Guides forums to your advantage. I don't want to have to tell you to read them!

#3 nvatray

nvatray

    ISF Newbie

  • New Members
  • Pip
  • 2 posts

Posted 10 January 2017 - 06:32 AM

The reason I wrote this up, is after searching the internet, I realized there were many others with the same types of setup as me having unexplained strange issues that no one else had been able to help them with.  The common answer was after they moved the drive it magically started working or after they replaced the cable it magically started working. In truth many of them only bypassed the problem instead of fixing the real issue at hand which could have fixed other performance issues with their system as well.



#4 Ch3vr0n

Ch3vr0n

    ISF Member

  • Members
  • PipPip
  • 196 posts

Posted 10 January 2017 - 11:34 AM

If you'll read the notice that comes with asmedia chipsets it's real easy. 'DATA drives only' aka HDD or SSD. ODD's are not supported at all or can have erratic behavior

Sent from my Nexus 6P with Tapatalk.

Official Dutch (nl-BE) translator for:

 

Internet Download Manager, ALL Slysoft products, VSO ConvertXtoDVD, various joomla extensions & components





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users