Jump to content

ImgBurn Support Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

Photo

How I fixed "Device not Ready - Media not present" [TRY AT YOUR OWN RISK!]


Forum Rules

Read the Guides forum if you don't know how to do something. :readbook:
If you have a question or a problem, check the FAQ and use the Search to see if you can find the answer for yourself. :lightbulb:
If you're having trouble burning double layer media, read Here.
Still stuck? Create a new thread and describe your issue in detail.
Make sure you include a copy of the program's log in your post. No log = :chair:


  • Please log in to reply
No replies to this topic

#1 Tyltyl

Tyltyl

    ISF Newbie

  • New Members
  • Pip
  • 1 posts
  • Location:Switzerland

Posted 19 September 2017 - 11:34 AM

Hello everyone, after a failed DVD burning with my external DVD writer (a Samsung SE-218CN), I ended up with the aformentioned error in IMGBurn.

It didn't detect ANY disk at all, empty or not, DVD or CD, couldn't read or write anything at all. It was just completely dead.

btYTG6Q.jpg

I looked all around this forum and the only solutions I found were to update the firmware, to try with another disk or simply throw the drive in the trash bin as it was simply bricked. The last one was probably my way to go.

I tried to update the firmware to no avail, same error. 
However I didn't feel like giving up and seeing that the drive was dead I tried something extremely risky.

!!! TRY THIS AT YOUR OWN RISK, IT MIGHT DEFINITELY KILL YOUR DEVICE! DO THIS AS A LAST RESORT! !!! 
!!! THIS WORKED FOR ME AND IT MAY NOT WORK WITH YOU OR WITH ANOTHER BRAND OTHER THAN SAMSUNG!!!


I downloaded another copy of the same firmware (MF00) that is written in the back of the device, along with the software from Samsung TSDNWin, I started the update process and disconnected the drive.
 

TN7g63B.jpg

sofqUK8.jpg

 

 

Of course at that point it doesn't have a firmware anymore, the eject button doesn't work, the firmware updater said it was in "BOOT" mode and needing for a firmware version.

 

 

h9qf3jF.jpg

 

 

I downloaded a firmware for a similar model (TS00) and started the update again.

I had to to this because if I tried to update directly from MF00 to TS00 I just received an error saying that the firmware is not suitable for the drive.

Lo and behold, the update process is successful, the drive starts reading disks again and IMGBurn doesn't give the error anymore.
 

 

2Ixygyi.jpg

I tested by burning a CD and it worked just fine!
It may not be the simpliest nor the safest way to fix this, but it worked for me and the DVD Writer is back from the dead!
 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users