Jump to content
cholla

Cue Audio file Display DirectShow Filter List

Recommended Posts

@ LIGHTNING UK!

I followed your instructions to right click on a FLAC file in the Create Cue File being created.

This is the result:

1. -> Source (Vendor Info: Unknown)
2. -> LAV Splitter (Vendor Info: Unknown)
3. -> LAV Audio Decoder (Vendor Info: Unknown)
4. -> Sample Grabber (Vendor Info: Unknown)
5. -> Null Renderer (Vendor Info: Unknown)

 

Sample Grabber & Null Renderer are related to Microsoft qedit.dll.

Their File Merit is set to 00200000 which is "Do not use".

I tried a couple of softwares you suggested in other topics:

InstalledCodec & DirectShow Filter Manager .

I also have other software that does about the same.

None of these show Source (Vendor Info: Unknown) or just Source.

Would you explain the meaning of "Source (Vendor Info: Unknown)" ?

I believe I understand that Sample Grabber & Null Renderer are not being used.

If Source means the FLAC file itself then I understand what that is.

I believe that LAV Splitter & LAV Audio Decoder are what ImgBurn is using to Analyze FLAC  & other audio files.

Is this correct from what is shown ?

Just to note so far ImgBurn hasn't had a problem for me creating a .cue & has successfully analyzed all audio files I've tried.

I've even burned some to an Audio CD RW without a problem.

To test if they would burn.

I've even tried to find an audio file that would fail to analyze but I haven't so far.

 

BTW any other forum member that wants to post is welcome to do so.

 

 

Edited by cholla

Share this post


Link to post
Share on other sites

ImgBurn uses DirectShow for audio decoding. It specifies the source file and tells it the output format required. Everything else is pretty much automatic.
Yes, source will be the file... or something that can read the file. For this stuff, ImgBurn is querying DirectShow for everything it’s using to create the ‘graph’. The vendor info stuff is again, coming from DirectShow. Some filters fill it in, others don’t.

Share this post


Link to post
Share on other sites

Thanks LIGHTNING UK! ,

With some searching I found this:

LAV Filters are a set of open-source DirectShow filters.

I believe ImgBurn is only using the Source file then the  LAV Splitter & LAV Audio Decoder.

Since I have the File Merit of Sample Grabber & Null Renderer set to "Do not use".

I believe ImgBurn is detecting those but not actually using them.

This is what GraphStudio shows:

GraphStudio.PNG.e34b87626b2378401608105b9d52d29c.PNG

 

 The Default DirectSound Device is using the MS quartz.dll .

I believe ImgBurn is doing it the same or similarly.

Do you believe this is correct ?

Share this post


Link to post
Share on other sites

I had the LAV filters installed and when I tried to import FLAC files, I had to install madFLAC to get ImgBurn to import them.

Share this post


Link to post
Share on other sites

ImgBurn has to use the sample grabber and null renderer.... I'm not 'playing' the file and instead have to capture the output from the LAV splitter/decoder. Playback would use the 'default directsound device' that graphstudio shows - i.e. outputting to your soundcard / speakers.

 

Share this post


Link to post
Share on other sites

Thanks for your patience LIGHTNING UK!

I'm not having any problems creating .cue files from FLAC or any other audio format I've tried.

Just trying to learn some more.

 

@ dbminter I don't have madFlac installed.

When I "browse for a file" from the "Create Cue File" in ImgBurn the LAV filters being used show in my systray like in this image:

This is the LAV  Splitter & the LAV Audio Decodersystray.thumb.PNG.1ccdf69edd3f3dac18684954c0b2981a.PNG

I do have flac checked in the "Input Formats" in the splitter & in "Formats" in the Audio decoder .

 

Share this post


Link to post
Share on other sites

I was just saying I have LAV filters installed as part of my K-Lite Codec Pack Mega install and I still had to install madFLAC to get ImgBurn to import FLAC files.

Share this post


Link to post
Share on other sites
2 hours ago, dbminter said:

I was just saying I have LAV filters installed as part of my K-Lite Codec Pack Mega install and I still had to install madFLAC to get ImgBurn to import FLAC files.

I understood that.

I was pointing out that I didn't need to do that to get ImgBurn to import FLAC files.

I have necessary codecs installed but I don't have a "codec pack" like K-Lite .

I'm using Windows 7 .

If you are using Windows 10 that might be the difference as it might need madFLAC to import FLAC files.

Have you checked the LAV configurations to see if flac is checked ?

 

Share this post


Link to post
Share on other sites

@ dbminter

I'm not sure with your setup.

It may be part of the K-Lite Codec Pack Mega & the LAV configurations would be in it.

Since I don't have it I can't say for sure

For my OS I can access LAV Filters from my Programs Menu.

This is installed when I install the LAV filters as standalone filters.

This is what it looks like on my OS:

LAVAudioConfig.PNG.869c82f4f27e216ed2ed3ef411793bf8.PNG

 

In the Start Programs Menu:

LAVSM.PNG.491ba31ab10b3823d90c4b304044f03d.PNG

Share this post


Link to post
Share on other sites

I've got something similar.  It showed FLAC as being checked, but I still needed to install madFLAC before ImgBurn would process them into Audio CD's for me.  I even posted about it here when it didn't work and LUK told me to install madFLAC, which got it working for me.

Share this post


Link to post
Share on other sites

I don't have any explanation for why your OS needs madFLAC  for ImgBurn to work with FLAC files.

When mine only needs the LAV filters.

Both apparently need the Microsoft sample grabber and null renderer that are part of the qedit.dll.

What does it show when you right click on a FLAC file in the.CUE & select "Display DirectShoe Filter List" ?

I have my LAV filters also checked to show in the systray when they're being used.

If you can check that box . See if they will show in the systray.

Syatray.PNG.73eaa916b60b08f2de41f3059fc450cc.PNG

Share this post


Link to post
Share on other sites

MadFLAC

Sample Grabber

Null Renderer

 

All Vendor Info unknown.

 

I know the LAV shows up in my system tray whenever I play an audio or video file in Media Player Classic Home Cinema.

Share this post


Link to post
Share on other sites

I downloaded the last version of madFLAC: madFlac-1.10 .

This was written in 2011.

I didn't use the InstallFilter.exe or install.bat.

I did a manual install of the madFlac.ax & libFLAC.dll to my Windows/System32 folder.

Then I registered madFlac.ax with regsvr32 in the Run window.

The I tested with ImgBurn: Create Cue File.

I browsed for  a FLAC file & selected it.

Using the right click of the FLAC file & selected Display DirectShow Filter List.

This is what I got:

DirectShow Filter List:
1. -> madFlac (The Pusher (Live at The Matrix, San Francisco
1967).flac) (Vendor Info: Unknown)
2. -> AC3Filter (Vendor Info: Unknown)
3. -> Sample Grabber (Vendor Info: Unknown)
4. -> Null Renderer (Vendor Info: Unknown)

This is with the flac still checked in LAV filters.

So madFLAC is selected instead of LAV when it is installed.

That explains why your OS is using madFlac over LAV for FLAC files.

I then unregistered  madFlac.ax with regsvr32 /u in the Run window.

So now my OS is back like it was & show this:

DirectShow Filter List:

1. -> Source (Vendor Info: Unknown)
2. -> LAV Splitter (Vendor Info: Unknown)
3. -> LAV Audio Decoder (Vendor Info: Unknown)
4. -> Sample Grabber (Vendor Info: Unknown)
5. -> Null Renderer (Vendor Info: Unknown)

 

Share this post


Link to post
Share on other sites

I guess for whatever reason, K-Lite Codec Pack, which I choose to install LAV filters with as part of its Mega package, isn't loading FLAC files.  Maybe because I don't have LAV always "running" in the system tray?  :unknown:  That only displays whenever MPC-HC opens an audio/video file.

Share this post


Link to post
Share on other sites

I believe it is because you have madFlac installed.

Try this in the Run box regsvr32 /u madFlac.ax

Then see if the LAV filters display in the system tray when ImgBurn is analyzing Flac files for a Cue.

The LAV filters only display in the systray during the analyze.

The same way they only display when MPC-HC is playing a file.

To put it back just use regsvr32 madFlac.ax

This can be done from an Administrative Command Prompt also but it has to be cded to the specific location of the madFlac.ax .

For example:  cd \Windows\System32


I don't know how K-Lite updates but if it doesn't regularly the LAV filters are probably an old version.

Share this post


Link to post
Share on other sites

Ah, now I think we're getting somewhere!  Well, somewhere insomuch as I have NOTHING listed under External Filters.  Neither the top or bottom windows are populated with any information.  So, that indicated to me the LAV filters aren't "there."  Even when playing a file, nothing is listed.

Share this post


Link to post
Share on other sites

You have to select "AddFilter" & add manually.

Then select Prefer .

This is in MPC-HC Options .

The lower window will populate it self when you do this.

This makes MPC-HC prefer the LAV filters.

It won't do anything to ImgBurn & how it works with a Cue.

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.