Jump to content
Sign in to follow this  
layer

Blue Screen @ Sata burner

Recommended Posts

hello,

 

today i have purchased one Optiarc 7170S, now every time i start imgburn i receive one bluescreen :'(

i don't have anymore details...

 

any ideia LIGHT?

 

PS: It works on last nero and VSO soft

Edited by Peter

Share this post


Link to post
Share on other sites

See if you can find the OS's crash dump log.

 

It could be in C:\Windows - called memory.dmp

 

or it'll be a little file in C:\Windows\Minidump

 

The program doesn't cause blue screens, it's not working at a low enough level. Bad drivers are the cause of them.

Share this post


Link to post
Share on other sites

If they're dated to coincide with the crashes you experienced, upload them - assuming they're the same size as mine of course - about 70k !

Share this post


Link to post
Share on other sites

1: kd> !analyze -v
*******************************************************************************
*																			 *
*						Bugcheck Analysis									*
*																			 *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: ba1a3000, memory referenced
Arg2: 00000009, IRQL
Arg3: 00000001, value 0 = read operation, 1 = write operation
Arg4: f7468f55, address which referenced memory

Debugging Details:
------------------


WRITE_ADDRESS:  ba1a3000 

CURRENT_IRQL:  9

FAULTING_IP: 
m5288+3f55
f7468f55 881c17		  mov	 byte ptr [edi+edx],bl

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  DRIVER_FAULT

BUGCHECK_STR:  0xD1

PROCESS_NAME:  Idle

LAST_CONTROL_TRANSFER:  from f7490e44 to f7468f55

STACK_TEXT:  
WARNING: Stack unwind information not available. Following frames may be wrong.
f78aeb00 f7490e44 89b4a334 89b911b8 fffffff8 m5288+0x3f55
f78aeb58 f7494bb5 f7a75400 89b4a320 89b7ca38 m5288+0x2be44
f78aec84 f744fdd2 89b90004 f78aed50 89bc0e18 m5288+0x2fbb5
f78aec9c 804db90f 89bc0e18 89b7ca38 01010009 SCSIPORT!ScsiPortInterrupt+0x2a
f78aec9c baf49552 89bc0e18 89b7ca38 01010009 nt!KiInterruptDispatch+0x45
f78aed30 f7717c70 804e7929 f7717000 80560f00 AmdK8+0x3552
f78aed50 804dcbef 00000000 0000000e 0a97ff61 0xf7717c70
f78aed54 00000000 0000000e 0a97ff61 bf800933 nt!KiIdleLoop+0x10


STACK_COMMAND:  kb

FOLLOWUP_IP: 
m5288+3f55
f7468f55 881c17		  mov	 byte ptr [edi+edx],bl

SYMBOL_STACK_INDEX:  0

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: m5288

IMAGE_NAME:  m5288.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  43ac0f8b

SYMBOL_NAME:  m5288+3f55

FAILURE_BUCKET_ID:  0xD1_W_m5288+3f55

BUCKET_ID:  0xD1_W_m5288+3f55

Followup: MachineOwner
---------

 

There ya go, so you need an updated/fixed version of the m5288.sys driver.

Share this post


Link to post
Share on other sites

Of course it does then seem that you've got an optical drive on a 3rd party SATA controller (a ULI one from what I can tell). You'd be better off if it was on the main one that's part of the motherboard chipset.

 

Optical drives have always had problems working on anything but the main controllers.

Share this post


Link to post
Share on other sites

Do me a favour and locate the m5288.sys file in c:\windows\system32\drivers.

 

Checkout the properties of it and let me know the exact version you're running.

Share this post


Link to post
Share on other sites

Version 6.2.1.8.

this controller is the main chip of the motherbaord, is one M1697 Uli Eletronics, now nvidia.

Edited by Peter

Share this post


Link to post
Share on other sites

Oh right, I thought nvidia had their own sata controller, I didn't realise they were using Uli chips, sorry.

 

You can try the 6.2.2.1 driver from http://www.techpowerup.com/downloads/408 but that's all I can suggest.

 

I've been using an SATA drive all day on an nForce 4 AMD board without any issues so it's not a general SATA thing.

Share this post


Link to post
Share on other sites

not work, updated the driver but the same...

on nero it works good grrr

Edited by Peter

Share this post


Link to post
Share on other sites

If it works with vso, try making ImgBurn use that I/O interface instead (the Patin Couffin one).

 

You'll have to change the HKEY_CURRENT_USER\Software\ImgBurn\IO_Interface registry entry to '4'.

 

Failing that, the only way to try and see what's causing the BSOD is to force the program to make you click 'ok' to every single I/O command it sends - and you'd have to remember which one you last click ok to before it crashed! lol

Share this post


Link to post
Share on other sites

sorry, i may have edited my last post while you were typing your own.

 

Failing that, the only way to try and see what's causing the BSOD is to force the program to make you click 'ok' to every single I/O command it sends - and you'd have to remember which one you last click ok to before it crashed! lol

 

shame the patin couffin thing didn't workout. :(

Share this post


Link to post
Share on other sites

Assuming it crashes straight away, and without a disc in the drive, if you ensure all other drives are disconnected, ok'ing each command one by one wouldn't actually take long - just as a last resort type thing.

 

I for one am certainly interested to see where it falls over.

Share this post


Link to post
Share on other sites

i have tested all config that i can remember, only one solution, unninstall the ULi driver and use the default legacy Microsoft driver...

if you want i can try to discover the command, how can i do that?

Share this post


Link to post
Share on other sites

You would need a special version of the program.

 

If you're sure you're ok to do that, I'll get to work on creating it.

Share this post


Link to post
Share on other sites
do it.

 

:)

This almost sounds painfull. >_<:lol:

 

English is not my first language, but i think i don't have said anything wrong, wright? :thumbup:

Share this post


Link to post
Share on other sites
English is not my first language, but i think i don't have said anything wrong, wright? :thumbup:

No, not at all, I was just joking. :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.