Jump to content
Sign in to follow this  
Falcon

Soft buffer always runs down even at 4x CD-R (600k/s)!

Recommended Posts

L_wtfbuffer.png.png

 

Burning at 600K/s, no other drive activity (used Pause to let it recover - ImgBurn is the only program with a Pause, what a great idea!!!), and it never recovers until "Waiting for buffers to recover"... =(

 

This is a laptop I'm working with, and the HDD (UDMA-33) and CD-R (MW-DMA 2) are on the same channel. Crappy design, I know - when the CD drive is locked up, so is the HDD. I can't avoid it... but it does work fine in Nero. Everything else works kinda slow too, as though the CD drive is totally locking up the IDE channel.

 

Is there a way around this?

 

Hell, at any rate, ImgBurn kicks ass. You know how many times I fired up the other program just to burn an image before I knew about ImgBurn? Now I can burn everything!! :D

Share this post


Link to post
Share on other sites

You might want to remove your controller and let windows reinstall it as mentioned by LUK here to ensure DMA is set right - sometimes Windows XP reports it wrong (or is that reports it right - when it's wrong).

Share this post


Link to post
Share on other sites

I know laptop drives are a little slow but not even being able to keep up with 600k/s is pretty pathetic!

 

Are you sure there's nothing else going on?

 

Burning lots of little files, you'd be better off creating an image and then burning that, rather than doing it on-the-fly. I suspect the random access involved in reading all the little files is just killing things. If you have a lot of memory, you could of course try increasing the buffer to something more useful.

Share this post


Link to post
Share on other sites
You might want to remove your controller and let windows reinstall it as mentioned by LUK here to ensure DMA is set right - sometimes Windows XP reports it wrong (or is that reports it right - when it's wrong).

Or just go to regedit, hklm/system/currentcontrolset/control/class/{4D36E96A-E325-11CE-BFC1-08002BE10318}/0001 and 0002 and make sure MasterDeviceTimingModeAllowed and SlaveDeviceTimingModeAllowed are both set to FFFFFFFF :)

 

Which they are.

 

Nothing else was going on... like I said, I "paused" the burning and the HDD light went off (it blinks in time to the CD drive light as well, highly annoying design) and it never picked back up after resuming. If nothing else, maybe I could ask that when the process is paused, it takes the time to refill the buffers? :D

 

I could create an ISO first, but that would defeat the purpose of using ImgBurn instead of Nero... *shrug* I figure there has to be a better way. I could increase the buffer size - I didn't even know there was that option. I could make a 256mb buffer... hehe. =)

Share this post


Link to post
Share on other sites

'Pause' pauses everything and that's the way it'll be staying I'm afraid.

 

'Buffer Recovery' would have paused just the burn bit and refilled the buffer (assuming you've not disabled it of course), it's not something you need to do manually.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.