Jump to content
Sign in to follow this  
Sailing_Nut

Bootable DVD from ISO problem

Recommended Posts

I tried burning the Windows Vista x86 install DVD from an ISO (legally downloaded from MSDN) onto a DVD+RW.

 

I'm running ImgBurn on Windows Vista x64.

 

The DVD appears to burn properly and the autorun works if I place it in a machine with Windows XP. The problem is that the DVD will not boot. I keep on getting NTLDR Not found when trying to boot the DVD.

 

I have burned the x64 Vista ISO image using Nero (Under XP) and it was bootable.

Share this post


Link to post
Share on other sites

If it was an ISO and you burnt it as an ISO (i.e. using Write mode), ImgBurn is nothing to do with it.

 

The bootable info is just part of the ISO file, it's not anything ImgBurn has to do and as such, burning a bootable ISO is exactly the same as burning *ANY* image file.

 

Burn it and verify it. If that all goes ok, you have to look elsewhere for the issue.

Share this post


Link to post
Share on other sites

You are quite corredt, I checked the DVD in another machine and it is bootable.

 

Must be something f-ed up in my other machine that prevents it from booting from a DVD. It's probably the DVD drive since the mobo came from a machine that I know boots DVDs.

 

Thanks for your response and getting me to check the obvious!

 

Great program! Thanks for the work!

Share this post


Link to post
Share on other sites

There is only one DVD drive in the system and it was selected to boot from before the HD.

 

It turns out it is an old DVD drive that will not read recorded DVDs. Luckily I was able to download the software on CDs and load it that way.

Share this post


Link to post
Share on other sites

I have a similar Problem like you. It's not a DVD it's a CD but the Errormessage ist the same. I even tried another Drive and Computer but it did not change a thing.

 

I'll double check the ISO-Creation now since it's located within the ISO not the burn-process.

 

I've been creating a SP2 Slipstream XP CD with it's own bootloader (xpboot.bin / computerbase [de]) but I have no Nero so I choosed CD BurnerXP Pro 3 to create the ISO. Maybe I need to burn a CD first and then create the ISO of it. Is there a freeware/opensource ISO Creator someone can recommend?

 

--hakre

BTW ImgBurn really does a great Job!

Edited by hakre

Share this post


Link to post
Share on other sites

I might be on the wrong track here but you know that ImgBurn builds .iso images from files don't you ?

Share this post


Link to post
Share on other sites
I might be on the wrong track here but you know that ImgBurn builds .iso images from files don't you ?

That's good to know. I was looking for that! Does it handle Bootable CDs as well?

 

The other CD I directly burned directly (no ISO) with CD BurnerXP Pro 3 didn't work as well (same Errormessage on Boot on 2 Computers), so I need to forget that app completeley I guess.

Share this post


Link to post
Share on other sites

Yes, it handles bootable images and can build bootable CDs as well.

Share this post


Link to post
Share on other sites

Okay, as far as I realized now after burning some more CDs with ImgBurn, there is no problem in burning the bootable CD. But this does not solve my problem (damit ;) ). The CD is booting fine but the bootloader get stuck:

CDBOOT: Couldn't find NTLDR

I'll google for that now.

Share this post


Link to post
Share on other sites
Okay, as far as I realized now after burning some more CDs with ImgBurn, there is no problem in burning the bootable CD. But this does not solve my problem (damit ;) ). The CD is booting fine but the bootloader get stuck:
CDBOOT: Couldn't find NTLDR

I'll google for that now.

Are you using the latest ImgBurn? Inside Advanced tab, Restrictions tab, ISO 9660 tab, did you enable both "Allow Files Without Extensions" and "Don't add ';1' Version Number to Files"? These options are needed for a bootable Windows CD to work. The newest ImgBurn should do this automagically as soon as it detects the I386 folder.

Share this post


Link to post
Share on other sites

Yeah, that was the exact thing my google research did reveal. It's the "Don't add ';1'" option, the other one I had already enabled. The New .iso is even smaller now. I made two screenshots of the settings:

post-6853-1176303113_thumb.png

ISO9660 Settings

Allow Files Without Extensions and Don't Add ';1' Version Number To Files are the important Settings

 

post-6853-1176303143_thumb.png

Bootable Disc Settings

If you need a Boot Image, you can download one here (Note: german language and registration required).

 

I hope this is usefull to somebody else as well.

Edited by hakre

Share this post


Link to post
Share on other sites

Silly me, I didn't force the one to remove the file version, just the one to allow files without extensions :(

 

It's done for the next release.

Share this post


Link to post
Share on other sites

Cool! U-boat jokes...He's about somewhere :boat: ...dammit :shipwrecked:

 

Whatever you do Basil, don't mention the War...

Share this post


Link to post
Share on other sites
Whatever you do Basil, don't mention the War...

Don't get that one...

 

Anyway, wanted to yell out a Big Thanks for ImgBurn which helped me a lot with this u-boot-cd thingy as well as a Big Thanks to the community here for the very fast support - especially mmalves! It so often helps to get a second view on the damn same thing! Need to get my freeware site online again so pplz can download my stuff again as well. :pirate:

Share this post


Link to post
Share on other sites
Personally I'd just extract it from the real xp bootable cd!

 

Does imageburn allow you to extract a boot image from a bootable CD?

 

I'm trying imageburn for the first time and I did not find an option to allow doing this.

I know isobuster can do this, but if imageburn has this option, that would be great.

 

Al

Share this post


Link to post
Share on other sites

'Build' mode -> 'Advanced' tab -> 'Bootable Disc' tab -> 'Create Boot Image'.

 

Just point it at the right drive and click the little blue floppy disk icon.

Share this post


Link to post
Share on other sites
'Build' mode -> 'Advanced' tab -> 'Bootable Disc' tab -> 'Create Boot Image'.

 

Just point it at the right drive and click the little blue floppy disk icon.

 

Duh, I saw that, but was confused because it did not use the file name as it appears on the CD.

The windows CD that I have uses Microsoft Corporation.img. The file name that imageburn was using

confused me and did not realize that it had extracted from CD. Why not use the original name?

 

Also, what is needed for Developer ID under Bootable Disc tab?

 

Thanks, Al

Edited by adric

Share this post


Link to post
Share on other sites

The thing you're looking at is not a file - or at least not in the way you think it is.

 

IsoBuster just displays the bootable image using the 'Developer ID' as the name of the file.

 

i.e. if you told ImgBurn to write a disc using 'Hello' as the Developer ID for a bootable image, IsoBuster would show the bootable image 'file' as being called 'Hello.img' or whatever.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.