Jump to content
Sign in to follow this  
LZeppelin

FLAC problems

Recommended Posts

I am having trouble creating a cd cue file. When I add tracks to the cue file I receive this error:

 

E 17:33:10 ConnectFilters(Source, Sample Grabber) Failed!

E 17:33:10 File Name: C:\Users\Jan\Downloads\1994.01.17 Buenos Aires, Argentina - Robert Plant (FM)\01 - Track 01.flac

E 17:33:10 Reason: No combination of intermediate filters could be found to make the connection.

E 17:33:10 Hint: You may need to install some additional DirectShow filters in order to support files of this type or the file might be corrupt.

 

Any help with this would be greatly appreciated!

 

Thanks,

Jan

Share this post


Link to post
Share on other sites

Thanks for the new version LUK! :thumbup:

 

I was about to ask a similar question when I saw this thread, so I thought I'd post here instead of starting a new thread.

 

I had installed the madFlac directshow filter and am able to play flac files in various media players (WMP, MPC etc.) and also render them in GraphEdit, but when I try to create a Cue File in Imgburn using flac files or load an existing Cue sheet that points to a flac file I get the same error message about "No combination of intermediate filters could be found to make the connection."

 

Anyway, I was just wondering if this is an issue with madFlac or Imgburn?

Share this post


Link to post
Share on other sites

If it won't convert to the specific format required for burning (and enforced by the 'Sample Grabber' filter), there could be an issue. Otherwise the code being used should be exactly what graphedit uses - i.e. 'Intelligent Connect'.

 

I know first hand that the ones I linked to work, so no harm in giving them a try I guess :)

Share this post


Link to post
Share on other sites

Yeah when the flac files rendered in GraphEdit without problem I was surprised (and confused) that ImgBurn couldn't connect to a working set of filters, that's why I thought I'd check with you first rather than report it in the madFlac thread.

 

Those illiminable ones work okay with ImgBurn, but I am wondering why the madFlac one doesn't, as I'd prefer to only have that one installed.

 

Actually I would have preferred if the user was simply able to place the appropriate decoder (flac.exe, lame.exe etc.) in the ImgBurn folder and it be used instead of going the directshow route, but I guess you've ruled that out as an option?

Share this post


Link to post
Share on other sites

lol yeah sorry, I've ruled that one out. It's complicated enough without adding a 3rd decoding method - and one that I assume requires me to decode the files first before I can burn them?

 

Hopefully the madFlac people can figure out whatever the issue is and fix it.

Share this post


Link to post
Share on other sites

I would like to add that the Illiminable and Core FLAC DirectShow filters don't work properly. They drop frames at the end of an audio file. You might not notice unless you are burning a live CD, then you will hear a tick from the missing audio.

 

At the moment the only FLAC filter which works properly, that I can find at least, is this one: http://www.dsp-worx.de/?n=15. It does not drop any frames.

 

MadFLAC may be working in the near future also.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.