Jump to content
Sign in to follow this  
PCPete

Clicks between tracks when using audio session builder

Recommended Posts

G'day all,

When I create a cue list and insert a 2-second (150 frame) gap between tracks, the resulting audio CDs nearly all have clicks either at the end of the previous track, or at the end of the gap.

I master all CD tracks to end on an exact frame boundary so this kind of thing won't happen, and it seems to only happen with IB's cue-based sessions.

Is there something I'm missing? Or should this be formally raised as a bug report? (Hopefully it's just me).

Cheers,

PCPete

Share this post


Link to post
Share on other sites

It should just be silence. Can you examine the CD with a wav editor and see if that is not so?

 

Regards

Share this post


Link to post
Share on other sites
It should just be silence. Can you examine the CD with a wav editor and see if that is not so?

 

Regards

Thanks all for the suggestions, but unfortunately, the gap is not usually part of the audio returned by the ISO9660 track data, it's inserted between the end of one track and before the beginning of the next, sometimes even as subchannel data. The CD's TOC should always return just the track start and end points (in frames), you should never (normally!) get the inter-track gaps returned as track data. The only exception is if the tracks themselves contain silence (which used to be a workaround years ago).

 

I've looked at one CD sector by sector (CDRWIN is excellent for this :thumbup: ) and I think the tracks each end on a frame boundary (I'm currently counting offsets in hex and converting on the fly with pencil and paper, so I could easily be wrong, but I'm getting the same values each time).

 

Clicks and noises like that are generally caused by audio or subchannel data ending on a non-frame boundary - that's why things like cues and metadata (tags) can sometimes (but not always!) cause unwanted transients in CD audio recordings. Since each frame is 1/75th of a second, that equates to roughly 588 samples (or 294 stereo samples). If audio data ends before a frame boundary and metadata is written, click goes the speakers. Good audio software will generally pad out each WAV chunk to frame boundaries when writing to CD, in case the audio data ends "early". I try really hard to do all that manually, so I can use any software at all to burn audio CDs without worrying about RIFF chunk padding and metadata problems.

 

So (I think, but I'm still not sure) there needs to be a way to tell IB to start and end the gap right on a frame boundary.

 

BTW, I've verified all the tracks since the last burn, and all audio data is padded to exact frame boundaries, i.e. all tracks contain whole multiples of 588 samples. So either there's a tiny timing problem when writing the gap, or else something else is "rounding up" the samples past the end of the frame.

 

That doesn't answer every possibility as to why I'm getting these results, but from past experience, it's something like that.

 

I was hoping there would be a simple "don't round or pad" setting in case that was what was causing it.

 

Again, I have a good workaround (manually insert 2 seconds of silence and burn without gaps), but I haven't tested it yet with IB.

 

Keep the great ideas coming, I'm sure I've just missed something blindingly stupidly obvious...

Share this post


Link to post
Share on other sites

If something doesn't fit, ImgBurn only ever pads with 'nothing' (zeroes, digital silence, whatever) so hopefully that would mean it doesn't cause a click?

 

By 'doesn't fit' I'm referring to when DirectShow reports one size for the file and the amount it decodes comes up a little short (in sector terms).

Digital silence is also used for pre/post gaps.

 

Are you burning PCM/WAVE data or decoding stuff?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.