Jump to content
Sign in to follow this  
laserfan

Bad command for Samsung DVD-ROM drive?

Recommended Posts

I attempted a "make iso from disc" for a CD in my Samsung TS-H352A and ImgBurn immediately stuck on "Setting Samsung High Speed Mode..." and after a minute or two of doing nothing that I could see, or placing anything in the log, I aborted (or tried to abort) but nothing happened then either. I finally did CTL-ALT-DEL and tried to kill the imgburn.exe process and that didn't work either. Tried restarting the PC and it wouldn't shut-down normally.

 

Powered-off, and on re-starting the computer the drive is no longer detected in BIOS.

 

Dunno what "Setting Samsung High Speed mode" is supposed to do but I have a dead drive (with a CD stuck inside) as a result. I'll come back here and report if I'm able to revive it; so far no good. :(

Edited by laserfan

Share this post


Link to post
Share on other sites

Sending a command to a drive shouldn't kill it, it should just reject it if it's not supported.

 

I'm not familiar with that particular model but I've seen a fair few other mentioned in the forums and nobody else has come forward with a problem like that.

Share this post


Link to post
Share on other sites

You can paralyze a device with commands (I did this to a HDD connected through VESA-LocalBus-ATAPI on a 486er),

just pull the power plug of the device and have a fresh coffee (ca. 10min).

Then repower the device.

Share this post


Link to post
Share on other sites
Sending a command to a drive shouldn't kill it, it should just reject it if it's not supported. I'm not familiar with that particular model but I've seen a fair few other mentioned in the forums and nobody else has come forward with a problem like that.

Well then I'm the first. At the least I would strongly suggest that you disable as Default the Enable High Speed Mode (Samsung) setting in the Read Settings menu, to save anyone else a similar fate.

 

While I agree that it *shouldn't* have killed my drive, but I am certainly convinced that somehow it *did*. I've built a fair number of computers and worked on many many more and this just did not have the look of coincidence. At least it was a cheap drive, but still... :(

Share this post


Link to post
Share on other sites

Consider it disabled / removed.

 

I'm almost tempted to try and get one of those drives and have a mess around with it.

 

I wonder if mtkflash could be used to salvage it?

 

Anyway, if that command really did kill it, I can only apologise :(

It's been fine on my S203B so it's not like I have / had any reason to think it could be dangerous!

No hard feelings I hope.

Share this post


Link to post
Share on other sites

I do appreciate that you trusted my report and will change the default--this particular model (firmware TS05 btw) must have a thin skin. I've already substituted an old(er) Pio DVR103 in that position so I'm back in business, my main drive being a 109. But I think the Sammy's dead given the BIOS doesn't see it (even keeps the Master from being "seen" if it's plugged-in).

 

No hard feelings--I never contributed to that "other" piece of software of yours I (still) have around here someplace (!) so I'm still ahead of the game I think. :innocent:

Share this post


Link to post
Share on other sites

I would just like to say I have had plenty of Samsung DVD-ROM drives that worked OK 1 minute and Broke the next with various symptoms .

 

No bios detection being one of them, another drive being recognised as Samslung ¬/$ in bios (or similar) to not being able to read DVD,s but Cd's being fine, no power at all on another one clicking noise could go on for a while as I have had about 20 of them go off their DVD -Roms do not last long IMO.

 

That command must also be in the samsung utils they release so If your convinced take it up with Samsung.

Share this post


Link to post
Share on other sites

I appreciate the advice, but the drive's 3 yrs old (almost to the day). Only paid $25+ for it so I'm not losing any sleep.

 

Whatever the "Setting High Speed" command did certainly hung the thing-up somehow, though it is possible if-not-likely that my CTL-ALT-DEL and then shutdown efforts are what actually killed it. In any case I felt I had to post to get LUK's attention, and he has responded exactly the way I'd have expected and hoped (to not make that command a default).

 

If you have ever worked in a (good) restaurant, you know that they APPRECIATE when customers tell them the food tastes bad, so they can pull it and not make anyone sick! :)

Share this post


Link to post
Share on other sites

I would never return a meal and accept another as you never know what they have done to it after you have complained :unsure:

Share this post


Link to post
Share on other sites

Hmmmmmm...ImgBurn does sound a lot like Burger King now doesn't it..... :blink:

Share this post


Link to post
Share on other sites
Hmmmmmm...ImgBurn does sound a lot like Burger King now doesn't it..... :blink:

 

Fried chips contra fried burners... :teehee:

Share this post


Link to post
Share on other sites

Mmmmmm I can almost smell it from here :blink: .

Share this post


Link to post
Share on other sites
If you have ever worked in a (good) restaurant, you know that they APPRECIATE when customers tell them the food tastes bad

Wow, obviously no one here knows what a good restaurant is!!!! :'(

 

Well, I'm sure LUK understands the analogy...

Share this post


Link to post
Share on other sites

lol course we do.

 

McDonalds, Burger King, KFC... they're all good ;)

 

Seriously though, if someone reports that their drive has been permanently damaged by a command ImgBurn issues and I cannot say with 100% certainty that the command is safe then I have a responsibility to ensure it doesn't happen again by removing said command from the program (or at least any automatic calls to it).

Share this post


Link to post
Share on other sites
McDonalds, Burger King, KFC... they're all good ;)
I must say for all my visits to the UK I did enjoy the food! Though I must admit I still find the word "bangers" pretty funny!

 

Thanks again for fretting along with me and my tribulations. I have edited the thread title to look less panicky--there are many things in life which look alot better in the rear-view mirror...

Share this post


Link to post
Share on other sites
I attempted a "make iso from disc" for a CD in my Samsung TS-H352A and ImgBurn immediately stuck on "Setting Samsung High Speed Mode..."

Guess what just happened! :o

I wanted to create an ISO from a CD using the very same model. When the message "Setting Samsung High Speed mode" appeared in the status bar, I heard a "pling!" coming from the drive. ImgBurn froze in that moment and so did XP. Drive dead.

I'm just glad it wasn't the Samsung burner I put the CD in but then again that's the reason why I have 2 separate drives - one for burning, the other one just for reading.

FWIW, the drive was connected as a secondary master to the nForce4 PATA controller (using the MS ATAPI driver) and was flashed with the latest firmware version TS05 (RPC1).

Anyway, I hope this setting gets removed.

Edited by AlphaDog

Share this post


Link to post
Share on other sites

I just noticed that the option is present in the "Read" and "Verify" tab.

Since you have no issues with it, LUK, will you set it to disabled by default in both locations?

Share this post


Link to post
Share on other sites

It's been totally removed from both. The only way to mess with the option now is to do it via the 'Advanced Settings' window.

Share this post


Link to post
Share on other sites
Awesome!

Hopefully this was the last drive that was killed by a simple, innocent check box!

 

 

Total Fluke or my Samsung drives would be broken as well.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.