Jump to content
Sign in to follow this  
MeReadyToRetire

Failed to unlock volume from exclusive access.

Recommended Posts

Occasionally I get the error "Failed to unlock volume from exclusive access. Reason: RequestExclusivity = False." Strangely this only happens with DVD+R DL media. The burn appears to be successful, but is this a bug or a setting that I've missed? Never received this error in previous version.

Share this post


Link to post
Share on other sites

I didn't check for the error before this version.

 

Does it also happen if you use SPTI rather than Patin Couffin for the I/O interface?

Share this post


Link to post
Share on other sites
I didn't check for the error before this version.

 

Does it also happen if you use SPTI rather than Patin Couffin for the I/O interface?

 

Haven't checked that. I've used Patin Couffin ever since I began to use ImageBurn. While on the subject, is there a preference of SPTI over Patin Couffin and why?

Share this post


Link to post
Share on other sites
SPTI gets tested 24/7 (because it's the default), none of the others do!

 

Thanks Lightning UK, changing to SPTI corrected the problem. Bet that could be why I have issues sometimes with DVDFab5 on writing.

Share this post


Link to post
Share on other sites

It's something you'll need to take up with vso-software really, Patin Couffin is their baby.

 

The program won't issue that error (in the log yeah?) if the drive hadn't been successfully locked in the first place.... so I'm not quite sure why it's faling to unlock it again.

 

Are you 100% sure it's just on DL media? I've tried a DVD+RW a few times with verify on and off (just in case) and didn't get the message on my machine but I don't really want to waste DL media trying it!

 

I assume your Patin Couffin layer is up-to-date? (version 1.37.0.0)

Share this post


Link to post
Share on other sites
It's something you'll need to take up with vso-software really, Patin Couffin is their baby.

 

The program won't issue that error (in the log yeah?) if the drive hadn't been successfully locked in the first place.... so I'm not quite sure why it's faling to unlock it again.

 

Are you 100% sure it's just on DL media? I've tried a DVD+RW a few times with verify on and off (just in case) and didn't get the message on my machine but I don't really want to waste DL media trying it!

 

I assume your Patin Couffin layer is up-to-date? (version 1.37.0.0)

 

So far it has only been with DL media using VSO. I used the same media when I switched to SPTI and all worked great. And Patin Couffin is up-to-date. I configured DVDFab5 to use ImgBurn engine for writing now, although I seldom use DVDFab5 for burning.

 

Thanks, you've been a great and very responsive help.

Share this post


Link to post
Share on other sites

I receive this error once in a while. Just today when burning a Sony BD50-RE. Burn was successful, but received error during verify. Then it verified O.K. at the finish.:

 

; //****************************************\\

; ImgBurn Version 2.4.4.0 - Log

; Saturday, 25 April 2009, 20:49:32

; \\****************************************//

;

;

I 14:35:13 ImgBurn Version 2.4.4.0 started!

I 14:35:13 Microsoft Windows XP Media Center Edition (5.1, Build 2600 : Service Pack 3)

I 14:35:13 Total Physical Memory: 1,047,916 KB - Available: 695,348 KB

I 14:35:13 Initialising SPTI...

I 14:35:13 Searching for SCSI / ATAPI devices...

I 14:35:19 Found 1 DVD-ROM, 1 DVD

Share this post


Link to post
Share on other sites

Are you using the latest drivers available for the SATA controller that the drive is connected to? Also please post your Filter Driver Load Order (look in ImgBurn's Tools menu).

 

You might also want to enable FastWrite in the program's settings to speed up burning, but always leave Verify enabled :)

Share this post


Link to post
Share on other sites
Are you using the latest drivers available for the SATA controller that the drive is connected to? Also please post your Filter Driver Load Order (look in ImgBurn's Tools menu).

 

You might also want to enable FastWrite in the program's settings to speed up burning, but always leave Verify enabled :)

 

I looked at the Sony web page that has the latest updates/drivers for my model (VGC-RA820G), but did find any newer SATA drivers. And they only had the original MB bios from 2004.

 

Here is the Filter Driver Load Order:

===============================================

Filter Driver Load Order - ImgBurn v2.4.4.0

===============================================

 

Upper Device Filter: redbook

Upper Class Filter: [None Found]

Device: CD/DVD-ROM Device

Lower Class Filter: PxHelp20

Lower Class Filter: clbstor

Lower Class Filter: Afc

Lower Class Filter: AnyDVD

Lower Device Filter: imapi

 

Filter Name: redbook

File Name: C:\WINDOWS\system32\DRIVERS\redbook.sys

File Version: 5.1.2600.5512 (xpsp.080413-2108)

File Description: Redbook Audio Filter Driver

Product Name: Microsoft

Share this post


Link to post
Share on other sites
Have a look here and see if INF Update Utility and Matrix Storage Manager can be installed on your system :)

 

I read the .txt files for each download. Afraid this stuff is a little over my head. Not sure if I should mess with it.

 

This scared me away as well:

 

"NOTE: File is intended for use by developers/advanced users. If you are not a developer/advanced user, please download INFINST_AUTOL.EXE instead."

 

Anyway, the burn/verification was successful. I just quickly scanned through the disc on a PS3, and no lockups. I'll watch it in full tomorrow night.

Share this post


Link to post
Share on other sites
The text says that you should download this one instead of the other :)

 

Thank you. I'll try and play with it tomorrow. Time for bed now. :teehee:

Share this post


Link to post
Share on other sites
The text says that you should download this one instead of the other :)

 

Installed the above. No glitches or other hangups occurred during installation, or after reboot.

 

Would doing this alone have solved the problem, or are there other steps I need to take?

 

Please let me know if you require any additional information now that this procedure has been accomplished.

Share this post


Link to post
Share on other sites

You could remove PxHelp20, clbstor and Afc if you aren't using software that needs them for burning.

 

Any filter you have in place has the potential to screw up the I/O chain.

Share this post


Link to post
Share on other sites
You could remove PxHelp20, clbstor and Afc if you aren't using software that needs them for burning.

 

Any filter you have in place has the potential to screw up the I/O chain.

 

Thank you.

 

The only other burning programs installed on this particular PC would be Nero (a version that's at least 4 years old) and the OEM (Cyberlink InstantBurn) software that came with the LG GGW-H20L drive.

 

After I do another burn with ImgBurn, I'll see what happens.

Share this post


Link to post
Share on other sites
You could remove PxHelp20, clbstor and Afc if you aren't using software that needs them for burning.

 

Any filter you have in place has the potential to screw up the I/O chain.

 

As a general rule, is it preferable to have only one disc burning software program installed to avoid potential conflicts?

Share this post


Link to post
Share on other sites

If the applications install low level filter drivers - yes, the fewer you have installed the better.

 

Certain filter drivers might not like certain things the previous ones in the list are doing. They get confused and either mess up the I/O chain or just 'hang'.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.