Jump to content

Autoplay Option fails for BD (Win7 Ultimate 64bit)


guru1968
 Share

Recommended Posts

Hi there,

 

I'm having a problem with Windows7, namely the anoying questioning whether to use Live FileSystem or Mastered Mode each time I insert an empty BD (i.e. Blu-Ray); I don't have that problem with empty CDs or DVDs (there automatically ImgBurn is launched, but not for empty BDs).

 

after some minutes of investigation I learned this is due to Windows Autoplay "feature" which is not setup properly for empty BDs...

 

Now the question/support-inquiry:

the "Burn an Image with ImgBurn"/"Built + Burn an Image with ImgBurn" options are only available for empty CDs and empty DVDs, but not for empty BDs (there only: "Burn with Windows Explorer", "no Action" and "Ask each time")!

 

YES - I did check the according options in (Tools -> Settings -> Registry), and YES - I did run ImgBurn as Administrator when applying those settings...

-- didn't help, still the option to use ImgBurn is not available for empty BDs...

 

I am using an licensed (registered/activated/even bought ;-) version of Windows 7 Ultimate 64bit!

 

 

 

I do know how to use Regedit, so if you simply could tell me what keys need to be modified/added, I'm quite happy with that...

 

 

bRgds,

Guru

 

<update>

I guess I figured out what went wrong

- ImgBurn uses wrong registry keys for Blu-Rays:

 

HKCU > Software > Classes > ImgBurn.AutoPlay.1 > shell > HandleBluRayBurningOnArrival_BuildImage/_BurnImage

 

 

...but Windows expects something different:

 

HKCU > Software > Microsoft > Windows > CurrentVersion > Explorer > AutoplayHandlers > HandleBDBurningOnArrival

 

could this be a localisation issue? (I'm using German Win7)

anyways: fixing this does not instantly make ImgBurn available for empty BDs, maybe this requires a reboot; not possible a.t.m - still burning ;-)

 

 

<update2>

renaming the ImgBurn handlers is a bad idea... won't work!

 

what actually did work:

just add the entries for HandleBluRayBurningOnArrival in HandleBDBurningOnArrival

(HKLM > SOFTWARE > Microsoft > Windows > CurrentVersion > Explorer > AutoplayHandlers > EventHandler)

 

don't know why it didn't work with the BluRay keyy but only with the BD key...

- maybe the BluRay key wasn't listed in the UserChosenExecuteHandlers key? (but manually adding it there didn't help as well)

Edited by guru1968
Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.