Jump to content
Sign in to follow this  

Additional info for " Can't Install ImgBurn "

Recommended Posts

Just a note to add, in case others have this problem. Couldn't add to older topic but thought this might be helpful.


For whatever reason, installs perfectly on a Windows XP machine that runs the Online Armor firewall. would start, but no installation window would open. I told OA to allow the program to run, "trust" it, and that it should be allowed to run in "install mode". Didn't make any difference. Uninstalled, cleaned the registry, and tried again to same result. Installed again, successfully. Tried installing again with same result. Turned out both the installer executable and apnstub.exe were listed in running processes, but that's as far as it got. Only after shutting down Online Armor was the process successful. What's odd about this was that it's the only installer I've had this problem with, and earlier versions of ImgBurn didn't have this issue either.


The problem of not being able to write to apnstub.exe only came up when I had started the installation a second time after nothing happened with the first attempt. The apnstub.exe file (which was also already running) was probably locked by the previous instance of the installer process (that was also already running).


12/19 update...


Had the same problem on a laptop that I just bought a DVD burner for. I forgot my own advice to turn off Online Armor first, and of course the installer didn't show up. I went in to Task Manager to end the 2 running processes, SetupImgBurn_2.5.6.0.exe, and ApnStub.exe, before turning off OA and trying the installation again. Well, ApnStub was at the top of the list and as soon as I ended that process, the installer appeared! So that seems to be where the conflict with Online Armor is. ApnStub.exe apparently restarted with ImgBurn once the installation was complete, as I'm looking at it in the Processes tab of Task manager now.


Turns out that apnstub.exe is a utility related to the Ask.com toolbar. On top of that, I'm running Avira Free Antivirus, which ALSO uses an apnstub.exe for multiple update checks. Ubiquitous, isn't it? So the best advice for those using Online Armor and/or Avira is to temporarily disable BOTH of them and stop any apnstub.exe processes already running.


UPDATE: 8 April 2012


Exact same issue with SetupImgBurn_2.5.7.0.exe, and exactly the same solution.

Edited by SavOak

Share this post

Link to post
Share on other sites
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.