Jump to content
BaconBandit

Imgburn cannot load CDrom drivers

Recommended Posts

Hi all,

I ran into an issue with a workstation I have with a built-in CD/DVDrom burner. When I load Imgburn, the app says 

 

Searching for SCSI/ATAPI devices..

CreateFile Failed! -Device: <hardware ID info>

Reason: Access is denied.

...

You need Administrative privileges to use SPTI.

 

I found an older thread noting that this was the desired behavior in Windows XP from Microsoft. Has there been an update to that behavior? Why do I see this on SCSI CD/DVDroms and not USB ones? Any help you can provide would be greatly appreciated.

Share this post


Link to post
Share on other sites

You could try changing the translation layer to ElbyCDIO and see if that helps.

 

Tools --> Settings --> I/O --> Uncheck SPTI - Microsoft and check ElbyCDIO - Elaborate Bytes.  Restart ImgBurn.

 

If that doesn't help, try any of the other I/O options to see if one works.

 

If you want to use SPTI for absolute certain, wait and see if someone else replies because I don't know about your issue.

Share this post


Link to post
Share on other sites

If it's your workstation, run the app as Admin.

Post the full log (everything from the Log window) next time please, it's easier to help if we have all of the info.

Share this post


Link to post
Share on other sites

Thanks for responding!

@dbminter I tried the suggestion, but all the I/O options I tried did not work. Most of them require other apps to be installed to switch modes like that. I tried each one this morning to no avail.

 

@LIGHTNING UK! I snagged the contents of the log file and attached it. The scenario is that this is a shared work machine on a non-Internet connected workstation. If possible, I'd like to avoid giving everyone local admin or the permissions to "run as administrator".

ImgBurn_log.txt

Share this post


Link to post
Share on other sites

Is it actually Windows 8 or is it Windows 10?

Not really sure why it's trying to open the device by drive letter, it should default to 'Device Interface' on that OS. Have you adjusted some settings trying to get it to work? Please revert to defaults.

It shouldn't have a problem using SPTI on Windows 8 / 10, even when you aren't running with admin rights.

Share this post


Link to post
Share on other sites

Sorry about that! I was tinkering with options to see if I could get it to work. I reset the I/O options back to default. The updated log file is attached.

 

The workstation is Windows 10 build 1903 (current patches installed). The line in the logfile that said Win8 threw me, but I figured it was just the driver that the application had access to.

ImgBurn_log.txt

Share this post


Link to post
Share on other sites

That doesn't look like standard Windows behaviour to me, so maybe you've set something in group policy or are running 3rd party software that's blocking access to the drive.

I have no such issue on a Windows 10 workstation with a 'normal' user logged in.

Share this post


Link to post
Share on other sites

I've had issues like this and it's due to a non-standard security setting. Did you harden your Windows security? Maybe it's a group policy? You have to track it down and change it to get it to work. The only other workaround might be to install Virtual Clone Drive since that will ALSO install the ElbyCDIO drivers and you could use that for IMGBurn instead.

Share this post


Link to post
Share on other sites

Thanks all for the responses. I reinstalled the OS and reinstalled all the apps on it. Everything worked without issue. Since I couldn't reproduce this, I'm going to call this "Windows Magic".

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.