Jump to content

ImgBurn now top of context menu?


terrypin
 Share

Recommended Posts

Something odd going on here. If I r-click the 'CD-Drive' entry under My Computer, I'm now seeing 'Read using ImgBurn' as the top entry. Pretty sure it used to be 'Play with PowerDVD'. And I no longer see an entry 'Open with...' which I'm pretty sure was there yesterday.

 

I'll look around, but any idea what can have happened here please, and how I restore normality?

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

OK, thanks. I think there could be two causes behind these problems. First, I think the ImgBurn crashes I've described may have changed file association/context Settings under the Registry tab.

 

I found that under Tools > Settings > Registry most of the following were checked.

 

Shell Extensions

----------------

AutoPlay - Blank CD

AutoPlay - Blank DVD

AutoPlay - Blank HD DVD

AutoPlay - Blank Blu-ray

AutoPlay - CD Audio

AutoPlay - DVD Movie

AutoPlay - HD DVD

AutoPlay - Blu-ray

AudioCD

Drive.CDROM

DVD

Open With

 

Not sure whether these were the installation defaults? Anyway I've now unchecked all but the last, at least until I sort out the main issue of the 'DVD' drive entry.

 

I strongly suspect this arose as a direct result of upgrading the firmware of my DVD Reader/Writer (Blue-Ray, PIONEER BD-ROM BDC-202) from version 1.01 to 1.07

 

It seems it's not actually totally missing, but is in fact that second entry '(NONE) Drive':

http://img66.imageshack.us/img66/8904/filetypes1dp6.jpg

 

The evidence for this is that when I r-clicked the DVD drive entry in My Computer and then clicked 'Play with Power DVD' I got the message:

"This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel."

 

Making the assumption that this had to mean the second entry, I duly added an Action for Power DVD. And now I can play it from the r-click menu. The contents under that now look like this:

http://img237.imageshack.us/img237/9133/filetypes3zz5.jpg

 

I've no idea what that original entry 'find' is. And neither of the two entries can be edited or removed! Nor can I change the inappropriate name 'Drive' to 'DVD RW drive' or something. The only thing I could change was the icon. Also I can't remember what the other contents were. So I would like to get the original one back! The snag with System Restore is that I don't want to mess up that firmware upgrade.

 

I suppose the next thing I'll try is to make a CURRENT registry copy with either System Restore or ERUNT/ERDNT, then try going back a bit. If it screws up, I should be able to get back to where I am right now.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

All those registry entries (apart from Drive.CDROM) are checked by default - and it's always been that way.

 

Are you sure you haven't uninstalled powerdvd or anything?!

 

Each context menu entry is its own unique registry key. Adding another one doesn't touch existing ones.

 

The 'Drive' entry you want to change to 'DVD RW' is an internal windows name, you can't change it and you wouldn't want to.

 

I don't believe there is any problem here. If your powerdvd has mucked up you could just reinstall it to fix the issue.

Link to comment
Share on other sites

I think I was mistaken about both the causes. Neither the ImgBurn crash nor the firmware upgrade are likely to have contributed to my screwed up drive entry. I'd forgotten one other thing I'd done, namely to uninstall AVS DVD Player.

 

This had been showing quirky behaviour and I thought I'd got rid of it last night. But this morning, working on this problem, I noticed I still had references to it in some context menus. It appears to be sort of 'partly uninstalled'. Anway, to cut to the quick, it seems to be responsible for the current issue. As I got it wrong before I hesitate to be 100% sure, but I'm still working on it and the evidence seems strong. But unfortunately right now it seems that I have to keep the darned thing installed, otherwise Autoplay stops working and other consequences! And with AVS it installed, it insists on placing itself at the top of the r-click context menu for the DVD drive. This despite not even being included in the list under File Types > Drive > Advanced as you see:

http://img93.imageshack.us/img93/8084/filetypes4ij6.jpg

 

I've re-populated that from scratch, and have 'Play with Media Player Classic' as the default. (All except VLC work from a r-click; VLC plays the DVD if opened from its own file menu, so maybe I have the entry wrong in File Types.)

 

Ideally I want to remove AVS completely, but each time I've tried has caused problems.

 

Anyway, plainly not an ImgBurn issue, and thanks for your help.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Thought I'd report back with final status to close off the thread.

 

I was right about AVS Player. However I was way off beam trying to get back in shape by hacking that second NONE entry. As I'm sure you realised, that's my main HD Drive icon. Anyway, to cut to the quick, I sacrificed a couple of days' work and did a System Restore. Happily that seems to have got me sorted. Here's a self-explanatory screenshot.

 

http://img155.imageshack.us/img155/3497/fi...essolvedqe8.jpg

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.