Jump to content
Sign in to follow this  
nick800

Issues out of the blue

Recommended Posts

Ok, so I've burned about 50-60 dvd images, all of a sudden a few days ago the burner won't go faster than 2.1. I'm using the same media, burning the same files. My drive is 4x and the discs are 8x. I have always used the MAX speed.

 

I upgraded to newest imgburn

was already at newest firmware

tried different media

increased buffer to 256mb

uninstalled controller

 

it still runs at 2.1x max, and when I move a window around it drops almost instantly down under 1.0x.

 

the ISO's are kept on a separate drive from my OS.

 

what could be going on? And why did it start doing this out of the blue?

Share this post


Link to post
Share on other sites

Although you say you've uninstalled the IDE controller, this is still a DMA issue. (So basically, it didn't work).

 

Moving the window would also consume CPU cycles and that's why you're seeing a drop in the speed - there is even less free for the I/O stuff.

Share this post


Link to post
Share on other sites

Nothing about transfer mode in there?

 

It does vary from bios to bios though so perhaps you don't have such a thing. PC's from people like Dell and that may not have them (incase yours isn't home made).

 

Try the IDE controller thing again. With the entire branch (i.e. controller + the 2 channels) uninstalled, reboot and wait for it to find them all again. Then check what windows thinks DMA is set to by looking at the properties of each 'channel' entry.

Share this post


Link to post
Share on other sites

It is a dell laptop. inspiron 9200, bout a year old.

 

the bios is 7 pages, none of em seem to have anything about transfer mode

 

windows definitly thinks it has DMA mode.

 

primary channel is ultra dma 5

and secondary is ultra dma 2

Share this post


Link to post
Share on other sites
It is a dell laptop. inspiron 9200, bout a year old.

 

the bios is 7 pages, none of em seem to have anything about transfer mode

 

windows definitly thinks it has DMA mode.

 

primary channel is ultra dma 5

and secondary is ultra dma 2

 

do a read test of a disk with dvdinfopro or cdspeed

 

hope that's not a matshieta burner

Edited by chewy

Share this post


Link to post
Share on other sites

open dvd info pro look at the top you'll see RPM pop a DVD in the drive make sure its the drive that Info sees and hit start, check the speed graph. You can set the drive to the actual speed instead of setting it to MAX and see if it helps

Share this post


Link to post
Share on other sites

Keep deleting all IDE controller related stuff until it works!

 

Try installing the latest chipset / ide drivers too.

Share this post


Link to post
Share on other sites

flashed the bios, uninstalled imgburn and xpburner.. still doesn't work.

 

If I buy a new burner will it work or is this an issue outside of the burner?

Share this post


Link to post
Share on other sites

I dont know if you have tried this and i'm presuming you are on XP

 

Go to

 

Start > RIGHT CLICK my Computer > SELECT Properties > Click Hardware > Click Device Manager

 

> Open up IDE ATA/ATAPI Contrllers

 

Double click on Primary and check the Transfer Mode under the Advanced Tab

 

What does Current Transfer Mode Say ?

 

If its set to PIO can you change it to DMA ?

 

Do the same for Secondary controller (depends on where your cd rom is)

post-2424-1138692467_thumb.jpg

Share this post


Link to post
Share on other sites

Ok Just re-read the post and im guessing that you have done what i suggested above

 

Now try this for XP (Not sure for 2000)

 

First create a system restore point

 

Now go to

 

Start > Run

 

Type in regedit and press return

 

Unless confident be careful editing the system registry!

 

Then try the following

 

==========================================================

Re-enable DMA using the Registry Editor

 

Run REGEDIT. Go to the following key:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

 

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. You have to go through these subkeys and check the DriverDesc value until you find the proper IDE channel.

 

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

 

2006-01-19 ? Horst Sch?lke wrote that it is sufficient to empty the content of these values. But you can also delete the values entirely. Windows will automatically recreate them anyway, with new content.

 

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

 

2005-10-24 ? Tom?? Souček wrote, if this doesn't work, check also the dword value MasterDeviceTimingModeAllowed, whose default value is hex 0xFFFFFFFF. If you have a much smaller value, you can try to set it back to its default and reboot for a test.

======================================================

 

 

In the attached pic, my values are in subkey 0001 and 0002

 

What Operating System and Service Pack are you running ?

post-2424-1138693509_thumb.jpg

Share this post


Link to post
Share on other sites

Uninstalling the IDE controller from within Device Manager has the same effect as that - execpt it's easier, cleaner and removes the entire key, not just those reg values.

 

(nick800 claims he's already done/tried that - ARE YOU SURE nick800 ?!)

 

Uninstalling ImgBurn isn't going to help matters, nor is buying a new burner.

Share this post


Link to post
Share on other sites

yea I've done everything, except the regedit, numerous times at this point. The drive say it's running in dma ultra mode 2, but still doesn't burn faster than 2.1 , still has problems reading discs.

 

my os is xp sp1

drive is _NEC nd-6500a

Share this post


Link to post
Share on other sites

I don't think its related at all - but is there any reason why you haven't installed SP2 for xp ?

Share this post


Link to post
Share on other sites
I don't think its related at all - but is there any reason why you haven't installed SP2 for xp ?

 

with possible driver issues you may have hit the nail on the head, the registry tweak might help,

but what would be causing xp to error out the drive so quickly?

Share this post


Link to post
Share on other sites

yea my usb ports won't run at 2.0 when sp2 is installed. I wiped the harddrive and did a fresh install about 6 months ago.

 

Dvd drive stopped working correctly last Sunday.

Share this post


Link to post
Share on other sites
yea my usb ports won't run at 2.0 when sp2 is installed. I wiped the harddrive and did a fresh install about 6 months ago.

 

Dvd drive stopped working correctly last Sunday.

 

 

11/16/2005 the new chipset driver has usb and agp support

and may have to be reloaded after the bios flash

damn rocket science

Edited by chewy

Share this post


Link to post
Share on other sites

See this MS KB Article

 

http://support.microsoft.com/kb/817472/

 

Now if you have uninstalled the drivers or done the reg edit thing that should have worked, failing that have you got a big hammer

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.