Jump to content

Fails to burn DVD ISO with Sony DW-Q58A


CompNetTeach
 Share

Recommended Posts

Might not be a bug, but, some additional drive checking logic is a good idea. Just a heads up for another maintenance task.

 

Sorry I don't have the log to post (ran ImgBurn in portable mode on a guest machine) - I thought I copied it to the flash drive, but got the wrong log. I'll try again when I get a chance to use this particular machine again.

 

I tried to burn a large 4+GB ISO onto DVD-R with a Sony DW-Q58A slimline burner on a Dell laptop. I remember two semesters ago burning some CD ISOs successfully using this machine. However, in trying to burn this to a DVD-R, I am getting "invalid parameter" errors after a prolonged OPC write cycle (maybe the display didn't update, and it was trying to initialize writing the image). Ignoring the error and continuing fails to do anything. This then results in a drive that usually doesn't seem to respond properly afterwards - shutdown & reboot required. Letting ImgBurn try to close the disc may or may not do anthing (drive may be unresponsive). One attempt did result in a closed blank platter - what a wasted coaster!

 

However, it does write to DVD+R with book type DVD-ROM fine (this is my preferred media & setting, however, I don't feel like subsidizing schools more than I have to, which is already too much ...)

 

Since two semesters ago, the drive's firmware has been updated from UYS2 to UYS3. VSO Inspector shows that it only supports Track-At-Once writing (kind of strange for a major manufacturer's drive, even if it is OEMed from Lite-On, a reasonably good drive maker, n'est pas?). If I remember correctly, usually ISO burns are done using Disk-At-Once. The drive previously did write CD-TEXT, but does not do so now - I suspect that this drive did not fully support DAO, and the firmware upgrade disabled it along with whatever else was in the update.

 

When trying other burning software with ISOs using DVD-Rs on the DW-Q58A, mixed results occur. Packeges using the StarBurn engine (which always defaults to TAO) does work. CDBurnerXP Pro crashes at the end of the write - if the ISO was a video, it does play in standalone DVD players.

 

If an ISO write to DVD-R with ImgBurn does indeed attempt to use DAO mode, then some additional checking to see if the drive does support DAO properly should be implemented.

 

What a stupid limitation of tlhe DW-Q58A!

Link to comment
Share on other sites

Open ImgBurn, right click on your Sony and click on 'check for firmware updates' in the drop down menu and see if that helps.

That will not work in the current open version, as it will take you to the old not working page.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.