Jump to content

turning off autoplay with imgburn


sbm
 Share

Recommended Posts

hi,

 

running win xp home edition, imgburn 2.1.0.0

 

during install process, imgburn asked me if i wanted to turn off autoplay (or autorun) in Windows and I foolishly chose "no".

 

i *would* like to turn it off--have tried using the properties tab in windows device manager where u can set individual actions for each type of data on the disk--but does not work. everytime, windows anyway opens up a folder of the files on the CD. i just want it to do *nothing*.

 

can i use imgburn to turn this feature off (without re-installing it)? if so, how?

 

also, is it possible to turn it back on (if for some reason i needed that at a later point?)

 

tx.

Link to comment
Share on other sites

Erm.... I don't recall ever adding an option for autorun/play anything into the installer!

 

The option in ImgBurn is a little different to what you want windows to do, so I'd suggest you leave it enabled.

 

You probably need some sort of autoplay repair tool. Even uninstalling the cdrom devices within Device Manager and then rebooting might work.

 

Windows probably got confused and so is ignoring the autoplay options you've set in the properties of the drivers via my computer / explorer.

Link to comment
Share on other sites

Erm.... I don't recall ever adding an option for autorun/play anything into the installer!

 

The option in ImgBurn is a little different to what you want windows to do, so I'd suggest you leave it enabled.

 

tx for ur reply.

 

what is different between windows autoplay and the imgburn option?

 

the thing is: i don't want windows to do anything at all when i insert a cd. i want to insert it and do whatever i want afterwards, open up imgburn or winamp, etc....

 

i could *swear* that during install, imgburn gave the message: "autoplay can be tricky or unstable and it is recommended to turn it off. would u like to do so?"--words to that effect.

 

if it is not imgburn, then it must be another program but i really don't think so.

 

in any event, i went ahead and disabled it following the advice in the 1st reply in the thread and it works fine.

 

why is that not recommended?

Link to comment
Share on other sites

I don't recommend it because then explorer doesn't notice when the media in your drive changes.

 

AutoPlay is what it does when it finds new media - i.e. play the dvd, open it as a folder in explorer etc.

 

AutoInsert is the whole thing of noticing the media has changed. i.e. if you just look at the drive in my computer, the volume label of said drive will not update when you insert a new disc.

 

VMWare issues the warning you mentioned about AutoInsert being enabled, ImgBurn does not. You must be confusing it with something else.

Link to comment
Share on other sites

Many dvd gurus recommend turning off autoplay to avoid calls/interruptions to the drive during burning programs.

 

I did it also because, as the post said, I want the drive to do nothing until I run a program.

 

The way to do it is to go to your write drive directory (like E:), right click to get Properties, then there is a tab AutoPlay. Select each type of media and how you want the computer to react to it, and press Apply after selecting each one.

 

It might also be a good idea to turn off the XP native CD recording capability (if it's on), which is also there in the drive Properties/Recording.

 

:typing:

Link to comment
Share on other sites

If you had XP PRO you could type gpedit.msc in run box and double click administrative templates , click on system, in right hand pane look for turn off auto play click on it and then enable it for CD Roms etc.

 

I am sure XP Home does not allow this command though.

 

 

You may be able to do it using the registry in xp home

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom.

Double-click the Autorun value, and type 0 for its value

 

If Autorun is not there create new DWORD value name it Autorun and 0 for the value.

 

 

Edit maybe the registry from my xp pro above will not work in Home.

 

As i found this after i typed it.

 

http://www.windowsnetworking.com/kbase/Win...dowsXPHome.html

 

 

 

 

And this http://www.dougknox.com/xp/tips/cd_autoplay_home.htm

Edited by dontasciime
Link to comment
Share on other sites

VMWare issues the warning you mentioned about AutoInsert being enabled, ImgBurn does not. You must be confusing it with something else.

 

That's it you're right. It's VMWare....

 

Sorry about that.

 

"I don't recommend it because then explorer doesn't notice when the media in your drive changes.

AutoPlay is what it does when it finds new media - i.e. play the dvd, open it as a folder in explorer etc.

 

So what if Explorer doesn't notice it? I can just hit refresh and that's that....

 

Or open WinAmp or whatever else and hit "play" for example and off we go....

 

More comments:

Using the regular "The way to do it is to go to your write drive directory (like E:), right click to get Properties, then there is a tab AutoPlay. Select each type of media and how you want the computer to react to it, and press Apply after selecting each one." does not work in a consistent manner. e.g it still opens an explorer window even if I tell Win XP to do nothing.

Perhaps that is the XP native CD recording capability that I *also* need to turn off as mentioned in this thread....

The Tweak is really not for me, sorry guys.

gpedit.msc does not work in Home Edition.

 

I will try to turn off the XP native CD recording capability perhaps but I'm happy with having turned off the autodetect within ImgBurn..... Unless that's a problem, I may just leave it that way.

Edited by sbm
Link to comment
Share on other sites

A window popping open when you insert a blank disk is exactly the behavior that happens when you have the native CD capability activated, and you have the AutoPlay for a blank disc set at Open Writable CD Folder.

 

yes, that was the last bit bugging me after setting all the different types of data actions to "do nothing"....

 

it was still taking that action....

 

i guess i could re-enable the feature within imgburn, and disable the native cd capability....

 

i think i'm fine the way i am right now tho....

Link to comment
Share on other sites

For anybody interessted :

 

To disable the AutoRun & AutoPlay features of Windows XP, while still having Auto Insert Notification enabled, then copy/paste the following text into a new file with a ".reg" extension like e.g. "Disable AutoRun & AutoPlay.reg". Then to merge the keys into the registry, then just double-click on the reg file, and answer "Yes" to the confirmation dialog that pops op and reboot afterwards.

 

Windows Registry Editor Version 5.00

;Disables AutoRun & AutoPlay for CD/DVD drives.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:000000b1

 

To revert back to enabling AutoRun & AutoPlay again, then copy/paste, save and run the following text and reboot afterwards.

 

Windows Registry Editor Version 5.00

;Enables AutoRun & AutoPlay for CD/DVD drives.
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

 

Note: The often recommended suggestion for disabling AutoRun by just modifying the reg key listed underneath this note, will actually do this by disabling Auto Insert Notification, which means that discs aren't refreshed in Windows Explorer anymore, which is something that i personally find very annoying and hence, posted the above solution instead. Also, if preffering a GUI solution instead, then the same can be archived with the Windows XP PowerToy Tweak UI v2.10.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000000"

 

CU, Martin.

Edited by Martin H
Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.