Jump to content
guys

ImgBurn won't run under WINE in Linux Mint 19 (Ubuntu 18.04)

Recommended Posts

I have had Imgburn v2.5.8.0 working fine for a couple of years under WINE v 1.6.2 on Linux Mint 17.3 (based on Ubuntu 14.04).

Recently I installed Mint 19 into a separate partition to dual boot with Mint 17.3. Mint 19 has WINE version 3.0 as the stable default. I installed Imgburn v2.5.8.0 apparently OK but when I started it the transparent splash screen was displayed but then hung - ie it never went on to open the Main and Log Windows. Despite repeated retries I couldn't get round this.

I did manage to get ImgBurn working in the end. I went back to Mint 17.3 and installed ImgBurn in a separate Wine prefix using PlayOnLinux. I set the Windows version to XP and the Wine version to 1.7.25 and checked it all worked - it did. I  also installed Wine version 1.7.25 on Mint 19 using PlayOnLinux (PoL).

Then I just copied the entire Wine Prefix from PoL in Mint 17.3 to the same place in PoL Mint 19. PoL was able to create a Desktop Launcher but when I activated it all that happened was a couple of windows opened but they were just solid grey - no text or graphics.

However I then switched the Wine version for the ImgBurn prefix in PoL to "System" (ie 3.0) and tried again and now Imgburn worked perfectly.

It's a grotty workaround but if like me you really like to use ImgBurn it is a way forward until Wine and PlayOnLinux gets sorted out properly. I have had major problems with other WIndows programs which used to work perfectly but have required a lot of similar skulduggery and fiddling to get to work on Mint 19.

Share this post


Link to post
Share on other sites

×

Important Information

By using this site, you agree to our Terms of Use.