Jump to content

Fatal UI errors at program start

Woolis Beltway

Recommended Posts

On a recommendation, I have downloaded the latest version of ImgBurn (v2.0.0.0). I have Nero v6 and Alcohol 120% installed with one virtual drive and a Lite-On LDW-811S.


Upon startup of ImgBurn, the following error appears and program is aborted on 'OK':


Error reading btnMoveUp->OnClick: Invalid Property Value.


After trying to run ImgBurn again, the error may appear again (or skips to the next error) and program load is again aborted.

A third try usually starts the program without error, although not always.


If ImgBurn is then closed and re-started, the following error appears:


Class TPngSpeedButton not found.


Another start attempt sometimes starts the program without error (or the first error appears again and then a successful load is possible) and for a half hour or so, it can be shut down and restarted without error.


After being closed for a longer period of time, the error cycle will be triggered again on program start (with seemingly random variation in the number and/or order of the errors before ImgBurn loads normally.)


I would think this is a problem with my system as I haven't seen any threads about this. Anyone have any idea what's going on?

Link to comment
Share on other sites

The first thing I?d be looking at is Alcohol 120. Have you tried shutting it down before starting hImgBurn? There?s been a couple of posts recently with people having problems with it.threads



Thank you for the response and the suggestion. (cut to the chase=3rd paragraph)


Just before checking in here to see if there were any clues, I couldn't get ImgBurn to start at all. The same two errors just kept coming up every time I started it, in seemingly random order. I tried it 10-15 times without one successful start. What a weird bug... :geek:


As for Alcohol, it hasn't been running, but after going to disable the virtual drive to find out if that had an effect, I discovered I had forgotten that I had already disabled it a few weeks ago. Apologies for the incorrect system status, but thanks for the heads-up on keeping Alcohol from running with ImgBurn;


Anyway, after thinking hard about what could be interfering with the ImgBurn UI, I looked at all running processes in TaskMgr for UI-tampering apps and immediately noticed the free systray-minimizing/window mgmt app, RBTray ( RBTray Homepage )


I end-tasked RBTray, and (after all those errors and failures to start) ImgBurn started fine. I'm going to wait a while longer and try it a few more times, but after testing it quite a few times with RBTray on and off, I'm pretty sure I found the guilty party... Might have to go back to using TaskSwitchXP....


=EDIT=: End-Task kills RBTray.exe but does not kill RBTray.dll (system hook). An hour later, with RBTray.exe not running, the first error appeared once, but on second try loaded normally. Used Sysinternals Process Explorer and found RBTray.dll active under 'Find Handle or DLL'. Seems less troublesome with the .exe terminated, at least. I'll have to reboot with and without RBTray set to load on startup to test it properly.


I wish I did more thorough system troubleshooting before posting this bug report. Hopefully at least this info will turn out to be useful for somebody else having this problem using ImgBurn and RBTray. Will post again if I find out I'm wrong, but until then, maybe there is someone using RBTray and ImgBurn without issues?


- Woolis (whatchoo talkin bout woolis) Beltway

Edited by Woolis Beltway
Link to comment
Share on other sites


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.