Jump to content

Windows (10,11) ISO not bootable (VMWare?)


Recommended Posts

Hi all,

I tried to create modified Windows 10/11 boot media for use with VMWare Workstation 15. I downloaded the final ISOs for Windows 10 and Windows 11 from Microsoft, they boot and install fine in VMWare 15.

I then unpackerd the ISO to a local folder, added a bunch of files, and used ImageBurn to create a new ISO. I have set the "Advanced" properties for "Bootable Disc" like follows:

Emulation: none
Boot-Image: path to ..\boot\efsboot.com of the unpacked ISO
Platform ID: 80x86
Developer ID: Microsoft Corporation
Load Segment: 07C0
Sectors to load: 8

Nonetheless neither a newly created Windows 10 nor Windows 11 ISO boots any more.

What I noted is that the created ISOs, even if I don't modify any of the ISO contents, but simply "repack" it to test the bootability, that they are slightly smaller than the originals, e.g. for WIndows 10: 5760336 KB (original) vs 5758656 KB (re-cerated).

Am I missing something, or is ImgBurn simply unable to create bootable ISOs for Windows?

Computer used is plain vanilla Windows (Version 10.0.19043.1766), settings on defaults., no antivirus installed. VMWare Workstation 15.

Thnx, Armin.

Here si a log (looks all fine, I guess):

I 10:05:42 Operation Started!
I 10:05:42 Building Image Tree...
I 10:05:48 Checking Directory Depth...
I 10:05:48 Calculating Totals...
I 10:05:48 Preparing Image...
I 10:05:48 Checking Path Length...
I 10:05:48 Contents: 904 Files, 85 Folders
I 10:05:48 Content Type: Operating System Installation
I 10:05:48 Data Type: MODE1/2048
I 10:05:48 File System(s): UDF (1.02) (Bootable)
I 10:05:48 Volume Label: Win10_21H2_German_x64
I 10:05:48 Size: 5.893.152.159 bytes
I 10:05:48 Sectors: 2.877.941
I 10:05:48 Image Size: 5.896.863.744 bytes
I 10:05:48 Image Sectors: 2.879.328
I 10:05:50 Operation Successfully Completed! - Duration: 00:00:07
I 10:05:50 Operation Started!
I 10:05:50 Image Contents: 904 Files, 85 Folders
I 10:05:50 Image Sectors: 2.879.328 (MODE1/2048)
I 10:05:50 Image Size: 5.896.863.744 bytes
I 10:05:50 Image Layer Break Position: 1.439.664
I 10:05:50 Image Single Layer Profile: DVD-R/RW (Media Capacity: 2.297.888)
I 10:05:50 Image Double Layer Profile: DVD+R DL (Min L0: 0, Max L0: 2.086.912, Media Capacity: 4.173.824)
I 10:05:50 Image Volume Identifier: Win10_21H2_German_x64
I 10:05:50 Image Volume Set Identifier: 54DD50B5002BEF55
I 10:05:50 Image Application Identifier: IMGBURN V2.5.8.0 - THE ULTIMATE IMAGE BURNER!
I 10:05:50 Image Implementation Identifier: ImgBurn
I 10:05:50 Image File System(s): UDF (1.02) (Bootable)
I 10:05:50 Destination File: C:\Users\Admin\Documents\ISO\Windows10.iso
I 10:05:50 Destination Free Space: 53.435.854.848 Bytes (52.183.452,00 KiB) (50.960,40 MiB) (49,77 GiB)
I 10:05:50 Destination File System: NTFS
I 10:05:50 File Splitting: Auto
I 10:05:50 Writing Image...
I 10:06:21 Operation Successfully Completed! - Duration: 00:00:31
I 10:06:21 Average Write Rate: 185.763 KiB/s (137.3x) - Maximum Write Rate: 572.755 KiB/s (423.5x)

 

 

Edited by ArminLinder
Link to comment
Share on other sites

I have never successfully managed to create any bootable media with ImgBurn.  What I would do to modify an existing ISO that boots is inject the files with UltraISO, but that's not freeware.

 

What you might have a shot at is taking one of these bootable ISO's, writing it to a flash drive with Rufus, which is freeware, adding the contents you want to the flash drive you've just written, and then imaging that flash drive with the new contents back to a new ISO file.  It should be bootable and contain the files you wanted to add.

 

Link to comment
Share on other sites

You probably need to build it as a UEFI bootable disc, not 80x86 - or make sure your vm supports the older style bios bootable discs (in vm options -> advanced -> firmware type = 'bios').

I'm afraid I've never updated the guides to cover that.

Link to comment
Share on other sites

Hi Lightning,

I did like you said, and had some progress. Now when I boot the VM I get an additional boot message saying

Windows Boot Manager ... unsuccessful

Pointing the VM to the original ISO works, pointing it to an image built with imgBurn (file contents untouched - settings used see attachment) doesn't.

I am willing to spend some time on this issue, but I need your advice to get proper diagnostics set up. To start somewhere ... can you suggest a tool which can dump the ISO boot stucture, so I can compare it with what's in the original ISO?

Best regards from Bavaria, Armin.

 

2022_06_30_09_50_27_.png

Link to comment
Share on other sites

Posted (edited)

Man, you are HERO 🙂

WIth the correct boot image and settings mastering an ISO supporting secure boot works like a charm.

Btw, for those reaching here after me: it turned out that Windows 11 is completely happy witrh a VMware virtual machine.

There is a good article here showing the required settings: Install Windows 11 in a virtual Machine

I used method A on VMWare V16 (Note: it is marked "experimental", the process is not very robust, need to follow the instructions by the book, otherwise it will fail), and Method B (on VMWare V15). B is a bit more manual configuation work, but for me it worked more reliable and gave me more insight into what settings process (A) tries to set automatically.

Note that it has been absolutely unneccessary (though looking very cool ...) to patch the Windows 11 registry ("Labconfig"), Windows 11 installed in VMWare without any strange hacks, the only thing to "patch" was to give the VM sufficient RAM (4G+) before running the install, for some strange reason the automated VMWare V16 settings wizard assigns 2GB even if you choose "Windows 10 + successors" as the target operating system - VMWare should now better by now.

But all this has absolutely nothing to do with the ability to master a bootable ISO using imgBurn.

🙂 Guess dbminter needs to re-adjust his mindset 🙂

Thanks again, Armin.

 

Edited by ArminLinder
Link to comment
Share on other sites

It has been like a decade since I last tried to create a bootable image in ImgBurn.  Plus, if the guide were CORRECT, I'd probably have had better luck... ;)

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.