Jump to content

Filename limit - Number of characters


Recommended Posts

I'm trying to burn a BD-R:

 

HL-DT-ST BD-RE  WH12LS39 1.00 (SATA)
Current Profile: BD-R

Disc Information:
Status: Empty
State of Last Session: Empty
Erasable: No
Free Sectors: 12.219.392
Free Space: 25.025.314.816 bytes
Free Time: 2715:27:17 (MM:SS:FF)
Next Writable Address: 0
MID: CMCMAG-BA5-000
Supported Write Speeds: 2x; 4x; 6x; 8x; 10x

 

...using ImageBurn 2.5.8.0.

Windows 7 - SP1 - 64 bits.

 

My problem is too many files with long names, around 130 characters (+ extension).

I'm aware that the File System ISO9660+UDF is limited to 128 characters, including extension.

 

Searching around, I tried:

Level X - 219 characters

ISO9669:1999 mode

ASCII character set

 

None, nothing worked...  🙁

 

I also tried Data Type MODE2/FORM1/2352

But the Log told me that my media do not support it.

 

So, does anybody know how to increase a little bit that limit of 127 characters?

 

Thanks.

 

 

 

 

Link to comment
Share on other sites

Thank you for your prompt reply.

I've already tried that...

I've tried all combinations...

No way.

 

Do you know other tool that could do that? To allow a little more characters?

Link to comment
Share on other sites

I don't know why UDF wouldn't work as it has a maximum file name length of 256 characters as far as I know.  Then again, it's been so long since I used Windows 7.  Given its age, it may not support UDF 256 character file systems.  Though I would think it would.

Link to comment
Share on other sites

Posted (edited)

I did not burn the BD yet. I'm trusting what the log says, this:

W 11:11:54 UDF File: '\Videos\A very long filename here. I omitted its real name. A very long filename here. I omitted its real name. A very long filename here. I omit' -> 'A very long filename here. I omitted its real name. A very long filename here. I omitted its real name. A very long filename her' (OS Path: F:\Meus documentos\omitted...) bla bla bla
W 11:11:54 UDF File System: 9 folder/file names have been modified due to your current settings.
W 11:11:57 Data type changed to 'MODE1/2048' due to current media.

 

I'm afraid to burn it and get truncated names.

 

 

I duplicate your thoughts: Windows 7 is able to handle long filenames.

The problem is elsewhere.

Edited by Gabarito
Link to comment
Share on other sites

I believe you also have to take into consideration that the "file name" character limitation includes the number of characters in the path the file resides in.  Not entirely sure about that.  How many characters are in the folder path preceding the file name?

 

Also, I saw you mentioned ASCII; did you try Standard character set?  And Allow more than 255 characters in path under the ISO9660 settings?

Link to comment
Share on other sites

Thank you, dbminter, for your patience, trying to solve the problem.

 

Filenames are truncated always at 128 characters, including extension, no matter where they are in.

Below, some screenshots:

 

 

1222650136_ImageBurn-Conf.1.png.123d571d075baa831d325aeb0438f38d.png188981657_ImageBurn-Conf.2.png.0119e29d1c59e2db2b4dc954406c094b.png491254980_ImageBurn-Conf.3.png.a45cab79aebe9c32218dd0211475de64.png2133083055_ImageBurn-Conf.4.png.e5ae0a5394f5137c42e1795989da8dca.png

 

And a part of log text:

1086557145_ImageBurn-Conf.5.png.e7d508d6811a261986c265f3d31f7037.png

 

 

Link to comment
Share on other sites

The only 2 differences in my setup: under UDF, I have Disable Unicode Support checked.  Try changing that and see if it works.  And try changing the UDF Revision from 1.02 to 2.60.

 

If that still fails, try loading the attached ImgBurn job Project IBB file.  It's my defaults that are loaded on every time ImgBurn starts.  Download the attached file, load it as an ImgBurn Project, add the stuff you want to add to it, and see if you have better luck.

Set Default Options.ibb

Link to comment
Share on other sites

Hey! I found out where is the problem!

🙂🙂🙂

 

 

Unicode Support.

If I disable it, I can get much more characters in filenames.

The bad news is to have some extended characters vanishes, overwritten by underscore...

 

But now I know what was happening.

 

🙂

Link to comment
Share on other sites

If you include UDF, the stuff in ISO9660 will never get seen (by anything that supports UDF) - so there's almost no point in changing the ISO9660 options unless it's the only file system you're including on the disc.

Well done for getting it semi working with turning off UDF unicode support.

Link to comment
Share on other sites

24 minutes ago, LIGHTNING UK! said:

If you include UDF, the stuff in ISO9660 will never get seen (by anything that supports UDF) - so there's almost no point in changing the ISO9660 options unless it's the only file system you're including on the disc.

Well done for getting it semi working with turning off UDF unicode support.

 

What is the main difference between ISO9660+JOLIET+UDF and just UDF?

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.