Jump to content
Sign in to follow this  
Adrianvdh

BiDi Mode bugs

Recommended Posts

So, I don't know how long it took you to implement this into the program and how to recreate the universe to make the programs controls and classes be BiDi supported, wow. But there are a few bugs after playing around with the program:

 

I don't think I can list all of them, but just play around with your program and find them :)

 

1. Log and Main form Main Menu control, 'File'; 'View'; 'Mode', etc have not changed to BiDi Right to Left, but the Log's form has, i.e 'Tools'; 'Edit'; 'File', in that order.

 

Main.PNG

 

2. 'Build mode', 'Remaining disc space' label are messed up to unreadable state.

 

3. Tools (etc) -> ISO -> Context menu show on the left hand side not the right, so change it to the right, because it is not correct, it should follow the arrow.

This may vary, but it changed to normal after restarting the program.

 

4. Automatic Write Speed, list view (Details) the columns are not alined correctly, there is a big cap after the 'Write Speed' column.

 

5. Wow, the 'Disc Layout Editor' is really messed up, ListView1 has a cap after the 'Size' column, and the 'Type', 'Date Modified' columns and not show.

Treeview1, Areo items don't cover over the icons as they should,so yeah.

 

ListView2, it all over the place. and image below will explain.

Treeview2 is not effect at all by the BiDi Right to Left, but remains as default.

 

The multiselect is not Areo any more in ListView2

 

Disc%20Layout%20Editor.PNG

 

6. The drop down list for the drives, the format text of the drive is not the same as the format text of the drives in the log, the disc label, etc.

 

7. I think most message boxes have this effect, but on the 'Display Graph Data' button and the message 'There is nothing to display', the explanation mark (!) does not seem to start at the beginning of the sentence, 'You..... !something'

 

MsgBox.PNG

 

8. In the settings, the labels seem to be everywhere, not in the border of group boxes, etc. Checkboxes seem to be in center of group boxes not on the side. Check boxes seem to have something on top of them, in the 'Sounds' tab

 

9. After BiDi is set to default, the Main Menu control seem to "malfunction" and looks well weird:

 

MainMenuSetDefault.PNG

 

This can be caused by going through the modes of ImgBurn.

 

Well, that is all I could find in 10 minutes so, please get these bugs fixed for the next release :)

Edited by Adrianvdh

Share this post


Link to post
Share on other sites

I do nothing with/for BiDi except change a variable the development environment offers me.

 

It's an English application, any other support for languages is a bonus.

Share this post


Link to post
Share on other sites

Where is the BiDi project available for download? And another thing, how many other projects are compiled with imgBurn?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.