Jump to content
Sign in to follow this  
duggy

cant use a 1GB buffer

Recommended Posts

Hi,

 

I've been unable to use a 1GB buffer when writing bluray discs. My PC currently has 32GB ram so I'm pretty sure I'm not out of RAM :)

 

If i lower the buffer to around 800GB it works but I'd like to use 1GB if possible please.

 

The logs dont say anymore than the following, the out of memory info is never added, but i see it via pop-ups (see attachments). 

 
I 20:44:02 ImgBurn Version 2.5.8.0 started!
I 20:44:02 Microsoft Windows 8 Professional x64 Edition (6.2, Build 9200)
I 20:44:02 Total Physical Memory: 33,466,220 KiB  -  Available: 28,099,972 KiB
I 20:44:02 Initialising SPTI...
I 20:44:02 Searching for SCSI / ATAPI devices...
I 20:44:02 -> Drive 1 - Info: ATAPI iHAS124   F CL02 (F:) (SATA)
I 20:44:03 -> Drive 2 - Info: ATAPI iHBS112   2 PL06 (E:) (SATA)
I 20:44:03 Found 1 DVD±RW/RAM and 1 BD-RE!
 
I'm on windows 10 64-bit if it helps, all patched up.

post-12916-0-33828700-1484772854_thumb.png

post-12916-0-87175000-1484772877_thumb.png

Share this post


Link to post
Share on other sites

Just tried with 900Mib buffer and that worked, just cant use the full 1GB.

 

I 20:44:02 ImgBurn Version 2.5.8.0 started!
I 20:44:02 Microsoft Windows 8 Professional x64 Edition (6.2, Build 9200)
I 20:44:02 Total Physical Memory: 33,466,220 KiB  -  Available: 28,099,972 KiB
I 20:44:02 Initialising SPTI...
I 20:44:02 Searching for SCSI / ATAPI devices...
I 20:44:02 -> Drive 1 - Info: ATAPI iHAS124   F CL02 (F:) (SATA)
I 20:44:03 -> Drive 2 - Info: ATAPI iHBS112   2 PL06 (E:) (SATA)
I 20:44:03 Found 1 DVD±RW/RAM and 1 BD-RE!
I 20:54:25 Operation Started!
I 20:54:25 Source File: D:\GA 6.ISO
I 20:54:25 Source File Sectors: 12,004,352 (MODE1/2048)
I 20:54:25 Source File Size: 24,584,912,896 bytes
I 20:54:25 Source File Volume Identifier: GA 6
I 20:54:25 Source File Volume Set Identifier: 4A32A4B200B72BE8
I 20:54:25 Source File Application Identifier: ImgBurn v2.5.8.0
I 20:54:25 Source File Implementation Identifier: ImgBurn
I 20:54:25 Source File File System(s): UDF (1.02)
I 20:54:25 Destination Device: [0:0:0] ATAPI iHBS112   2 PL06 (E:) (SATA)
I 20:54:25 Destination Media Type: BD-R (Disc ID: MEI-RA1-001)
I 20:54:25 Destination Media Supported Write Speeds: 4x, 6x, 8x, 10x, 12x
I 20:54:25 Destination Media Sectors: 12,219,392
I 20:54:25 Write Mode: BD
I 20:54:25 Write Type: DAO
I 20:54:25 Write Speed: 6x
I 20:54:25 Hardware Defect Management Active: No
I 20:54:25 BD-R Verify Not Required: Yes
I 20:54:25 Link Size: Auto
I 20:54:25 Lock Volume: Yes
I 20:54:25 Test Mode: No
I 20:54:25 OPC: Yes
I 20:54:25 BURN-Proof: Enabled
I 20:54:27 Write Speed Successfully Set! - Effective: 26,970 KB/s (6x)
I 20:54:27 Advanced Settings - Force HT: No, Online HT: No, OverSpeed: No, SmartBurn: Yes
I 20:54:27 CD/DVD Life Record Count: 10 - CD/DVD Record Count: 1
I 20:54:27 BD Life Record Count: 13 - BD Record Count: 5
I 20:54:55 Filling Buffer... (900 MiB)
I 20:54:59 Writing LeadIn...
I 20:55:02 Writing Session 1 of 1... (1 Track, LBA: 0 - 12004351)
I 20:55:02 Writing Track 1 of 1... (MODE1/2048, LBA: 0 - 12004351)
Edited by duggy

Share this post


Link to post
Share on other sites

Probably a stupid question, but are you using correct allocation granularity? Expecting 4k where the system actually uses 64k (which it usually does for VirtualAlloc) would explain this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×