Jump to content

ImgBurn Support Forum uses cookies. Read the Privacy Policy for more info. To remove this message, please click the button to the right:    I accept the use of cookies

Photo

[Solved] Suppress Errors?


Forum Rules

Read the Guides forum if you don't know how to do something. :readbook:
If you have a question or a problem, check the FAQ and use the Search to see if you can find the answer for yourself. :lightbulb:
If you're having trouble burning double layer media, read Here.
Still stuck? Create a new thread and describe your issue in detail.
Make sure you include a copy of the program's log in your post. No log = :chair:


  • Please log in to reply
2 replies to this topic

#1 DarkFalc

DarkFalc

    ISF Newbie

  • New Members
  • Pip
  • 2 posts
  • Location:NZ

Posted 16 January 2018 - 04:27 AM

Is there anyway to suppress errors?

 

I am automating the building of an ISO, I finally got the CLI command as I wanted for imgburn.. but... I can't run the command in a batch script unattended because imgburn hangs as it throws an IO error on launch.

I have full admin access on my machine, EXCEPT - domain policy has disabled write to optical disk or USB. This isn't should be an issue as I only want to make an ISO, but imgburn throws errors at start up.

 

These errors can be clicked past, but there doesn't seem to be a way to make my script function without hanging. I have looked for error suppression, but haven't found anything (only warnings).

 

IMGBURN.EXE /MODE BUILD /BUILDOUTPUTMODE IMAGEFILE /SRC "D:\Junk\toDelete" /ROOTFOLDER YES /PRESERVEFULLPATHNAMES NO /RECURSESUBDIRECTORIES YES /INCLUDEHIDDENFILES YES /INCLUDESYSTEMFILES YES /VOLUMELABEL TEST /FILESYSTEM "ISO9660 + UDF" /DEST "D:\Junk\test.iso" /START /CLOSE /NOIMAGEDETAILS

 

Is basically the command I am trying to execute in my batch script (names/paths changed), but it results in this (image attached).

 

Is there a way to do this?

 

Windows 10 Pro x64

ImgBurn 2.5.8.0

Attached Images

  • ImgburnError.PNG

Edited by DarkFalc, 30 January 2018 - 08:11 AM.


#2 LIGHTNING UK!

LIGHTNING UK!

    Author of ImgBurn

  • Admin
  • PipPipPipPipPip
  • 29,437 posts
  • Gender:Male
  • Location:United Kingdom

Posted 16 January 2018 - 05:39 AM

What if you change the i/o interface to one that doesn't exist on your machine? That might allow it to get past that point silently.
Please don't PM me with questions that should be posted in the forum. I won't reply - Especially if you have post count of 0!!!

Replies to posts belong in the forum where everyone can read them. Please don't PM them.

In fact, don't PM me at all unless it's something I've asked to be told about!

Before asking questions, search the forum to see if someone else already has.

Use the FAQ and Guides forums to your advantage. I don't want to have to tell you to read them!

#3 DarkFalc

DarkFalc

    ISF Newbie

  • New Members
  • Pip
  • 2 posts
  • Location:NZ

Posted 16 January 2018 - 08:19 PM

Thanks for the suggestion, genius. At first it looked like it almost was going to work but not quite. The errors were now in the log window rather than blocking error dialogue boxes.. but the build button was greyed out so I couldn't even build the ISO. But after changing to another I/O mode and also disabling all the read error options I could find.. it works! :D

 

Legendary hacking powers admin (bows).

 

Edit 0: I can't see how to mark or edit my original posts title to SOLVED, so I shall leave that to you LUK!

Edit 1: Never mind I figured it out - you have to edit, then select "Use Full Editor"


Edited by DarkFalc, 30 January 2018 - 08:12 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users