Jump to content

External Links


Groundrush
 Share

Recommended Posts

Hi Lightening UK,

Forgive me if this is the wrong place to post this but as in the Beta 1.2.0.4 i am still unable to check for firmware updates, in fact while i have the app' open I'm currently unable to open any link from within the program i.e. visit forum, home page or make a donation.

I'm running Zone Alarm security suite and the fire wall is configured to allow Internet access to ImgBurn and also for it to act as a server. I know last time i contacted you RPC 1 was undergoing a few tweaks but since then I've been unable to access the site via ImgBurn and have to go there or the forum manually.

 

 

Regards......:)

Link to comment
Share on other sites

Hi Lightening UK

I currently have Firefox set as my default browser and rarely use IE except for Microsoft updates. When clicking on any of the links i get nothing, no response. Neither browser opens regardless of what link i chose, i just have the ImgBurn GUI and sub menu.

Cheers in advance.

Link to comment
Share on other sites

in that case, it looks like something has messed up your url opening capabilities. probably because IE isn't your default browser anymore.

 

The api function (ShellExecute) is supposed to invoke the default browser if an URL is passed to it - which is what I'm doing.

 

You need to look at the registry, at 'hkey_classes_root\http\shell\open' and see what it says.

 

As a side note, the links have never (nor the way they're called) been changed since the day they were added.

Link to comment
Share on other sites

Hey, thanks guys i realize that It's probably something I've done to my laptop and not a bug in the system. I've had a look at the registry and found the reference to the key specified, would this cause the problem of not opening the links, this a shot of the registry and does it look right or wrong.

 

reglist7ze.png

 

If this is causing the problem any ideas how to solve the problem. Thanks.

Edited by Groundrush
Link to comment
Share on other sites

Sorry Lightening UK, i have edited the above post and found the correct Key.....forgive my haste. :(

 

 

Just looking at the Reg' entry it looks wrong, i run a version of Portable Firefox from a flash drive (E:) so is this entry incorrect, should the program, the full version be running from ( C:) and not the portable version(E:).....???

Edited by Groundrush
Link to comment
Share on other sites

double click that 'default' entry and then copy its value into the clipboard.

 

Try clicking start -> run and then pasting it in and clicking ok.

Does it work?

 

Paste it here too so I can see what it's doing.

 

Mine says:

 

"C:\Program Files\Internet Explorer\iexplore.exe" -nohome

 

You could always just open IE and tell it to make itself default again via the 'Internet Options' dialog. It's on the 'Programs' tab.

Link to comment
Share on other sites

@ Lightening UK, thanks for the prompt reply. I've set IE back to the default browser and still no luck with any link. The Reg' entry says I'm running my portable Firefox..... E:\FOLDER~2\LOCKER\PORTAB~1\FIREFOX\FIREFOX.EXE -url "%1"

where i know it should be running from my C: drive. Any help in changing the value back to what i should be would be most helpful as this is quite beyond and mere mortal like me :blush:. Also when i paste it into the Run window i get a message up " Windows can not read from the disk, disk may be corrupted, may be using a format not compatible with Windows" or words to that effect.

Edited by Groundrush
Link to comment
Share on other sites

Thanks Lightening UK, did as requested and works fine with IE. I know this is really cheeky but can you point me in the right direction in where to find the path for Firefox so i can do the same, change the command to open Firefox instead of IE.

 

Again many thanks Lightening, LFCrule, Volvo and Shamus for all you help and input. :)

Link to comment
Share on other sites

Thanks Lightening UK, did as requested and works fine with IE. I know this is really cheeky but can you point me in the right direction in where to find the path for Firefox so i can do the same, change the command to open Firefox instead of IE.

Try this:

 

C:\PROGRA~1\MOZILL~1\FIREFOX.EXE -url "%1"

 

 

Funny that it uses the old 8.3 naming thingy but it works.

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.