Jump to content
Sign in to follow this  
tacozip

Trouble burning some wavs

Recommended Posts

When creating Cue files to burn wavs to CD, some waves fail with the following error:

 

ConnectFilters(Source, Sample Grabber) Failed!

Reason: No combination of intermediate filters could be found to make the connection.

Hint: You may need to install some additional DirectShow filters in order to support files of this type or the file might be corrupt.

 

And also:

acmFormatSuggest Failed! - Reason: No device driver present.

 

I can't find the filters that are asked for. Could someone give me a hint?

 

Thanks.

Share this post


Link to post
Share on other sites

What's the format of the WAV files exactly?

 

You can probably use MediaInfo to get it.

 

http://mediainfo.sourceforge.net/

 

The files that fail are 2.822 Kbps, 44.1 KHz, 2 channels, PCM(IEEE) (Float)(Float)

The files that work correctly are 1.411.2 Kbps, 44.1 KHz, 2 channels, PCM (Microsoft)

 

We're getting somewhere. Is there a way to make ImgBurn accept the first format as well?

Share this post


Link to post
Share on other sites

ImgBurn doesn't support individual files, it supports DirectShow and ACM decoding. Those decoding methods support the files - as determined by the filters/drivers installed on your system as a whole.

 

So if you can find a DirectShow filter that supports the PCM(IEE) WAV file, it'll work fine in ImgBurn.

 

Can you open those files in GraphEdit?

Share this post


Link to post
Share on other sites

So if you can find a DirectShow filter that supports the PCM(IEE) WAV file, it'll work fine in ImgBurn.

I've searched and installed a few DirectShow filters from Free-codecs.com, but I keep getting the same error message. I don't know what to look for exactly, anyway.

 

Can you open those files in GraphEdit?

 

I downloaded GraphEditPlus but I can't open wave files in it. What do I use that tool for?

Share this post


Link to post
Share on other sites

In GraphEdit (NOT GraphEditPlus), just click 'File' -> 'Render Media File...' and select your WAV file.

 

I have build 090421 if that makes any difference - probably taken from a Microsoft SDK of some sort.

Share this post


Link to post
Share on other sites

In GraphEdit (NOT GraphEditPlus), just click 'File' -> 'Render Media File...' and select your WAV file.

 

I have build 090421 if that makes any difference - probably taken from a Microsoft SDK of some sort.

 

 

I found the solution. The failing files were saved from Adobe Soundbooth as a 32 bit file. The working files however, were 16 bit WAV files.

Saving the failing files as 16 bit WAVs did the trick.

 

Thanks a lot for your help!

Share this post


Link to post
Share on other sites

It would still be nice to find a DirectShow filter that can handle such files :)

 

Converting them to the correct format was always going to be an option, but it was a workaround and not a real solution (in my opinion anyway).

Share this post


Link to post
Share on other sites

It would still be nice to find a DirectShow filter that can handle such files :)

 

Converting them to the correct format was always going to be an option, but it was a workaround and not a real solution (in my opinion anyway).

 

I agree, but i needed those file on disk urgently. Worarounds are alowed in that case :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.