Jump to content
Sign in to follow this  
Croquet

New Verify Hang in 2.5.1.0

Recommended Posts

I've been using ImgBurn for some time, and have had no problems with it. It's a great program!

 

This new bug in 2.5.1.0 occurs during the verify cycle after burning an audio CD from a Monkey's Audio (.ape) or .flac file. The audio CD plays fine, both in the PC and in a stereo. There doesn't seem to be any problem with the burn itself.

 

It's just the verify: it hangs part way. I click the cancel button after about 20 minutes. Normally a verify takes a minute or two.

 

I've attached a log.

 

- Croquet.

Share this post


Link to post
Share on other sites

According to that log, it didn't even start to verify?!

 

What's written in the status bar at this point?

 

Can you reproduce the error easily?

 

I'm guessing it's stuck on 'Analysing Tracks...' or something similar on your PC. This isn't really due to your source files (but is unique to CD), just the program is probably caught in a loop on a certain track (working out the pregaps) - and that's as much down to the drive as anything.

Share this post


Link to post
Share on other sites

According to that log, it didn't even start to verify?!

 

What's written in the status bar at this point?

 

Can you reproduce the error easily?

 

Actually, that's correct. It hangs while "analyzing" the tracks. In this case, the status message reads: "Analysing tracks...(Session 1, Track 4)" and it hangs at that point.

 

Presumably. On one of the failed verifications (there have been a total of four different failures on different burns) I went back and asked it to do a verify only. That hung in exactly the same way.

 

I could try it again with the latest hang which you have the log for.....

 

OK, I tried verify only with the Audio CD burn you have the log for. Exactly the same result. Same status message (as above).

 

Log attached.

 

- Croquet

img.burn.verify.bug.-.log.2.txt

Share this post


Link to post
Share on other sites

You'd also run into the same issue if you tried to 'Read' that disc.

 

The issue (for you and your drive anyway) is with the code that analyses the tracks for pregaps - and that's shared by both modes (Read/Verify).

 

You *might* capture something useful if you can press F8 to enable I/O debug mode before it gets to a track that it gets stuck on and you leave it running for long enough (but not so long that it's repeating itself 50 million times ;) ).

 

Can I also ask, on the discs you're having this issue with, do any of the tracks actually have any INDEX 0 markers in the CUE file?

Share this post


Link to post
Share on other sites

I have a new build that you're welcome to test if you want to?

 

I dug out an old Samsumg DVD-ROM (with old firmware) and managed to get it stuck in a loop too. I've done what I can to fix it and it no longer gets stuck.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.