Jump to content
Sign in to follow this  
Gubin

using Nimbie + internal DVD on one PC

Recommended Posts

Hello

 

I've installed BSRobots_2.2.0.333 in ImgBurn and it can load and unload discs automatically from Nimbie. That's great. But I'm using on my PC an internal DVD writer as well and it doesn't work. ImgBurn tries to initialise Nimbie which is busy and  I can't open a second Window with ImgBurn in order to use it with my internal DVD. What do I need to change in the settings? Thanks in advance.

p.s. I'm using a batch script for both DVD writers (Nimbie and internal drive) and maybe there is an option to start ImgBurn via command line without the initialisation of the auto loader?

Best Regards

Edited by Gubin

Share this post


Link to post
Share on other sites

Doesn't it just eventually error out and then let you carry on with the devices that have been successfully initialised?

You could load it twice with autoloader support disabled and then enable it in 1 instance.

Share this post


Link to post
Share on other sites
18 hours ago, LIGHTNING UK! said:

Doesn't it just eventually error out and then let you carry on with the devices that have been successfully initialised?

You could load it twice with autoloader support disabled and then enable it in 1 instance.

I'm using a batch script. It opens a new ImgBurn window for each DVD and closes it after the finish. The same script I'm using for the internal DVD. Is there a parameter I could add to enable/disable the initialisation of the auto loader?

for /d %%i in (*.*) do (
"C:\Program Files (x86)\ImgBurn\ImgBurn.exe" /MODE BUILD /BUILDINPUTMODE STANDARD /BUILDOUTPUTMODE DEVICE /SRC "%%i\" /DEST "Z:" /FILESYSTEM "ISO9660 + UDF" /UDFREVISION "1.02" /VOLUMELABEL "%%i" /SPEED 8x /NOIMAGEDETAILS /START /CLOSESUCCESS /EJECT YES /WAITFORMEDIA
)

The Nimbie has the letter Z: and the internal DVD has the letter V:

Share this post


Link to post
Share on other sites

All supported CLI parameters are documented in the Readme.txt file. I don't recall there being one for this purpose.

You could use 'reg' to turn on the autoloader stuff in the registry just before you fire up your autoloader instance of ImgBurn... and disable it in the internal drive script.

HKEY_CURRENT_USER\SOFTWARE\ImgBurn

Set the value of 'IO_EnumerateDevices_AutoLoaders' to 0 or 1.

 

Enable:
REG ADD HKCU\Software\ImgBurn /v IO_EnumerateDevices_AutoLoaders /t REG_DWORD /d 1 /f

Disable:
REG ADD HKCU\Software\ImgBurn /v IO_EnumerateDevices_AutoLoaders /t REG_DWORD /d 0 /f

 

Share this post


Link to post
Share on other sites
On 11/23/2020 at 6:24 PM, LIGHTNING UK! said:

Enable:

REG ADD HKCU\Software\ImgBurn /v IO_EnumerateDevices_AutoLoaders /t REG_DWORD /d 1 /f

Disable:
REG ADD HKCU\Software\ImgBurn /v IO_EnumerateDevices_AutoLoaders /t REG_DWORD /d 0 /f

 

That sounds great, I will check this. Thank you!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.