Jump to content

Cannot see hidden files when I open an ISO file in Linux created by ImgBurn in Windows 10


flexm
 Share

Recommended Posts

I used Linux to create a disk image (.img file) that contains files and folders using dd and rsync. I then used ImgBurn in Windows 10 to convert that img file to a .iso file. I did this because double clicking on the .img file did not result in it opening in Windows 10 unless I used a separate program (OSFMount).

So this .iso file that ImgBurn made DOES open in Windows 10 and I can see all files and folders in it including hidden files and folders.

However, when I use Disk Image Mounter to open the same .iso file in Linux/Ubuntu I cannot see the hidden files and folders.... even with Show Hidden Files enabled in the Caja file explorer.

I used these settings in ImgBurn to create the iso file from my img file:

MODE1/2048

ISO9660 + Joliet + UDF

UDF Revision: 1.02

All of these options are selected:

Preserve Full Pathnames

Recurse Subdirectories

Include Hidden Files

Include System Files

In Advanced > Restrictions I have...

ISO9660... Character Set=DOS

UDF... Disable Unicode Support is NOT selected.

Is my problem something to do with these settings? I made another ISO file from my original .img file using mkisofs in Ubuntu and this time the created iso file DOES show hidden files and folders.

Thank you,

Flex

Link to comment
Share on other sites

Seeing as there’s no image conversion feature in ImgBurn, I’m going to assume you just mounted your img file using that other tool and then simply used Build mode to make a new ISO image.

If the folders show up when you ‘browse’ the ISO in Windows, they must be there. I have no idea why they’re then not visible when doing the same using Ubuntu.

Give each file system a different volume label when you build the ISO and then see which one gets shown by each operating system.
If they both show the same one, it’s must be down to the way it’s parsing the descriptors of said file system.

Link to comment
Share on other sites

Thanks for your help.

Yes I opened the .img file in Windows using a program called OSFMount... that made the folder and files available in Windows file explorer so I could use ImgBurn to build a new ISO file.

The hidden folders are certainly there in the ISO file. They don't show when I use Disk Image Mounter in UBuntu but I can use a mount command from the command line in Ubuntu to show them. So I know how to make the hidden files/folders in the ISO file appear in Ubuntu.

But what I am curious about is why they don't appear when I use right click open-with Disk Image Mounter from the Caja file explorer. It must be something about the settings ImgBurn uses to build the ISO and I am wondering if someone can help me with how to choose the right settings in ImgBurn so that I create an ISO file that can open in Windows, Linux and macOS simply by double clicking on the ISO. I don't want to use any other tools or tricky command line programs.

Cheers.

Link to comment
Share on other sites

Posted (edited)

OK, but can you clarify what you mean by:

"Give each file system a different volume label when you build the ISO and then see which one gets shown by each operating system. If they both show the same one, it’s must be down to the way it’s parsing the descriptors of said file system."

What do you mean "each filesystem"? I used ImgBurn to make an ISO out of an img file containing files and folders. The img file has an NTFS filesystem. The ISO file I made from that using ImgBurn has a UDF filesystem. And this ISO file does not display the hidden files and folders when I open it in Ubuntu with Disk Image Mounter (DIM).

I also remade the ISO file in Ubuntu using mkisofs using this command: 

mkisofs -v -J -l -R -V "ISO-Label" -iso-level 4 -o output-file.iso /img/file/mount/point

This ISO does show the hidden files and folders in Ubuntu when I use DIM and in Windows also. The filesystem of this new ISO file is CDFS. The img file and the two ISO files all have different "labels". When I right click on the hidden files and folders as they are showing in the ISO file in Windows I see from the properties that the "hidden" checkbox is ticked. Yet in either OS I try to open the ISO files in I always have "Show hidden files" enabled.

I have to use this command from Ubuntu to make the first ISO file (UDF filesystem) display its hidden files and folders in Ubuntu:

sudo mount -t udf -o loop,unhide /media/my/file.iso /mnt/ISOFileContents

So maybe Ubuntu does not understand the UDF filesystem properly and that was the wrong setting to choose when building the ISO file in ImgBurn? I'm still googling and trying things but welcome any more ideas!

Maybe DIM does not mount UDF filesystems properly to respect the hidden file attribute? Hence the only way to make them show all their files properly is via mounting manually... or use different settings in ImgBurn. I'm just thinking out loud.

Cheers.

Edited by flexm
Adding Information
Link to comment
Share on other sites

There’s a tab in ImgBurn where you configure the volume labels for whichever file systems you’ve chosen to include. I simply meant to put a different value for each one.

Your mkfsiso command line doesn’t appear to include UDF, so it could well be a problem with the parsing of that file system that’s causing the issue. In which case, try just setting ImgBurn to use ISO9660 + Joliet.

Link to comment
Share on other sites

I rebuilt the ISO file using ImgBurn leaving out UDF support and now the hidden files/folders ARE visible in Caja when I open the ISO file using Disk Image Mounter.

I wish I knew if this was a known limitation of Disk Image Mounter. I'll try and post a bug report.

Thanks for your help!

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.