Jump to content

Minor Bug: Unlock attempted after lock failure


scuzzy
 Share

Recommended Posts

There seems to be a small bugette in V2.2.0.0 ImgBurn's disc-erasing feature : if you select "Tools | Drive | Erase Disc | Quick Erase", but then ImgBurn finds it can't lock the drive for exclusive access, after correctly displaying an error message saying :

DeviceIoControl(FSCTL_LOCK_VOLUME) Failed!

Unable to lock volume for exclusive access

Reason: Access is denied

it then attempts to unlock the volume and of course fails, displaying the message :

DeviceIoControl(FSCTL_UNLOCK_VOLUME) Failed!

Unable to unlock volume from exclusive access.

Reason: The parameter is incorrect.

Presumably ImgBurn forgets that the volume isn't locked when it falls through the error path and gets to the unlock code (it should just skip the unlock ?).

 

I discovered this when I had an audio project all set up to burn to CDRW using a different program, but then remembered I hadn't yet erased the disc after the previous test burn, so decided to fire up ImgBurn to do the erase. The other program presumably had the volume already locked. After cancelling the other program ImgBurn completed the erase successfully.

 

Obviously this will only show up in obscure circumstances (such as when a stupid operator is in charge >_<), but it seemed worth reporting.

Link to comment
Share on other sites

I actually prefer that it still tries to unlock it even if it thinks it failed in the first place.

I have however made it fail silently when it knows the locking failed.

Yep .. that sounds like an excellent strategy - covering all the bases while being nice to the user - sounds like ImgBurn :D

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.