Jump to content

Can't create correct boot CD\DVD


EugeneM
 Share

Recommended Posts

I want create boot disc for Windows XP SP2 (Russian).

What I do incorrectly?

 

Pick "Create image file from files/folders"

Add in Source dir - "I386" and files - WIN51, WIN51IP, win51ip.SP2, BOOTFONT.BIN"

File System - ISO9660 + Joliet

Mark - Recurse subdirectories, Include Hidden and System files

Volume label - WINXP

 

In Advanced/Restrictions:

ISO9660 - Level 1, Character set - Standart, mark all "Allow..." and "Don't add ';1' Version number to files"

Joliet - Level 1, mark "Allow files without extensions" and clear "Add ';1' Version number to files"

 

In Advanced/Bootable Disc:

Mark "Make image bootable"

Emulation type - None

Boot image - correct, taken from original boot disc WinXP and more than once approved

Developer ID - Microsoft Corporation

Load segment - default, 07C0

Sectors to load - 4

 

Program warning me about bootable disc and i agreed to adjust setting.

Image file successfully create, but don't bootable. More precisely, it booting, but ntdetect print out some message and rebooting the comp. Message unreadable since russian distro (and so ntdetect probably don't see bootfont.bin)

 

I'm playing with setting (clear "Allow files without extensions", don't agreed with auto adjust setting for bootable system disc - the result the same.

 

In other program - Nero, UUDS, ImgBUrn 2.3.2.0 - with the same setting all fine.

 

PS. sorry for my bad english

Link to comment
Share on other sites

  • 4 weeks later...

Version 2.4.1.0

If setting, as alway i do,

 

In Advanced/Restrictions:

ISO9660 - Level 1, Character set - Standart

Joliet - Level 1

 

then image right.

 

But program offer change my setting to the next:

ISO9660 - Level X, Character set - ASCII

Joliet - Level X

 

And then, setup program of Windows XP don't recognize disc as correct and ask insert "Windows XP Service Pack2 CD"

Link to comment
Share on other sites

Version 2.4.1.0

If setting, as alway i do,

 

In Advanced/Restrictions:

ISO9660 - Level 1, Character set - Standart

Joliet - Level 1

 

then image right.

 

But program offer change my setting to the next:

ISO9660 - Level X, Character set - ASCII

Joliet - Level X

 

And then, setup program of Windows XP don't recognize disc as correct and ask insert "Windows XP Service Pack2 CD"

 

Make sure that you have "WIN51IP.SP2" file in the root of the cd.

Link to comment
Share on other sites

AFAIK, a real windows install cd only uses ISO9660.

 

If you don't then also select Level X (or at least Level 2), you'll be cropping some of the file names.

 

Likewise, if you don't select the ASCII character set you'll be modifying the file names.

 

EDIT: I've just taken a SP1 image, mounted it, copied the files to my hdd and integrated SP3 RC2 (or whatever it is).

 

It's installed just fine in VMware.

Link to comment
Share on other sites

I find out, that Level 1|X not important. In my distr some files in lower case and with ASCII charset they stay in lower in image. Setup stopping as can't find it.

But with Standart charset file names change to upper case and all ok.

So, may be, change default setting to 'Standart" charset?

Link to comment
Share on other sites

  • 4 weeks later...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.