Jump to content
Sign in to follow this  
NateTut

Pioneer DVR-X152 Not Recognized as Writer in XP

Recommended Posts

Hi;

I have a Pioneer DVR-X152 external USB DVD recorder. I use it with no problems on my Vista laptop at home. I'm trying to use it on my XP box at work and ImgBurn isn't recognizing it as a Writer. Also the built in XP CD/DVD burning doesn't seem to work either.

 

I'm not getting any error messages. The device appears to be OK in the Device Manager. There were no drivers to install on Vista, it worked right out of the box. I did find a firmware upgrade but it didn't recognize the drive either.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Can you see the drive in explorer?

 

Please copy + paste everything from the log window (enable it in the 'View' menu if it's not already visible).

Share this post


Link to post
Share on other sites
Can you see the drive in explorer?

 

Please copy + paste everything from the log window (enable it in the 'View' menu if it's not already visible).

Yes the drive is visible in Explorer and at least CDs are readable in it (I don't have any DVDs that aren't blank with me to test).

 

Here's the stuff from the log. The drive in question is D:

 

I 13:53:21 ImgBurn Version 2.4.1.0 started!

I 13:53:21 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 2)

I 13:53:21 Total Physical Memory: 785,840 KB - Available: 95,196 KB

I 13:53:22 Initialising SPTI...

I 13:53:22 Searching for SCSI / ATAPI devices...

E 13:53:24 CreateFile Failed! - Device: '\\.\CdRom1' (D:)

E 13:53:24 Reason: Access is denied.

E 13:53:27 CreateFile Failed! - Device: '\\.\CdRom2' (E:)

E 13:53:27 Reason: Access is denied.

W 13:53:27 Errors were encountered when trying to access 2 drives.

W 13:53:27 These drives will not be visible in the program.

E 13:53:27 You need Administrative privileges to use SPTI.

W 13:53:27 No devices detected!

 

Edit: Fixed a typo

Edited by NateTut

Share this post


Link to post
Share on other sites

Ok, does that 2nd from last log entry mean anything to you?

 

Are you actually configured to be an admin user on your machine?

 

If you are, it must mean something else has a hold of the drive - typically that's what packet writing software does... InCD and DragToDisc etc.

Share this post


Link to post
Share on other sites
Ok, does that 2nd from last log entry mean anything to you?

 

Are you actually configured to be an admin user on your machine?

 

If you are, it must mean something else has a hold of the drive - typically that's what packet writing software does... InCD and DragToDisc etc.

No I do not have Admin rights, unfortunately. What is "SPTI" and do I need it?

Share this post


Link to post
Share on other sites

It's what the program uses to talk to your drives. It stands for 'SCSI Pass Through Interface'. It's part of Windows but MS locked it down so only Admin users can use it on XP... it's open to everyone on Vista I think.

 

If you can't use SPTI then you'll need to install another I/O interface from the available options:

 

ASPI

ASAPI

SPTI (we already know this doesn't work)

ElbyCDIO

Patin Couffin.

 

You'll still need to be an Admin user to install those though so perhaps you're out of luck?

 

There is one other thing you can try (in order to get SPTI working) and that's detailed in the FAQ. Again, you'll still need to be admin though!

Share this post


Link to post
Share on other sites
It's what the program uses to talk to your drives. It stands for 'SCSI Pass Through Interface'. It's part of Windows but MS locked it down so only Admin users can use it on XP... it's open to everyone on Vista I think.

 

If you can't use SPTI then you'll need to install another I/O interface from the available options:

 

ASPI

ASAPI

SPTI (we already know this doesn't work)

ElbyCDIO

Patin Couffin.

 

You'll still need to be an Admin user to install those though so perhaps you're out of luck?

 

There is one other thing you can try (in order to get SPTI working) and that's detailed in the FAQ. Again, you'll still need to be admin though!

Well thanks for all your help. I've struck with all of the above options. I did find an asapi.dll do you know where that needs to go? I tried it in the ImgBurn directory but that didn't seem to work. Everything else failed because I don't have admin access.

Share this post


Link to post
Share on other sites

Found one other trick. But you need to be admin to set it up. :(

 

In administrator mode, Start, Run, MMC

Console Menu, Add/Remove Snap-in

Add.

Group Policy

(Group Policy will be shown as

Share this post


Link to post
Share on other sites
I did find an asapi.dll do you know where that needs to go? I tried it in the ImgBurn directory but that didn't seem to work. Everything else failed because I don't have admin access.

Use the download page/installers on this page:

 

http://www.imgburn.com/index.php?act=download

 

:)

Share this post


Link to post
Share on other sites

That 'trick' is the one in the FAQ Cynthia :)

 

Basically you're stuck unless you can get admin access of some sorts.

Share this post


Link to post
Share on other sites

Guess it's high time for me to read the FAQ thread. :bag:

Share this post


Link to post
Share on other sites

Yeah! And to lower your "suggestion success rate" BWAHAHAHAHAAHAHAHAH =)):D :D

 

Regards

Share this post


Link to post
Share on other sites

I've spent the best part of 2 hours messing on with a guest account to get access to I/O eg Spti in XP without admin.

 

 

Thought I had it but hit snags

 

Maybe someone else can spot something I may have overlooked.

 

Here's what I tried

 

 

type gpedit.msc in start/run

 

then windows settings / security settings / local policies / security option

 

Enable Device : Restrict CD-ROM access to locally logged-on user only (this works for guest after log off) but you have to have admin rights in the first instance to edit this with gpedit.msc (you can use gpedit without admin but cannot alter this value)

 

Enabling this sort of sets registry value below

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SeCEdit\Reg Values\MACHINE/Software/Microsoft/Windows NT/CurrentVersion/Winlogon/AllocateCDRoms]

"ValueType"=dword:00000001

"DisplayType"=dword:00000000

"DisplayName"="Devices: Restrict CD-ROM access to locally logged-on user only_@scii"

 

 

which I exported to reg file (I stuck @scii at end of description to check if display name altered to make sure I had right key/entry in regedit)

 

Trouble is importing/merging that reg file in with guest account fails as not all of the key is imported and even if it was imported fully that reg key must not be the be all and end all of setting enabled in gpedit) cos even if I reset to disable in my admin account(with gpedit) and then import reg key where value is 1 enabled it does not when logging off and logging on to guest account give me access to CdRom access like setting the value to enabled with secedit (gpedit)

 

 

[edit] maybe guest account is diff to actually creating another user, might try again when I get back from where I'm going.

Share this post


Link to post
Share on other sites

Yeah I know.

 

Still if that reg would have worked it would save admin gpedit to allow cdrom from user(guest etc) but I cannto get reg key to work that way anyways.

 

starburner I believe allows SPTI without admin unless I read it wrong last time I looked. ISO buster mentions it or one of the other ISO tools.

Share this post


Link to post
Share on other sites
Yeah I know.

 

Still if that reg would have worked it would save admin gpedit to allow cdrom from user(guest etc) but I cannto get reg key to work that way anyways.

 

starburner I believe allows SPTI without admin unless I read it wrong last time I looked. ISO buster mentions it or one of the other ISO tools.

I have found a copy of asapi.dll. Does anyone know how I can get it to be used to enable ASAPI?

 

Everything else I have tries I run into the admin rights barrier...

Share this post


Link to post
Share on other sites

I'm sure that whatever it does is just the same thing you've been trying. All these methods require you to be admin to change a setting or install another driver than can then be accessed by (or allow access to) 'normal' users.

 

I have to assume this is a work pc or something and so that's not likely to happen.

 

Course the easiest thing would just be to reset the local admin password via any number of the available dos tools, install the drivers and be done with it!

Share this post


Link to post
Share on other sites

The asapi.dll isn't enough, you need the sys file and/or vxd too and again they both need to be registered properly as an admin user.

Share this post


Link to post
Share on other sites
The asapi.dll isn't enough, you need the sys file and/or vxd too and again they both need to be registered properly as an admin user.

I was afraid of something like that. Thanks for all the help.

Share this post


Link to post
Share on other sites

After messing on a bit more I managed to figure out key to enable SPTI for non ADMIN eg for guest account from a registry entry however You need ADMIN to merge into registry (quicker than going through Gpedit or MMC though) not much good to poster but maybe trick admin into merging:D

 

 

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"allocatecdroms"="1"

 

guest_spti.reg

Share this post


Link to post
Share on other sites

You could try this download that reg file above put it on your dekstop

 

then restart computer and press [F8] to boot into safe mode

 

Choose the Administrator account (has to be this one not the named Admin)

 

then start look for my computer , open my computer then docs and settings your user name /desktop and find the reg file import it then restart

 

 

Just tried it on my guest account with my named Admin passworded and I can now burn using ImgBurn in guest account)

Share this post


Link to post
Share on other sites
You could try this download that reg file above put it on your dekstop

 

then restart computer and press [F8] to boot into safe mode

 

Choose the Administrator account (has to be this one not the named Admin)

 

then start look for my computer , open my computer then docs and settings your user name /desktop and find the reg file import it then restart

 

 

Just tried it on my guest account with my named Admin passworded and I can now burn using ImgBurn in guest account)

Thanks. I will try that.

Share this post


Link to post
Share on other sites
You could try this download that reg file above put it on your dekstop

 

then restart computer and press [F8] to boot into safe mode

 

Choose the Administrator account (has to be this one not the named Admin)

 

then start look for my computer , open my computer then docs and settings your user name /desktop and find the reg file import it then restart

 

 

Just tried it on my guest account with my named Admin passworded and I can now burn using ImgBurn in guest account)

Thanks. I will try that.

Well they're so paranoid here that they have disabled Safe Mode. I'm not even trying to do something bad, I just want to back up my files to DVD! I'm not trying to burn pornos or something

Share this post


Link to post
Share on other sites

download this then use winrar to extract to folder usbpassremover Usb_Pass_Remover

 

The files within folder place(copy to usb pen)(they have to be on root (not in a folder) then from cmd prompt type this (to make getting to cmd prompt easier try the reg file below ( once merged simply right click on usbpassremover folder) and choose Ascii Command) then take notice of the drive letter assigned to usb pen and type o:\syslinux.exe -ma o: [o is the letter assigned to my flash pen yours will be different]

 

ascii_command_prompt_from_folder.reg

 

 

if you can boot from usb you can change admin pass or upgrade your account to Admin status (choose which drive has windows and follow prompts)

 

 

P.s It might have been quicker to just write 1,s 0,s on disc :whistling:

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.