Jump to content

SATA burner doesn't work any more under Win7 x64


Recommended Posts

Recently, my burner has stopped working correctly under my Win7 x64. I can still use it to read discs, but I can't format the RWs, and ImgBurn cannot write the discs any more.


I've noticed several strange things:


- Device Manager lists now my drive as "ATA HL-DT-ST DVDRAM SCSI CdRom Device". IIRC, previously, the real name and brand of the burner was present. Imgburn doesn't "see" the brand either.


- When I try to erase a CR-RW (quick mode), ImgBurn returns immediately, and says that the disc has been erased successfully. But the icon and disc label in Windows Explorer doesn't change (although the original content of the drive seems to be erased as Explorer shows nothing). If I try to eject immediately the disc with ImgBurn's arrow icon or with the Windows context menu, an error occurs. Also, erasing the disc with the Windows wizard doesn't work. I see immediately this error dialog:

There was a problem erasing this disc
The wizard can't finish erasing this disc.  Please try to erase it again.  If the problem continues, there might be a problem on the disc that is preventing you from erasing it.

After that, I have to wait at least 30 seconds before being able to eject the disc, or another error occurs.


- If I insert a blank disc (that doesn't need erasing), ImgBurn accepts to burn it, but without success. Here is the log:

I 13:02:02 ImgBurn Version started!
I 13:02:02 Microsoft Windows 7 Ultimate x64 Edition (6.1, Build 7600)
I 13:02:02 Total Physical Memory: 4,192,436 KB  -  Available: 2,816,852 KB
I 13:02:03 Initialising SPTI...
I 13:02:03 Searching for SCSI / ATAPI devices...
I 13:02:03 -> Drive 1 - Info: ATA HL-DT-ST DVDRAM EL01 (W:) (SATA)
I 13:02:03 Found 1 DVD±RW/RAM!
I 13:02:18 Operation Started!
I 13:02:18 Source File: E:\test.iso
I 13:02:18 Source File Sectors: 339,744 (MODE1/2048)
I 13:02:18 Source File Size: 695,795,712 bytes
I 13:02:18 Source File Volume Identifier: XP.SP3.5512.RTM
I 13:02:18 Source File File System(s): ISO9660 (Bootable), Joliet
I 13:02:18 Destination Device: [0:64:0] ATA HL-DT-ST DVDRAM EL01 (W:) (SATA)
I 13:02:18 Destination Media Type: CD-RW (Disc ID: 97m32s10f, Prodisc Technology Inc.) (Speeds: 10x)
I 13:02:18 Destination Media Sectors: 359,847
I 13:02:18 Write Mode: CD
I 13:02:18 Write Type: SAO
I 13:02:18 Write Speed: 16x
I 13:02:18 Lock Volume: Yes
I 13:02:18 Test Mode: No
I 13:02:18 OPC: No
I 13:02:18 BURN-Proof: Enabled
W 13:02:18 Write Speed Miscompare! - Wanted: 2,822 KB/s (16x), Got: 1,764 KB/s (10x)
I 13:02:19 Filling Buffer... (40 MB)
I 13:02:19 Writing LeadIn...
E 13:02:30 Failed to Write Sectors -150 - -119 - Reason: No Additional Sense Information
I 13:02:30 Writing Sectors...
I 13:02:30 Synchronising Cache...
W 13:02:39 User opted to skip the 'Close Track/Session/Disc' functions.
E 13:02:39 Failed to Write Image!
E 13:02:39 Operation Failed! - Duration: 00:00:20
I 13:02:39 Average Write Rate: N/A - Maximum Write Rate: N/A

Of course, I have tried with several CDs and DVDs, but I have always the same problem.


- Since I have also WinXP (relatively fresh install) on another partition, I have tried to erase and burn a RW with ImgBurn under WinXP: no problem. So, I'm sure that the hardware works well.

Here is the successful log under XP:

I 13:36:14 ImgBurn Version started!
I 13:36:14 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 3)
I 13:36:14 Total Physical Memory: 3,405,928 KB  -  Available: 3,002,480 KB
I 13:36:14 Initialising SPTI...
I 13:36:14 Searching for SCSI / ATAPI devices...
I 13:36:14 -> Drive 1 - Info: HL-DT-ST DVDRAM GH20NS10 EL01 (H:) (ATAPI)
I 13:36:14 Found 1 DVD±RW/RAM!
I 13:36:41 Operation Started!
I 13:36:41 Device: [0:2:0] HL-DT-ST DVDRAM GH20NS10 EL01 (H:) (ATAPI)
I 13:36:41 Media Type: CD-RW (Disc ID: 97m32s10f, Prodisc Technology Inc.) (Speeds: 10x)
I 13:36:41 Quick Erase: Yes
I 13:36:41 Erasing Disc...
I 13:37:03 Operation Successfully Completed! - Duration: 00:00:22
I 13:37:22 Operation Started!
I 13:37:22 Source File: E:\test.iso
I 13:37:22 Source File Sectors: 339,744 (MODE1/2048)
I 13:37:22 Source File Size: 695,795,712 bytes
I 13:37:22 Source File Volume Identifier: XP.SP3.5512.RTM
I 13:37:22 Source File File System(s): ISO9660 (Bootable), Joliet
I 13:37:22 Destination Device: [0:2:0] HL-DT-ST DVDRAM GH20NS10 EL01 (H:) (ATAPI)
I 13:37:22 Destination Media Type: CD-RW (Disc ID: 97m32s10f, Prodisc Technology Inc.) (Speeds: 10x)
I 13:37:22 Destination Media Sectors: 359,847
I 13:37:22 Write Mode: CD
I 13:37:22 Write Type: SAO
I 13:37:22 Write Speed: MAX
I 13:37:22 Lock Volume: Yes
I 13:37:22 Test Mode: No
I 13:37:22 OPC: No
I 13:37:22 BURN-Proof: Enabled
I 13:37:22 Write Speed Successfully Set! - Effective: 1,764 KB/s (10x)
I 13:37:22 Filling Buffer... (40 MB)
I 13:37:23 Writing LeadIn...
I 13:37:39 Writing Session 1 of 1... (1 Track, LBA: 0 - 339743)
I 13:37:39 Writing Track 1 of 1... (MODE1/2048, LBA: 0 - 339743)
I 13:45:07 Synchronising Cache...
I 13:45:18 Exporting Graph Data...
I 13:45:18 Graph Data File: C:\Documents and Settings\rol\Application Data\ImgBurn\Graph Data Files\HL-DT-ST_DVDRAM_GH20NS10_EL01_SATURDAY-OCTOBER-16-2010_1-37_PM_97m32s10f_MAX.ibg
I 13:45:18 Export Successfully Completed!
I 13:45:18 Operation Successfully Completed! - Duration: 00:07:55
I 13:45:18 Average Write Rate: 1,520 KB/s (10.1x) - Maximum Write Rate: 1,538 KB/s (10.3x)


- I have also noticed that when an error occurs, the ImgBurn error message contains usually "no additional sense information". I don't know exactly what that means, but previously, when an error occurred, there was some sense information in the error message.


- I have installed recently the new Intel chipset drivers. Could it be the reason? Unfortunately, I can't find a way to uninstall them. (Uninstalling them with Device Manager has no effect, as they are re-installed automatically after a reboot.)


- Apparently, the drive is still able to read the discs without problem (but I did only a few read tests).


Sorry to post this problem here, as I'm sure that ImgBurn is not responsible of the problem. It's probably something I have installed recently. But what? I've searched the web, but I can't find any good explanation regarding a similar problem, so I guess it's here that I have a chance to get valuable help. Thanks!

Link to comment
Share on other sites

I don't think that drive is even attached to a Intel controller is it?


I've seen 3rd party controllers stick names infront of real device identifiers (JMicron used to do it) but I've never seen it happen on an Intel controller.


Of course if you're 100% positive that the drive IS on an Intel controller, I'd try reinstalling the chipset software from here:




and here:




anyway... your issue is definitely due to drivers (or the controller the drive is attached to) so just keep messing with them until you get it right :)

Link to comment
Share on other sites

Honestly, I don't know if the drive is connected to an Intel controller. I just know that it is connected to the motherboard, and there are several components on the motherboard that require Intel drivers. The motherboard itself is not signed Intel, so I doubt I have to install the Intel Board drivers. Anyway, it is extremely difficult to know exactly the detail of the hardware for this kind of PC (a Medion bought at an Aldi store).


Like you, I'm sure it's a software issue. But how can I instruct Windows to get rid of the drivers I have installed recently? Apparently, it's impossible. Windows says that my hardware is functioning correctly, and that the drivers are up to date. The Roll Back Driver option is greyed out. And Intel doesn't provide an uninstall utility. Dead end?


BTW, I forgot to say that I have CrystalDiskInfo installed. It's a good tool to monitor the hard disk drives temperatures and SMART data. But now, it doesn't recognize my drives any more. It's like I'm having no hard disc at all! I suppose that problem has occurred at the same time than the burner problem, but I'm not sure.

Link to comment
Share on other sites

Yeah! Problem solved. :)


I don't know how I found my way to the "Intel Rapid Storage Technology" (as the Intel download site is a nightmare), but I have installed it (more precisely I've downloaded and installed the file iata96cd.exe), and now ImgBurn works again perfectly, as always. CrystalDiskInfo works also fine now. :)


Thanks for the pointer, LUK!

Link to comment
Share on other sites


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.