Jump to content

ASUS Blu-Ray Writer BW-16D1HT


Recommended Posts

I've never posted a drive review thingy here before, so bear with me.  :)



Unfortunately, I don't really have any graph data because of the nature of the drive destroying rewritable media.  This post is more of a warning for people to be wary of this drive.



I've had 2 of these drives and they both suffered from the same problem of destroying rewritable media.  So, it's not that I just received a bad drive the first time.  It's an inherent design flaw in the drive.



I've thrown about half a dozen Ritek 8x DVD+RW (Disc ID: RICOHJPN-W21-01) at it.  After each write completes in ImgBurn, this drive would render the disc empty.  Verifies never start because the drive is constantly attempting to recognize it.  The drive lights flash infinitely.  Windows will not recognize a disc has been inserted but File Explorer will list the disc as empty.  I tried the same on a Verbatim BD-RE DL. It did the same thing.  So, this drive destroys rewritable media.  I could never fully erase the discs and try again because no drive, even my other Pioneer and ASUS USB, ever recognizes a disc has been inserted. 


I inserted 2 Verbatim BD-RE DL that had been formatted by Windows as giant floppies.  I copied over files to them and on random files, Windows would return the "error" Cannot read from source file or disc.  Immediately selecting Retry resumes the copy.  It did this once on the first disc and twice on the 2nd.  However, the real killer is the files actually written to the media are not written correctly!  I copied over many parts in a chain of a file backup from Macrium Reflect to these discs.  Reflect would load the last file in the chain to get the list of files from the archive.  However, on Verify, the first file would fail to read from the first disc!  It would cause Reflect to Not Respond and eventually return the "error" Verification failure Read error - permission denied.  So, this means the drive wasn't even correctly writing to the BD-RE DL media.  Even after I replaced the destroyed disc with a new one.



This drive definitely is worse than the ASUS USB one I had.  I went with an ASUS internal because of my good experience with the ASUS USB.  However, the internal USB drive appears to be junk.  It destroys rewritable media.  Not just one kind, but at least 2 different disc formats.  So, it seems that all rewritable media would probably suffer.  This isn't a firmware issue, unfortunately, because there are no firmware updates for this model or the model that preceded it.



What few DVD-R and BD-R I burned were apparently fine.  So, WORM media seems to be no problem with this model.  However, since this rewritable issue happened on 2 different samples of this model I received, it's an inherent design flaw in the drive itself.  Because it destroys rewritable media, I cannot recommend this drive.  I can say you shouldn't try it because I've already tried it for you.  :)

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.