Jump to content
Sign in to follow this  
Chala

Unable to lock volume for exclusive access error

Recommended Posts

"Is it crap, or is it Memorex? We'll never tell, and you won't be able to, either."

 

Been that way as long as I can remember. :thumbup:

Share this post


Link to post
Share on other sites
Another program probably something made by M$ Like MP11 or another burning program that maybe installed a service has got a lock on your drive. Check FAQ and sysinternals to find offending program. Then get M$ to fix how vista works.

Are you saying M$ is the problem or the solution? (My vote is for problem, since there are still bugs from XP they never figured out) And get them to fix Vista? Now that's funny. :lol:

 

And I already went through all the FAQs. I have been using sysinternals Process Explorer for quite some time now to fix problems created by M$, so I had tried that even before I looked at the FAQs. I will keep looking, though, and let you know if I discover the offending program.

Share this post


Link to post
Share on other sites

I am also having the exclusive access problem on Vista Home Premium 32-bit, identical to what others have described above.

 

I looked at Process Explorer. The offending process is "System" with PID 4. Not something I can just turn off. Looks like core Vista OS, not a program per se.

 

When I use Roxio, I never have a problem. Roxio appears to know how to handle this. But I really want to use ImgBurn because it allows me to launch jobs from scripts (command-line).

 

Any ideas?

 

f1nkster

Share this post


Link to post
Share on other sites
When I use Roxio, I never have a problem. Roxio appears to know how to handle this.

Yeah, it doesn't even attempt locking the drive, which shows it doesn't care if other programs can interfere with your burn and possibly waste your media.

 

Have you disabled Windows built-in burning sh... stuff?

Share this post


Link to post
Share on other sites

This is how you enable it - so do the opposite to stop it.

 

To enable IMAPI

 

1. Click Start, point to All Programs, point to Administrative Tools, and then click Services.

 

2. Right-click IMAPI CD-Burning COM Service, and then click Properties.

 

3. Set the Startup type to Automatic.

 

4. Click Start to start the service, and then click OK. Note that you may have to log off and then log on for this change to take effect.

Share this post


Link to post
Share on other sites
2. Right-click IMAPI CD-Burning COM Service, and then click Properties.

 

A service with this name does not appear in Services on my system. I have Vista Home Premium 32-bit, SP1. I will search Google and see if I can find something about IMAPI for Vista. Thanks for the tip.

 

f1nkster

Share this post


Link to post
Share on other sites

IMAPI on Vista is not implemented as a service. It is a DLL -- CD burning software can call IMAPI functions as needed. So there is no IMAPI process that runs on Vista like it does on XP, and so I am thinking this is not the problem.

 

I unchecked the exclusive access option in ImgBurn settings and so far all my burns have gone well, all verified successfully. I've only burned 2 DVD+RWs today (one was something I actually wanted to burn, the other was a test). So hopefully my future burns go as well. As long as my burns are successful, I can operate this way.

 

Be nice if the developer could determine a solution for this, but I realize that may be easier said than done.

 

f1nkster

Share this post


Link to post
Share on other sites

There is no solution.

 

Windows either lets ImgBurn lock the drive or it doesn't - and it doesn't when something else is using it.

 

I've no way of finding out what that *something* is (beyond what you've already done) and so all you can do is ignore the warning or tell ImgBurn not to bother locking the drive at all (which is what you seem to have gone for).

Share this post


Link to post
Share on other sites
search for this in task manager wmprph.exe end it if found

http://rapidshare.com/files/113646243/EnableCDBurning.reg

http://rapidshare.com/files/113646241/DisableCDBurning.reg


http://support.microsoft.com/kb/952790


close the vista sidebar


http://msdn.microsoft.com/en-us/library/ms681382.aspx

Share this post


Link to post
Share on other sites

 

I am trying the hotfix in the kb article above first. It describes my problem exactly. I backed up my system as a precaution overnight and just installed the hotfix. It will be a few days before I can confidently say that it worked (or not).

 

The short story on the hotfix is that MS acknowledges a problem where the System process locks the drive and prevents programs from gaining exclusive access. It occurs after the system has been running for at least a few hours, which explains why ImgBurn always worked fine after a reboot, but not later. The problem was introduced with Vista SP1. Roxio has been working fine, but as a previous poster said, it may be that Roxio is not locking the drive. In any case, I'm crossing my fingers...I'll post results in a few days.

 

My apologies for suggesting Lightning UK needed to fix his program.

Share this post


Link to post
Share on other sites

The hotfix has fixed the exclusive access problem -- that is, I can burn DVDs with ImgBurn with the exclusive access option checked and it works fine now, every time.

 

However, I am worried the hotfix may have introduced other problems. I leave the PC running 24x7 and for 2 days straight now since I installed the hotfix, I have sat down to the PC to find it locked up -- screen is asleep (does not wake up), no mouse/kb response, nothing -- I can ping it, but cannot map drives from remote PCs. All I can do is reboot. It is possible it may not be the hotfix, but this behavior is new and I've made no other changes. I am giving it a few more days to see if it persists. If so, I will restore my system backup (without the hotfix) and see if the problem goes away.

Share this post


Link to post
Share on other sites

What is the hotfix number?

 

Do you want the PC to sleep? Go to control panel>power settings> and set it to "never sleep"

Share this post


Link to post
Share on other sites
The hotfix has fixed the exclusive access problem -- that is, I can burn DVDs with ImgBurn with the exclusive access option checked and it works fine now, every time.

 

However, I am worried the hotfix may have introduced other problems. I leave the PC running 24x7 and for 2 days straight now since I installed the hotfix, I have sat down to the PC to find it locked up -- screen is asleep (does not wake up), no mouse/kb response, nothing -- I can ping it, but cannot map drives from remote PCs. All I can do is reboot. It is possible it may not be the hotfix, but this behavior is new and I've made no other changes. I am giving it a few more days to see if it persists. If so, I will restore my system backup (without the hotfix) and see if the problem goes away.

 

I have installed the hotfix, and it has resolved my issue of not being able to lock my drive. ImgBurn runs flawlessly and without incident now.

 

I also leave my laptop on 24/7 (unless I am traveling), and I have had no problems with my computer freezing or locking up. I do not have it set to sleep, but I do have an active screensaver, and the display is set to turn off after a while. Still, no freezing problems. Everything runs normally.

 

The hotfix article doesn't say specifically what it does to fix the problem, but it sounds like you have another program which is now unstable, whether it's the hotfix that caused it or not. I would suggest leaving the hotfix installed, and finding the offending program. It is more than likely a program which was not originally installed on the computer, so I would start with the programs which were installed later. Once you find the offending program, try re-installing it and see if that solves the problem.

 

There is a link in the hotfix article for contacting them regarding problems related to the hotfix, so you could take advantage of that resource as well.

Share this post


Link to post
Share on other sites

It's been over a week now, and my PC has not locked up since my last post. I don't know what caused it. ImgBurn continues to run fine with exclusive access to the drive. So I am happy.

Share this post


Link to post
Share on other sites

Well, M$ didn't exactly fix the problem. Even with the hotfix in place, I have noticed that if I leave my computer on for a couple days, I once again get the Access Denied error. It appears that something in the Vista sidebar takes hold of the cdrom and then still doesn't let go. If I close the sidebar, ImgBurn works fine. There are no gadgets in my sidebar that have anything to do with the cdrom drive, so I don't understand why this happens, but then there are a lot of things that M$ does that I don't understand.

Share this post


Link to post
Share on other sites

I am using Alarm Clock, Battery Monitor, System Control, Volume Control, and Weather Channel. None of them has any reason to access any of the drives.

Share this post


Link to post
Share on other sites

Rlly i have a weird problem about this i have this Windows

 

Windows Vista Ultimate SP1

 

I dowload this Hotfix, because i have da fucking problem with the Volume.

Sometiemes the problem with the volume is resolve! But sometimes the problem come back, i rlly in troubles

ImgBurn Doesnt Works, Nero Doesnt Works.

I use Sony DVD -R

 

Any can help me?

 

I read aaaaaaaal da thread, great thread, but i still have the problem.

 

thnx

Share this post


Link to post
Share on other sites

im on vista x64 bit and i have exact the same problem with the sidebar.

 

When i close the sidebar imgburn runs fine.

 

Its not only imgburn that has this problem InfraRecorder has it 2

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.