Jump to content

ImgBurn_TrackListing file getting some filenames instead of titles, and not all of the Performers


DickN
 Share

Recommended Posts

I have a 64-bit laptop running Windows 7.

I am generating cue files and editing the Track Listing output to make labels.  The audio is in .flac files generated by Audacity.  I tried converting them to .mp3, and it made no difference.

More often than not, the Track Listing file from ImgBurn contains filenames where the titles should be except for the last file or two, and Performer info is missing.

Example:

==========

Pastor Marc Aube, Springfield Assembly of God - 2021.09.05AM Move with Mercy (Lk 18.9-14,36-39; Mt 24.12; 14.14-18; 15.22-24; 9.36; Heb 2.18; Mk 7.24-25; 10.13-15; Col 3.12-13) (71:23:28)

01 - 01-Since Jesus came Into my Heart (03:59:41)
02 - 02-God's Wonderful Peace (06:31:69)
03 - 03-The Only Real Peace (04:49:38)
04 - 04-God is my Refuge (02:44:29)
05 - 05-Offering - Pauline -NCS (01:00:14)
06 - 06-Offertory - The Lord is In This Place (00:55:62)
07 - 07-Missionary Offering - Pauline & Sue -NCS,M9,M10 (00:26:17)
08 - 08-Offertory - The Lord is In This Place (cont) -NCS (05:09:15)
09 - Sermon (45:44:43)
10 - Closing Prayer (02:44:58)

===========

"07-Missionary Offering - Pauline & Sue -NCS,M9,M10" is the file name.

"Missionary Offering - Pauline & Sue" is the title, verified by MP3TAG.

====

When I left the Performer and Title fields blank for Disc, the last two lines of Track Listing were changed thus:

09 - 09-Sermon (45:44:48)
10 - Pastor Marc Aube, Springfield Assembly of God - Closing Prayer (02:44:63)

"Pastor Marc Aube, Springfield Assembly of God" is the Performer for both tracks 09 & 10.

If I pass only the 1st 8 files to ImgBurn, and leave the Disc info blank, I get this:

Unknown - Unknown (25:38:60)

01 - 01-Since Jesus came Into my Heart (03:59:41)
02 - 02-God's Wonderful Peace (06:31:69)
03 - 03-The Only Real Peace (04:49:38)
04 - 04-God is my Refuge (02:44:29)
05 - 05-Offering - Pauline -NCS (01:00:14)
06 - 06-Offertory - The Lord is In This Place (00:55:62)
07 - 07-Missionary Offering - Pauline & Sue -NCS,M9,M10 (00:26:17)
08 - Rod Lambert - Offertory - The Lord is In This Place (cont) (05:09:15)

- DickN

 

 

 

 

 

Link to comment
Share on other sites

When you add one of the problem files to the 'create cue' window and enable the 'Tag' option for CD-TEXT, does it fill out the 2 fields below with the correct info you expect to see?

By design, the individual track performer info is removed if it matches the performer of the disc. That's why your 9 and 10 didn't have it.

If I add someone's album and all the info is filled out everywhere, I want the album name and performer at the top and then all I need are the song names, not the performer and song names. That's duplicating info for no reason.

Link to comment
Share on other sites

  • 2 weeks later...

Sorry about the long delay here - I thought I would get an email when there was a reply since I have Follow Topic enabled.

I always have Tag enabled for CD-TEXT.  Seems if I add one file at a time to the window instead of dragging the whole group, the TrackListing file is correct.   The info shown in the Performer and Title fields is always correct.  Also, the .cue file is never affected by this anomaly, only the TrackListing file..

Edited by DickN
My reply was incomplete.
Link to comment
Share on other sites

So where it says 'Default CD-TEXT (Disc / Track)' down the bottom right of the 'Create CUE' window, you have 'Tag' selected in both drop down boxes?

The only time the track listing would use the file name is if the track's configured CD-TEXT Title and Performer are both empty.

btw... yes, you should/can get an email if a reply is posted in a 'followed' thread - subject to your notification settings, which you can configure here:

https://forum.imgburn.com/index.php?/notifications/options/&type=new_comment

Link to comment
Share on other sites

I've switched to a different CD files folder with 20 files for testing.  I found that the one I'd used for the Original Post sometimes fails to exhibit the problem.  I wonder whether it depends on the order in which Windows passes the files.  I know from experience with my own programming that the files  don't necessarily arrive in the sorted sequence of the folder listing.  The files all have Track# populated in the tags.  I don't know whether ImgBurn sorts a passed list by track# or filename - for me it would be the same.

I had 'Default Disc/Track' set to 'Custom/Tag' since I use our pastor's name and the church for the Disc Performer.  When I set Disc/Track to Tag/Tag and pass a selection of multiple files, the Disk Performer name comes from one of the files (all have the same Album, same as Disk).  This setting change had no effect on the track list portion of ImgBurn_TrackListing.txt except to show our pastor's name as Performer in the last track (since now it doesn't match Disk Performer).  The other tracks showed the filename instead of the Tag info.

Again after the default setting change, if I drag the files individually to the Create CUE File window, the TrackListing file correctly shows the Tag info and no filenames.  This is the same result as with Default = Custom/Tag except that the Disc Performer now comes from the 1st file passed.

 

Link to comment
Share on other sites

Don't worry, the order in which they come through isn't important.

Can you please double check then when you get an incorrect track listing file, clicking on the individual files in the list does indeed display the correct CD-TEXT info in the title/performer boxes. It makes absolutely no sense that the info would display correctly in one place and not the other. They're both reading from the same variables.

If it turns out that it's wrong in both places (but only sometimes), it would mean it's occasionally running into some sort of issue with parsing the file - maybe it's being locked out by some other software on your machine (AV or whatever).

Also, does it matter if you drag+drop the files Vs adding them via the 'browse' box?

I'm assuming no errors are being reported in the Log window as it tries to analyse the files (and extract Tag info) ?

Link to comment
Share on other sites

Ok, I've found the problem and can see why it would sometimes work / not work.

It turns out that the fields aren't populated during the initial analysis phase and are actually populated (refreshed from the file) when you select the track or go to save the actual CUE file. No such population / refresh occurs when just displaying the track listing.

 

Link to comment
Share on other sites

Thanks!  You've given me a workaround.  If I scroll through the file list before I grab the TrackList file it's correct.  I have a 'before' and 'after' TrackList on screen right now.

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.