Jump to content
Sign in to follow this  
ClueLess

Why is Imgburn such a hog?

Recommended Posts

Under Windows 98SE I'm see almost 1/3 of my resources(33% for User and 29% for GDI) being used up. What gives? I can't believe this is necessary. Can't anything be done to lessen the load? If not I'll move on to another solution...

 

That would be ashame because other than that it looks good.

 

Thanks

Share this post


Link to post
Share on other sites

Well Clueless

 

since 98 we have had Millenium, win 2k, win xp, and about to have vista, so your only about 9 years worth of technology behind with that OS .

i dont think ImgBurn is even tested on 98 anymore by LUK or any Beta's.

what specs are the machine your running it on ? CPU, RAM and HDD

curiosity says i have to ask you what happens when you use another burning app regarding use of resources ?

Share this post


Link to post
Share on other sites

To be honest, I've never even thought about it... and I've certainly never measured its usage.

 

I put controls on the various forms via the Borland development environment and just get on with the actual coding.

 

ImgBurn pretty much runs from 1 form with multiple 'panels' on it - one for each mode.

 

Panels get hidden when not in use and made visible when they are (I'm sure you get the idea).

 

Looking at the app under XP etc shows it to start with about 750 ~ 800 GDI objects. I guess that's a handle for every edit box/label etc on every panel of every form - so it looks about right to me.

 

As I've no intention of changing anything (unless it'll take 5 mins and someone tells me exactly what to do!), I guess you'll have to find another solution. Sorry!

Share this post


Link to post
Share on other sites

Have just tested quickly under Virtual PC with Windows 98 and while it does use quite a bit resource wise, it also seems to release these resources nicely on exit. I would imagine that it shouldn't be a problem unless you're also trying to run a lot of other stuff at the same time - which I normally avoid even on XP.

Share this post


Link to post
Share on other sites

Never had a problem myself whilst using Imgburn.

 

Just checked the process log,

Processor using only 7% resources, this while running browser, spyware, virus, firewall etc etc....all whilst burning.

Memory usage only 24,700k

 

No problems to report at all. Only ever had a problem when I tried un-raring once, which I avoid doing now. I tend to hold back on anything intensive when burning anyway.

 

 

Dave.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.